3 Replies Latest reply: Oct 27, 2009 7:30 AM by David Schwartzer
David Schwartzer Level 3 Level 3 (770 points)
I am a fairly new iPhone user syncing to a MacBook Pro running 10.5.8. It seems my syncing of contacts takes an unusually long time. I only have 240 contacts in Address Book and even if I have not made any changes to a contact, iTunes sits on Syncing Contacts for several minutes. Eventually it does move on to Calendar, Notes, etc. but those all go very quickly. The couple of times that the contacts sync quickly it seems like some updates did not actually sync. Something seems wrong.

Any ideas what could be going on or more importantly, how I can correct this slow syncing?

Thanks,


David

13" MacBook Pro & G5 iMac Rev. B., Mac OS X (10.5.8)
  • David Schwartzer Level 3 Level 3 (770 points)
    Here is some additional information on this issue. After a visit to the local Genius Bar today we were able to determine that the problem of the long contact sync time is associated with iTunes trying to sync the contacts with Yahoo. The solution would be to stop that sync process. The problem is we can't figure out how to do that.

    We have unchecked the sync. to Yahoo option in iTunes but it still tries to sync even with that choice unselected. In fact, the Yahoo box opens two times on each sync. If I hit cancel, the contacts sync right away.

    The Apple Genius says the only suggestion he has is to do an archieve & install of the OS. This seems to be a radical alternative.

    I have deleted every preference file I can think of, have reset the iSync software to first sync status and nothing seems to help. I searched these discussion boards and several people have raised this issue but no one seems to have a solution. A search of the Internet has not yielded any results either. I suspect there is a preference file somewhere that I am missing.

    Any suggestions would be appreciated.

    Thanks,


    David
  • BBfromCA Level 1 Level 1 (0 points)
    I had the "slow syncing contacts" issue also. I solved it by doing the following: open iTunes, go to "Edit", "preferences", then click the "Devices" icon, and then click the "Reset Sync History" button.
    I plugged in the iPhone and did a sync with no problems.
  • David Schwartzer Level 3 Level 3 (770 points)
    Upgarding to Snow Leopard seems to have corrected the problem.