Previous 1 11 12 13 14 15 Next 302 Replies Latest reply: Dec 2, 2015 4:23 PM by bjamil - Bel Air MD Go to original post
  • Harrisonbro Level 1 (0 points)
    Andrew, the fix sounds great but I cant get it to work. Using this code:

    cd /Applications/iTunes.app/Contents/MacOS
    sudo mv iTunes iTunesX
    sudo curl http://www.ast.cam.ac.uk/~app26/itunes/iTunes -O
    sudo chmod uog+x iTunes

    I try the last step and the terminal says there is no file or folder called "iTunes" - doesnt line 2 get rid of that file by renaming it to iTunesX? Is the last a typo or might I have done something wrong?

    Cheers.
  • cellist Level 1 (0 points)
    Here is a solution I found on another thread on how to prevent iTunes from launching and playing when hitting pause button on Apple TV remote.

    Re: Apple Remote
    Posted: Sep 23, 2009 1:06 PM in response to: EOS iPhone 3G 7...

    Preferences/security/disable remote. That will disable the remote for anything though. What happens when you close iTunes and use the remote?

    Message was edited by: hexonxonx

    2009 MacBook Pro - 20" Intel iMac - white 32GB iPhone Mac OS X (10.6)
  • jtissen Level 1 (0 points)
    I tried your terminal work around, but now iTunes won't boot up. The play button works do in Spotify now. But my iTunes is dead. Do you have a solution for that? Would help me greatly!
  • dougrb Level 1 (0 points)
    Petition ? They really need to fix this ASAP. It would be awesome if we could get a list of names together from people here, and send Apple a polite message. It would be equally awesome if we could coordinate a time when everybody calls Apple support at the same time to report and complain about this issue. They can't deny their F up forever.

    Doug
  • AllStarMe441 Level 1 (0 points)
    C'mon Apple!!! Make this all better!

    Jake

    "I'm Steve Jobs, and Windows 7 was my idea."
  • boniac Level 1 (0 points)
    I have the same problem. It was better before! How can I reverse this process?
  • Farth Nakur Level 1 (0 points)
    Why is this still not fixed?

    Here's an easy workaround (at least it works for VLC 1.0.2):

    Set QuickTime Player (I have 10.0) to run at log in and leave it running it in the background.
    This doesn't create any windows, and doesn't appear to use any of my system resources.
    My Activity Monitor has it using 0.0% of my CPU...

    I can use my keyboard shortcuts! Woohoo!

    I originally found this..... here:
    http://forums.macrumors.com/showthread.php?t=787472
  • NickPipp Level 1 (0 points)
    Hi guys,
    I was searching to an answer to this problem and reading this thread made me quite upset - especially after using both Windows and Mac for many years and recently making the full switch, finding something so petty and slack of Apple makes me think twice over making the switch.

    I'm not sure if it's the right procedure but I lodged a proper bug report (https://bugreport.apple.com/) detailing the nature of the problem and also referencing the anti-trust-type issues and including a link to this topic. Perhaps others could consider this course as it may finally bring about some recognition and action?

    If anyone wants to see a copy of the report I filed I can send you a PDF.
  • iaoth Level 1 (0 points)
    I filed a bug report at http://radar.apple.com
  • megarow Level 1 (0 points)
    Although not a complete fix, but it's better than messing around anything "complex":

    option + shift + F8 works to pause Spotify without opening iTunes. It works in 10.6.3 with my unibody MacBook.
  • Alejandro85 Level 1 (0 points)
    I struggled to find a way of assigning custom Hotkeys (I'd like a key assigned to pick up/hang up call on Skype too) but for now here are two solutions I found:

    The iTunes/Spotify F8 play/pause hotkey conflict can't be fully resolved but, using:
    Alt (option) + Shift + F8 (play/pause) you can control just Spotify, which is useful. Experiment with it and you'll be able to effectively do what you want within no time at all.

    I also assigned a Keyboard Shortcut to Skype for 'Hang Up' call, using System Preferences. This is a shortcut though, so only works when Skype is the active application (in the foreground).
    Unfortunately, I don't think there is a 'Pick Up' call menu shortcut, necessary to create a keyboard shortcut.

    It's not perfect but it's better than nothing.
    Hope you find this useful.
  • abugintheground Level 1 (0 points)
    I can't say whether or not this works as I'm too busy to try it right now, but I found this when googling:

    http://mdbraber.com/2009/10/21/stop-itunes-from-launching-when-pressing-the-play pause-button-on-your-keyboard-snow-leopard/
  • Erica Keays Level 1 (0 points)
    I agree that this is more of a bug than a feature but I found a work around.
    Using option + shift + (whatever media key you want) seems to affect the application currently in use and not open iTunes.
  • mbrown452 Level 1 (0 points)
    Have Apple seen this thread yet? My only real complaint about my new Macbook - I'd really appreciate it if I could use my media keys without iTunes popping up, as well.

    Tried the script they suggested earlier (http://discussions.apple.com/message.jspa?messageID=10175600#10175600), but now I can't launch iTunes at all! Can anyone suggest how I can get around the problem, perhaps by modifying this script? (I'm no expert at such things, unfortunately).

    Oh well, at least the new Spotify plays local music files as well...
  • mbrown452 Level 1 (0 points)
    Update: Turns out I only ran part of the script, it only renamed iTunes. Pasted in the other half, now it's working fine. Thumbs up to the author!

    Still, Apple need to address this issue, after all they are the ones claiming to be all "open" :P
Previous 1 11 12 13 14 15 Next