Previous 1 16 17 18 19 20 21 Next 302 Replies Latest reply: Dec 2, 2015 4:23 PM by bjamil - Bel Air MD Go to original post
  • bodhirocking Level 1 Level 1

    I solved this issue using the advice from this website.

    You basically have to hex edit the binary of remote control daemon (rcd) which is in /System/Library/CoreServices

     

    http://www.driestone.net/2012/08/10/stopping-the-media-keys-from-launching-itune s/

     

    Now I can use Vox.app and VLC without iTunes messing around!

  • riptide_ Level 1 Level 1

    Perfekt!

     

    This fixed it. It was a bit of a hassle but I got it to work.

    You also have to change the write permissions on the file aswell, but after that I could save the edited file.

     

    I used 0xED to edit and found the bit to delete starting at offset 0701E.

     

    Thanks again for linking to the solution.

  • grocklin Level 1 Level 1

    Hello,

     

    I tried the above solution of editing out the "tell application id "com.apple.iTunes" to launch" line from rcd, but now I see my console giving me this error every 10 seconds:

     

    kernel: proc 1038: load code signature error 2 for file "rcd"

     

    If I try to run rcd from the terminal, it immediately segfaults.

     

    Any idea what's going on?  This happens when I edit out that line using 0xED or using vi.  Did you leave blank space in the line?  Or delete it entirely?

     

    Thanks,

    Gabriel

  • bodhirocking Level 1 Level 1

    I've noticed I'm getting the same error on the console:
    17-11-12 16:43:01,000 kernel[0]: proc 80763: load code signature error 2 for file "rcd"

     

    i don't know how to solve it, but for now my mac has been working as usual without the hassle of iTunes popping out every time I pause the music.

    I you find a solution, please share it with us.
    Regards.
  • grocklin Level 1 Level 1

    As far as I can tell, the hex editing isn't actually doing anything except making the file crash.  If someone figures out how to make it run yet still not load iTunes, that would be ideal, to prevent the system from trying to start rcd every 10 seconds and failing.

     

    It seems to me if the hex editing is only going to make rcd crash, then a better option would be to just remove executable privileges from the same file.  chmod -x rcd.  I think that was an earlier solution posted in the thread before the suggestion of editing the file.  The system will still try to load rcd every 10 seconds though.

  • bodhirocking Level 1 Level 1

    what about disabling code signature check?

    there a response for this issue in AskDifferent:

     

    http://apple.stackexchange.com/questions/64408/can-you-disable-a-code-signature- check

  • grocklin Level 1 Level 1

    Er, as far as I can tell, they couldn't actually figure out how to do it for just the rcd file in that thread, right?  It seems not ideal to globally turn off signature checking..

  • bodhirocking Level 1 Level 1

    Well since the rcd got corrupted or can't be launch because of codesigning issues, we can disable the launch request for the app using:

     

    launchctl unload -w /System/Library/LaunchAgents/com.apple.rcd.plist

     

    I got this terminal command from: http://gavinroy.com/disabling-default-itunes-launch-behavior-with

     

    Now the console is not showing the error anymore. I still don't know if this setting will remain after a reboot, I always leave my mac in sleep mode.

     

    I Hope this will be helpful for you all. Regards

  • grocklin Level 1 Level 1

    Great!  This seems to work for me, and seems to remain in effect over reboots.

  • cpaugh Level 1 Level 1

    Worked for me too.  Awesome, I've been struggling with this for awhile now.  Thanks

  • Classee Level 1 Level 1

    Thanks, absolutely brilliant.

     

    Finally I can launch iTunes when I want, not when my Mac want!

  • tfoggo Level 1 Level 1

    Nice one.  Simple to do and works well.  Many thanks.

  • WebsterNYC Level 1 Level 1

    I tried the command described above:

    launchctl unload -w /System/Library/LaunchAgents/com.apple.rcd.plist

     

    iTunes no longer launches when I use the remote, but now iTunes doesn't respond at all to the remote.

     

    I tried the terminal command to revert back to the prior state: launchctl load -w /System/Library/LaunchAgents/com.apple.rcd.plist

     

    But the problem remains.

     

    Amazing how such a simple problem is so difficult to resolve. You'd think only one active application at a time would respond to the remote, but apparently there is no easy way to control this????

     

    Thanks for any help from the gurus out there.

  • melencap Level 1 Level 1

    THE FIX:

    Once the iPhone is connected it should appear in iTunes and perform an automatic sync. Tap on the iPhone box that is located in the top left. The "summary page" will show information on the user’s iPhone. Scroll to the bottom of the Summary screen and uncheck Automatically sync when this iPhone is connected. Once this box is unselected choose Apply in the bottom right. As soon as the new setting is applied, whenever that device is connected it will not launch iTunes and begin an automatic sync.

  • plentyofpaper Level 1 Level 1

    I just found a solution that works for me, but may cause problems for others.

     

    I renamed iTunes.app. It no longer launches when I press the keyboard keys, but will still launch when I tell it to.

    This may cause some issues elsewhere, but I only use iTunes for syncing my iPod, and nothing more, so it works for me.

     

    This "feature" has caused me a headache, as my cat is constantly launching iTunes.