Previous 1 17 18 19 20 21 Next 302 Replies Latest reply: Dec 2, 2015 4:23 PM by bjamil - Bel Air MD Go to original post
  • chrisclock Level 1 Level 1

    Hello everyone, I hope I have found a proper solution for ML that works very well.

     

    I removed the line to launch itunes from the rcd binary and re-signed it. It now runs perfectly smooth and the media buttons control all apps (including itunes if open) without starting itunes.

     

    The portion in the rcd binary I removed was "tell application id “com.apple.iTunes” to launch" (replaced it with zeroes). I signed the binary using "sudo codesign -f -s - /System/Library/CoreServices/rcd.app/Contents/MacOS/rcd"

     

    I attached a zip file containing the original rcd binary as backup, one with the changes (it won't run due to the code signing) and the new resigned. Rename the signed one to rcd and replace the existing copy at /System/Library/CoreServices/rcd.app/Contents/MacOS/.

     

    Running OSX Mountain Lion 10.8.3, use at own risk!

     

     

    https://dl.dropbox.com/u/1837223/rcd_nostart.zip

     

    Good luck

  • Zerged Level 1 Level 1

     

    This works. Thanks chrislock

  • FokkerTISM Level 1 Level 1

    I tried that, but it said "This file is damaged. Move it to the trash." when I tried to launch rcd, so I set my security settings to Anywhere and launched it, but now the Play button on my remote won't respond when iTunes is off. I want to use the remote with Clementine and Spotify. Where did I go wrong? I have ML 10.8.3.

  • arman3939 Level 1 Level 1

    Instead of using only play key you can combine some keys with play/pause key for example

     

    Shift + play

    Control + play

    Alt + play

    Alt + Control + play

    Shift + Alt + play

    and  so on

  • Tatel Level 1 Level 1

    chrisclock's solution worked for me like a charm.

    Thank you very much, it's been a while until I found someone who solved it.

     

    Cheers.

  • jedidiah Level 1 Level 1

    Chrisclock's solution worked for me! I'm on 10.7.5.

  • Ralph Sauer Level 1 Level 1

    This worked (so far) for me, too. Thanks so much.

  • Zan5hin Level 1 Level 1

    I am trying to replace rcd but it says an older item already exists, and when I try to replace it doesn't allow me, as file is busy.

     

    I tried deleting rcd and emptying the trash but this didn't help.

     

    Any ideas?

  • matonmacs Level 1 Level 1

    Nevermind: it worked.

     

    Unfortunately, the download link seems broken. Any chance you could make it available again.

  • Zevacu Level 1 Level 1

    Hi

     

    When I press option shift L on a Belgian keyboard, iTunes is launched just like when I press the Play (F8) button. This prevents me from making the pipe / vertical bar character, so it's quite annoying. Could your solution be applied to this particular problem too? I'm unfamiliar with tweaking, I'm afraid.

     

    Best regards

  • Lgjmac Level 1 Level 1

    phenomenal, thanks chrisclock works like a charm... make sure you go to open package contents on rcd.app file

  • plmegalo Level 1 Level 1

    Great ! A bit hacky but works flawlessly on ML and freshly installed macMini late 2012. Beware to do the edit of rcd again when next updated, of course. Thanks for the codesign hack BTW, 

     

    To be sure it will work I'll managed that way :

     

    1 - Stop rcd process (via kill or activity monitor "quit")

    2 - copy rcd_nostart from Chrisclock zipped package on the right location ('/System/Library/CoreServices/rcd.app/Contents/MacOS/')

    3 - renamed rcd to rcd_backup

    4 - renamed rcd_nostart to rcd

    5 - "codesigned" newly named rcd file (via terminal line command)

    6 - launch back rcd by typing "./rcd &" in terminal opened in the rcd file location

     

    All this required some admin password signing popup fillings of course.

     

    Regards

     

    Pierre

    Visual Art by Une-Vache on deviantArt

  • mikelis Level 1 Level 1

    Does this work with 10.8.4?

    already spent half a day on trying to figure out when and why my apple remote started hating on vox

  • mikelis Level 1 Level 1

    does not. 

  • warpkanal Level 1 Level 1

    I've always used

    launchctl unload -w /System/Library/LaunchAgents/com.apple.rcd.plist

    to stop itunes from interfering.

    Strangely after the 10.8.4 update, Vox couldn't be controlled anymore by my media keys, but after

    launchctl load -w /System/Library/LaunchAgents/com.apple.rcd.plist

    and

    launchctl unload -w /System/Library/LaunchAgents/com.apple.rcd.plist

    it works again