Previous 1 3 4 5 6 7 Next 302 Replies Latest reply: Dec 2, 2015 4:23 PM by bjamil - Bel Air MD Go to original post
  • Mark Chernev Level 1 (5 points)
    This "feature" is horrid. Please, Apple, remove it soon.

    Message was edited by: Mark Chernev
  • TWH3 Level 2 (470 points)
    Given I can't really control my Mac as needed I think this is the only viable option for me.

    Really basic question: how does one go about rolling back to 10.5?

    Once I read that this is fixed I'll dig out my Family editon Snow Leopard disc

    thanks
  • mckelvaney Level 1 (0 points)
    This is an evil 'feature', I have recently moved from Windows to Mac, and though that it was the end to my annoying 'features'. Apparently not.
    As mentioned by others, the play/pause key is now just an iTunes quick launch key.
  • 0scar Level 1 (10 points)
    I've found a workaround. I've posted it here: http://discussions.apple.com/thread.jspa?threadID=2165265
  • biskitwheels Level 1 (0 points)
    yes! works for me. you are my hero. thank you so much for your effort.

    2 notes on the instructions

    - you need to change permissions on the folder "Contents" to save the plist file
    - move itunes back to apps folder after logging back in (obvious)

    thanks again!

    Message was edited by: biskitwheels
  • 0scar Level 1 (10 points)
    I'm glad it worked! ^^

    Please post those useful amendments about the permissions to the 'solution'-thread too? (I must have used a text-editor that worked around that...)

    /ozzie
  • SwedePetter Level 1 (0 points)
    Yeah Apple, this is a pretty pathetic, Windows-like feature. Get rid of it as soon as possible, or at least make it properly configurable. And demote the guy who put it there in the first place, he will dilute the Apple brand if he gets any further.
  • harryfear Level 1 (0 points)
    andrew pz wrote:
    I got so sick of this that I made a fix. It's a fairly ugly workaround, but hopefully it'll tide me over until Apple realize that this "feature" has to go. It works by preventing iTunes from launching if Spotify is open. (You can't even launch it manually, unfortunately, but as soon as you quit Spotify you are fine again.)

    This seems to work with iTunes 8 and 9, although you'll need to redo the patch after upgrading. Needless to say, if this wrecks your system I'm not to be held responsible.

    Open a Terminal and type the following

    cd /Applications/iTunes.app/Contents/MacOS
    sudo mv iTunes iTunesX
    sudo curl http://www.ast.cam.ac.uk/~app26/itunes/iTunes -O
    sudo chmod uog+x iTunes

    You'll have to type your password after the second step. Hope this helps some people.


    How do you 'uninstall' this fix?

    Thanks.
  • dmonner Level 1 (0 points)
    To "uninstall" this, you just need to revert the change made; open a Terminal and type the following:

    cd /Applications/iTunes.app/Contents/MacOS
    sudo mv iTunesX iTunes

    That will remove any trace of this fix from your system.
  • harryfear Level 1 (0 points)
    dmonner wrote:
    To "uninstall" this, you just need to revert the change made; open a Terminal and type the following:

    cd /Applications/iTunes.app/Contents/MacOS
    sudo mv iTunesX iTunes

    That will remove any trace of this fix from your system.


    Thanks for this, but I think there's something else I have to do. I did what you suggested, but now although my play/pause key loads iTunes, now the media keys won't play/pause, rewind, or forward iTunes! Please help!

    Thanks!
  • dmonner Level 1 (0 points)
    There's nothing else to it. Are you on the iTunes Store page when iTunes starts up? As we've seen in this topic already, iTunes will not respond to these keys when the Store page is open. Or if you have another application open that uses the keypresses, it may be intercepting them from iTunes. Finally, restarting your machine might help; if some underlying Apple process that handles keypresses is still using the old reference to iTunesX instead of iTunes, restarting should set it back.
  • Roger de Matas Level 1 (5 points)
    Hi everyone. I'm a recent convert from windows to the mac, since the end of July. All I can say is that I love it.
    I've been lurking here for years and I've picked up lots of good info from here, so I guess it's my time to try an attempt to help Please be kind !
    I have the reverse situation. I like the idea of launching iTunes from the keyboard media keys and after I installed SL , it stopped working. I had to hold the fn key down and hit the play key for Itunes to launch, so I did some digging. I went into keyboard preferences and unchecked to box where it says;

    *Use all F1, F2 etc. keys as standard function keys*
    +when this option is selected, press the fn key to use the special features printed on each key+

    This worked fine for me. Hope this helps and that we are talking about the same thing...lol
  • zenona Level 1 (0 points)
    Looking forward for the preference to disable it. I use Spotify 90% of the time and it's a waste of memory having to have iTunes open for nothing.
  • Madgick Level 1 (0 points)
    I dont imagine this was an attempt at forcing people to use iTunes, My guess is it just seemed like a nice idea at the time but turned out to be a total crap one. I'm going with the 'Leave it in iTunes Store' fix at the moment, but its just irritating to be honest and I'm really surprised it wasn't fixed in the latest update. Hope its sooner done than later, really irritating
  • cliveports Level 1 (0 points)
    Ok, so we're all agreed this is awful. (I want control of Logic 8 BACK please - without workarounds etc.!!)

    But I notice one contributor to this discussion is painfully absent.......

    This is an Apple SUPPORT forum, so give some!!
Previous 1 3 4 5 6 7 Next