12 Replies Latest reply: Dec 30, 2009 6:48 PM by kxp109
rarrieta Level 1 Level 1 (0 points)
I was doing software updates tonight. I started the updates then it looked like the computer was off si I hit the startup button. When it came back on I get the kernel panic. Its right after startup like 5 seconds in. I cant even boot off a disk because it kernel panics so fast. Does anyone know a way around this?

Thanks

iMac, Mac OS X (10.5.4)
  • 1. Re: Kernel panic at startup
    Dave Barnes Level 4 Level 4 (2,975 points)
    rarrieta,

    You wrote: "can't even boot off a disk because it kernel panics so fast".

    Do you mean that you cannot boot from the install DVD?
    If yes, then you have a hardware failure and need to take in to be repaired.

    ,dave
  • 2. Re: Kernel panic at startup
    Michael Lafferty Level 6 Level 6 (16,080 points)
    If you interrupted the application of an OS or security update, you may need to reinstall your operating system using your original DVD install disks and the archive and install option.

    It is very unlikely that you are seeing a kernel panic as a result of what you describe. Can you be more specific about exactly how your machine crashes: for example, what appears on the screen when your boot process halts? Kernel panics are indicated typically by the display of a multilingual crash message, or the display of a specific kernel message and the creation of a crash log entry.
  • 3. Re: Kernel panic at startup
    rarrieta Level 1 Level 1 (0 points)
    Ok, well I hit the power button, see the gray screen since its ready to start. Apple logo apears and then quickly the kernel panic happens. Let me try and type what it says.

    panic(cpu 0 caller 0x001A9C68) Kernel trap at 0x00000000, type 14=page fault, registers:
    CRO: 0X8001003b, CR2 0x00000000, CR3: 0x00d14000, CR4: 0x000000660
    EAX: 0x00000001, EBX: 0x00136757, ECX: 0x00000000, EDX: 0x00000598
    CR2: 0x00000000, EBP: 0x1b3dbf38, ESI 0x028e2000, EDI: 0x00000001
    EFL: 0x00010002, EIP: 0x00000000, CS: 0x00000008, DS: 0x004f0010

    Debugger called: <panic>
    Backtrace (CPU 0), Frame : Return Address (4 potential args on stack)
    0x1b3dbd28 : 0x12b4f3 (0x45b13c 0x1b3dbd5c 0x1335e4 0x0)
    0x1b3dbd78 : 0x1a9c68 (0x464700 0x0 0xe0x463eb0)
    0x1b3dbe58 : 0x1a038d (0x1b3dbe70 0x212 0x1b3dbf38 0x0)
    0x1b3dbe68 : 0x0 (0xe 0x48 0x10 0x95b0010)
    0x1b3dbf38 : 0x1b3aaf13 (0x2724c00 0x0 0x2782f20 0x27832e8)
    0x1b3dbf58 : 0x1b3af4ab (0x2782f20 0x95bdc01 0x0 0xd007fd2a)
    0x1b3dbfc8 : 0x1ao17c (0x0 0x0 0x1a3065 0x27832e8)
    Backtrace terminated-invalid frame pointer 0
    kernal loadable modules in backtrace (with dependicies):
    com.apple.driver.AppleIntelCPUPowerManagement (76.2.0)@0x1b3a7000->0x1b3c5ff

    BSD process name corresponding to current thread: Uknown

    Mac OS version:
    Not yet set

    Kernel version:
    Darwin Kernel version 9.6.0: Mon Nove 24 17:37:00 PST 2008: root: xnu-1228.9.5
    System model name: imac7,1 (Mac-F4238CC8)
  • 4. Re: Kernel panic at startup
    B Man Level 1 Level 1 (95 points)
    rarrieta,

    Have you found a solution to this yet? I'm having the same issue. Can't boot from the iMac restore disc, and when I boot from the hard drive I get to the desktop for a few seconds then KP. Happens slower when the machine has been shut down for a few minutes. That suggests to me that it's a hardware issue. Though I'm trying to remain optimistic.
  • 5. Re: Kernel panic at startup
    Marcos Duran Level 1 Level 1 (40 points)
    Have you guys tried booting up with the SHIFT key pressed? Maybe there is startup process that is causing this. If it does boot up with the shift key pressed go into system preferences, accounts, login items and turn off all those startups (write down what they are). That is for the person that actually gets to the desktop.

    For the person who is getting kernel panic within seconds something must have gone wrong with an update that was interrupted. The system does not seem to recognize the installed OS version (it says not set). Insert your MacOS X DVD in the drive and boot up with the "C" key pressed until you see the Apple logo. Reinstall the oeprating system.
  • 6. Re: Kernel panic at startup
    B Man Level 1 Level 1 (95 points)
    Tried that and got the KP when at the grey apple screen with the spinning icon. It powers on with the chime, I hold the shift key, grey apple shows up, spinning timer signal comes up below the apple, it spins for several minutes then KP.

    Message was edited by: Sleestak
  • 7. Re: Kernel panic at startup
    jeff090897 Level 1 Level 1 (0 points)
    As of yesterday I am experiencing the EXACT same problems as Sleestak.

    Cannot do SAFE boot, cannot boot from install DVD, etc.

    This is a Macbook, approx 1 yr old. Machine was working fine, closed the lid to put it to sleep. Opened the lid, screen was black and it would not restore from sleep. It has had this problem since.
  • 8. Re: Kernel panic at startup
    jeff090897 Level 1 Level 1 (0 points)
    Update -
    I tried resetting PRAM and NVRAM via the command-option-P-R trick.

    No luck. However, I failed to mention that the startup sound was extremely quiet, but after resetting this, the startup sound went back to normal volume.

    I still cannot do SAFE boot or boot from DVD.

    Additionally, if I try to boot my BOOT CAMP Windows XP install, same problem, I get the blue screen of death.

    So this seems like a physical issue rather than a software problem.
  • 9. Re: Kernel panic at startup
    jeff090897 Level 1 Level 1 (0 points)
    Another update.
    After downloading and running the Ultimate Boot CD (which I CAN boot from), I used the memory diagnostics to verify that Memory tests fail (and fail very badly at that). So I suspect either bad RAM or bad memory controller. Note that I have not done any upgrades to this Macbook since purchase.

    Further testing coming soon.
  • 10. Re: Kernel panic at startup
    jeff090897 Level 1 Level 1 (0 points)
    Final update.

    PROBLEM SOLVED.

    This issue was caused by failed RAM.

    I discovered this via memory diagnostics on The Ultimate Boot CD (which is free for those who do not know). That CD would boot when others would not.

    Memory tests were failing, so I popped in some spare RAM laying around and all was good. Since then I replaced the RAM with new sticks, and my Macbook lives again.

    I'm not sure WHY the RAM failed in the first place, but am just happy it was a relatively inexpensive fix.
  • 11. Re: Kernel panic at startup
    kxp109 Level 1 Level 1 (0 points)
    I'm having the exact same problem as jeff with my Macbook Pro.

    - Kernel panic at startup; can't get beyond the Apple logo
    - Can't reboot from DVDs (the computer will eject them as if they're unreadable)
    - Can't boot in safe mode
    - Reset the PRAM and NVRAM (prior to this, I'd get the "You must restart..." message before the gear under the logo could make one full rotation but afterwards, the gear spins for 3 minutes or so before I get the message.)

    It was suggested that there might be something wrong with my optical drive but I'll give the Ultimate Boot CD a try, too.
  • 12. Re: Kernel panic at startup
    kxp109 Level 1 Level 1 (0 points)
    Belated update on my problem:

    I ran the fsck -fy, it repaired something (I'm sorry, I didn't write down what it was) and then told me everything was OK, so I rebooted and... success! I was able to log in normally. I immediately reboot from the DVD to use disk utility and after that was done, I was able to log in normally again. I then tried to get the panic log but while I was trying to make a copy of it, the computer froze. Less than 5 minutes elapsed between logging in and the computer freezing. I shut down, waited a few minutes before powering it on again, got the kernel panic at startup again, did the fsck but this time it told me everything was OK on the first try, so I rebooted. Was able to log in normally... 1 or 2 minutes later, it freezes again.

    Now I'm back to square one. I get a kernel panic after the Apple logo, I cannot start up in safe mode, I can't start up from the DVD, fsck -fy tells me everything is OK, although I do get this message (I don't know if it's related or not but it was there from the very first time I used fsck -fy):

    ----
    Extension "com.apple.driver.AppleUSBTCKeyboard" has no kernel dependency.
    Extension "com.apple.driver.AppleUSBTCKeyEventDriver" has no kernel dependency.
    Dec 30 12:03:32 launchd: Bug: launchd.c:1990:17: ioctl(s6, SIOCAIFADDR_IN6, &ifra6) != -1
    Singleuser boot -- fsck not done
    Root device is mounted read-only
    ----

    I used the tail /var/log/system.log command and I got these lines (each being preceded by a timestamp):

    ----
    My-Computer lookupd[63]: lookupd (version 369.8) starting - Dec 30 12:23:32
    My-Computer /System/Library/CoreServices/loginwindow.app/Contents/MacOS/loginwindow: Login Window Application Started
    My-Computer loginwindow[65]: Login Window Started Security Agent
    My-Computer mDNSResponder: Addling browse domain local.
    My-Computer launchd[118]: com.veoh.webplayer.startup: execve(): No such file or directory
    My-Computer launchd [128]: com.veoh.webplayer.startup: execv("/Applications/Veoh Web Player.app/Contents/MacOS/VeohWebClient", ...): No such file or directory
    localhost kernel[0]: hi mem tramps at 0xffe00000
    localhost kernel[0]: PAE enabled
    localhost kernel[0]: 64 bit mode enabled
    ----

    I'm guessing the veoh thing is causing the problem... is there anything else I can do from fsck? I'm not familiar with Unix commands, etc.

    Thanks