Skip navigation
This discussion is archived

Cannot install Snow Leopard over 10.5.8 because "can't boot from" boot disk

151835 Views 143 Replies Latest reply: Mar 15, 2010 3:17 PM by Jman5112 RSS
  • R C-R Level 6 Level 6 (13,780 points)
    Carl Muckenhirn wrote:
    It seems odd to me that the Installer would be this finicky about the partition table, when all it needs to do is operate within the existing partition.


    That isn't true because the installer involves restart(s) -- the 'upgrade' install process at least seems to require at least one restart during the install process besides the final one that returns control to users.

    It is obvious that Apple tried to make the new installer as "goof proof" as possible & part of that is most likely making sure there is nothing unusual on the targeted drive that would prevent the final restart from running the newly installed Snow Leopard & doing its 'first boot' stuff (which seems mostly to automatically invoke Software Update and the Setup Assistant).

    What the installer does during any other restarts isn't clear to me but I suspect this is a part of why it is so finicky compared to the Startup Manager, which doesn't have to contend with installs in progress.

    My guess is that third party boot utilities like rEFIt & some disk utilities will need to be updated for Snow Leopard compatibility. Since Apple doesn't support them, this seems like the kind of issue that should be raised on their support forums.
    iMac 2008 24"/3.06 GHz; White MacBook/2.4 GHz; iMac G5 17" ALS/2.0 GHz, Mac OS X (10.6), Kensington Trackball; Airport Extreme 802.11n; assorted iPods and older Macs
  • Luloh Level 1 Level 1 (0 points)
    Ok. None of the fixes above worked for me.

    However, I may have found the glitch in the install which worked on my MacPro. The problem is that the yellow triangle of death pops up and makes you believe that SL was not installed on the HD, even though it was.

    After you get the triangle, do a shut down and then turn your computer back on while pushing the "option" key when you hear the Apple startup sound. You will then have the option to either boot from the install dvd or from the hard drive that really does have SL installed. Then eject the DVD and pick the hard drive as your boot device.

    Then be very, very patient because it took my MacPro almost 10 minutes to boot the first time. First with the Apple logo and spinning wheel and then a blue screen for 5 minutes.

    After that Snow Leopard was running.

    I hope this works for you.
    All Macs, Mac OS X (10.6)
  • R C-R Level 6 Level 6 (13,780 points)
    I have no idea what you mean by the "yellow triangle of death." Where do you see this?
    iMac 2008 24"/3.06 GHz; White MacBook/2.4 GHz; iMac G5 17" ALS/2.0 GHz, Mac OS X (10.6), Kensington Trackball; Airport Extreme 802.11n; assorted iPods and older Macs
  • The hatter Level 9 Level 9 (58,535 points)
    I booted from SL DVD.
    Repair drive.

    Message: "Updating boot support partitions for the volume as required."

    No idea as to EXACTLY what that did, and if I wasn't using DVD, it might have required a restart otherwise.

    But, almost every new or update to the OS has required changes in the driver or driver partition or partition tables. Whether that was a larger hidden partition to hold the new driver in 6.0.7, or new features and partition table(s) in the move from Tiger to Leopard. And sometimes inbetween changes. Or how RAID partitions created in Tiger could not mount, viewed or accessed in Panther (10.3.9). Changes happen.

    Leopard introduced formal support for Boot Camp partitions; for resizing and creating new partitions out of free (unfragmented) space; better support for GPT.

    I always use the new OS to format a drive.

    At the least, make bootable backup, run Disk Warrior (the SL certified version, not the older 4.1.1), (or another 3rd party) beforehand. And repair your drive with Snow Leopard itself. We don't know but usually Disk Utility is new, improved and better at knowing what to look for and repair.
    Mac Pro 8800GT WD VelociRaptor 10k, Mac OS X (10.6), Windows 7 Core i7 920 GTS 250 CyberPower UPS
  • Luloh Level 1 Level 1 (0 points)
    The yellow traingle with ! comes up and says cannot install SL on your hard drive.
    All Macs, Mac OS X (10.6)
  • Kulaid982 Calculating status...
    I was triple-booting Leopard, Jaunty, and XPPro using ReFIT, and had the issue identified in this post. Someone suggested booting into Linux and using gParted to shrink the Macintosh HD partition. I did, and it worked. I used gParted to add 128 MB AFTER the partition, and Snow Leopard installed, no problem!
    MacBookPro5,5, Mac OS X (10.6), Triple Booting Snow Leopard, Jaunty, XPPro, using ReFIT
  • ijonglin Calculating status...
    I can confirm that this fix works. I am upgrading a MacBook Pro that dual boots MacOS X and Ubuntu 7.04. Without any changes, when I tried to install Snow Leopard onto the system, there was a yellow triangle with an exclamation mark that told me the partition was not bootable.

    Following the instructions on the previous post, I booted into the Ubuntu side, I put an extra 128MB after the MacOS partition, using gparted. Booted up with the Snow Leopard Install Disk and now it is installing.
    MacBook Pro, Mac OS X (10.4.11), Dual Boot with Ubuntu
  • vincefer Calculating status...
    Hi,

    This procedure with gParted also worked for me. I'd like to point a pair of things to save some time to others using it:

    -After resizing partitions with gParted reboot with Snow Leopard CD inserted and boot from it. When I rebooted into Mac OS X 10.5 after repartitioning and launched Snow Leopard installer it just crashed. I tried then to reboot with the CD but the yellow triangle appeared on Leopard partition. I had to use gParted again and boot from CD. Then it allowed the installation.

    -When using gParted do only one change. If you for example resize to leave 128Mb and after accepting, you realize that the utility has adjusted it to, lets say 120Mb. And then you resize again to 130Mb. Then gParted will apply both changed and that will take a LOT of time. It is better to cancel the first resize and start all over with one change only.

    Writing from Snow Leopard. Thanks for the workaround.
    MBP17, Mac OS X (10.6)
  • Wanderedinn Calculating status...
    When I run gparted, my mac os partition has a yellow triangle with an exclamation mark on it. When I select to shrink it, it will not permit me change it's size. Any suggestions would be greatly appreciated.
    Macbook pro, Mac OS X (10.5.3), 2.5 Ghz core 2 duo 2GB
  • Wanderedinn Level 1 Level 1 (0 points)
    I should mention that I'm currently dual booting Red Hat EL 5.4 and OSX with refit.
    Macbook pro, Mac OS X (10.5.3), 2.5 Ghz core 2 duo 2GB
  • Wanderedinn Level 1 Level 1 (0 points)
    My solution was to shrink the partition that followed the mac partition. It was a linux swap partition. So, gparted did this fine. I rebooted from the Snow Leopard install disk and all appeared well, it went into the update fine. Problem is, when I attempt to boot to my Linux partition, it says it's not bootable, thus I'm trying to recover that now. The OSX disk utility sees my linux partitions. I tried booting with a fedora 11 rescue. fdisk only shows the gpt partition and tells me to use gparted. Unfortunately, fedora 11 rescue does not include gparted. Any suggestion as to how to recover my Linux install would be greatly appreciated. Fortunately, I did backup up my Linux data before attempting this effort, but I hate to think I'm looking at a complete reinstall of Linux.
    Macbook pro, Mac OS X (10.5.3), 2.5 Ghz core 2 duo 2GB
  • Lordmorgul Calculating status...
    Fedora includes parted (the cli version of gparted). Try turning on the boot flag of your lnux partition with parted.
    MacBook 2,1 (blackbook), Mac OS X (10.5.8)
  • Lordmorgul Level 1 Level 1 (0 points)
    Also if you did not know, while running a live cd you can o stall software, it wll only be there until restart. On fedora while running, run
    su -
    yum -y install gparted
    gparted
    MacBook 2,1 (blackbook), Mac OS X (10.5.8)
  • Wanderedinn Level 1 Level 1 (0 points)
    Thanks for the hint on parted. Parted indicates the boot flag is already turned on. All the partitions are there, I have successfully mounted them and reviewed their contents. Any other suggestions would be appreciated.
    Macbook pro, Mac OS X (10.5.3), 2.5 Ghz core 2 duo 2GB
  • Wanderedinn Level 1 Level 1 (0 points)
    Got the solution from the mactel-linux-users list. I had to run gptsync from the refit shell. After that all is well. I'm posting this from my Linux env on my mbp.
    Macbook pro, Mac OS X (10.5.3), 2.5 Ghz core 2 duo 2GB
1 ... 6 7 8 9 10 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.