Previous 1 2 3 4 5 6 Next 143 Replies Latest reply: Mar 15, 2010 3:17 PM by Jman5112 Go to original post
  • Russell Mclean Level 1 Level 1 (10 points)
    PGP Desktop was the issue for me.

    1. Open PGP Desktop
    2. PGP -> Uninstall
    3. Restart

    Thanks for the tip!
  • redpola Level 1 Level 1 (25 points)
    Ok so it was not as plain sailing as I hoped. After running the SL install from 10.5.8 and it completing, my machine seemed hung during shutdown (except that it wasn't - FileSync threw up an error and CMD-OPT-ESC worked). After some random keystrokes I got to a login prompt (must have got the magic "log me out" keystroke) and chose "shutdown". Again this just hung. After half an hour I powered off and booted. Except that I got the flashing question mark on the folder.

    So rebooted from the install DVD. The installer saw that there was a recoverable install of SL and er... recovered it.

    I am now in Snow Leopard. Thanks all.

    Dear Apple, buy more QA engineers. Speaking as a professional QA manager, it's shocking that this kind of showstopper defect can exist at release. Speaking as a long-time Apple user, this is the first time something like this has happened to me. Declining standards? Bad luck? Surely a less-than-six-month-old machine makes it big in the test matrix?

    On the bright side - I would like to thank William for being hugely helpful.

  • zen pathfinder Level 1 Level 1 (0 points)
    I was running happily 10.5.8 and had a single partition on a 500GB drive.

    I made the partition a smidge smaller and hit Apply. It verified, but would not allow me to set it back to the original size.

    This being said, the installed now believes the disk is worthy.

    Apple needs to generate a better error message.
  • myneid Level 1 Level 1 (0 points)
    thank you this worked for me as well.
    very frustrating
  • Carl Muckenhirn Level 1 Level 1 (5 points)
    I'm hoping your solution works, however, when I select "Apply" I get the confirmation box (which I confirm) then get an error message about "MediaKit can't write partition (map) too small" or something similar.

    I've got a triple boot using ReFit, but that shouldn't (famous last words) matter, right?

  • Ty Stein1 Level 1 Level 1 (20 points)
    Same issue for me. Uninstalled PGP, restart, and SL installation was uneventful.
  • Loren Ryter Level 2 Level 2 (495 points)
    William's tip did the trick! Haven't installed yet but it now allows it. I also have PGP desktop installed and did not uninstall it first.
  • Mac1987 Level 1 Level 1 (0 points)
    I've spent the day dealing with AppleCare and the local Apple store on this issue. I've tried installing on 5 MacPros, 2 17" MBPs and one Mac Mini. The Mac Mini worked and all seven others got the exact same error you got.

    I got the error while trying to install while logged in and by trying to install with booting off the SL disk. AppleCare thought the DVDs were bad and they seem to be using this as the answer to a number of problems. I went back to the Apple store and swapped all my DVDs and they also tested them there. Both the original set and the new set worked there but once again didn't work on mine.

    AppleCare and the techs at the store are stumped at this point. I was going to be testing further but PGP has released a notice that if you're running PGP you should not install till PGP 10.0 comes out, which means that now I'll probably hold out upgrading to SL till PGP 10.0 comes out.

    From PGP: "This email is to advise you that if you are running PGP® Whole Disk Encryption, PGP® Desktop Professional, PGP® Desktop Home or PGP® Desktop Email, you should NOT upgrade to Mac OS X 10.6 (Snow Leopard). If you intend to upgrade to Snow Leopard, you must decrypt all PGP® encrypted drives and uninstall PGP® Desktop before upgrading the system to Mac OS X 10.6. After upgrading your system you should not attempt to re-encrypt any disks with PGP® Whole Disk Encryption as it is likely to lead to potential data loss or other system and data issues. We expect support for Mac OS X 10.6 to be available in the next major release of PGP® Desktop (10.0). PGP Corporation recommends waiting until PGP® Desktop 10.0 is available before upgrading to Mac OS X 10.6. If you would like to be notified when the beta version becomes available, please register at"

    The seven Macs that failed were all Intel Macs and covered a variety of generations over the past few years. All were fully patched up to 10.5.8 and were running without issue.

    I'm going to try and test your suggestion William on one but have a question, does raising, lowering or moving around the partition like that have any possible negative impact on data stored on the drive, especially if there is only 50GBs or so free?

    Also, got to say, I'm a bit surprised that Apple could miss something so basic as this. Not sure what percentage of users affected is but for me it was seven out of eight so far and that's way too high. Techs recommending people to wipe their drive and do reinstalls all day and returns DVDs only has aggravated the issue and wasted a lot of people's time.
  • bluecrabby Level 1 Level 1 (0 points)
    I have a Macbook Air with the 128 GB SSD. I am noticing allot of you do too. I do not have PGP and believe that is most likely another issue with a similar error message. I have tried dragging the partition size up releasing and then dragging it back down and applying but it does not help. When I attempt to lower my partition size, even slightly, it tries for a bit then pops up that it cannot complete as "the device is out of space". I am currently running 10.5.8 and my drive is GUID. The install DVD worked fine on my other Macbook. Any help or advice would be gladly appreciated.
  • PastorPaulH Level 1 Level 1 (0 points)
    I am having the exact same trouble with my unibody macbook.

    Won't let me change the partition.

    I did upgrade the hard drive to a 320 GB awhile back. Kept the original 250. The SL Disk is presently updating that drive to SL. We'll see how it goes.
  • reachinguganda Level 1 Level 1 (0 points)
    So far no luck for me. To start off with, my MBP had the Apple Partition Table. So I used iPartition and changed it to GUID. Now I have the "cannot boot from" error. I tried the resizing trick... nada. Verified and repaired... nada. Anyone have any other ideas? This is rather frustrating. Thanks. BTW... no PGP installed.
  • jdtate Level 1 Level 1 (0 points)
    MBP with leopard and PGP install.

    De-crypted the Whole Disk Encryption, Uninstalled PGP. SL still would not say the disk was bootable. Re-sized the partition as suggested and BINGO it works.

    Many thanks to all who suggested this work around. You just saved me a whole day of re-installation and pain.
  • aching Level 1 Level 1 (0 points)
    A friend of mine reports:
    Wow. Went onto the Apple Support forum and some guy told me to
    wiggle the volume size up and down in Disk Utility and click apply
    and it's working!

    Sounds worth a try.
  • Carl Muckenhirn Level 1 Level 1 (5 points)
    This is now officially really frustrating.

    I've got a 500G seagate running fine under 10.5.8, formatted as GUID with multiple partitions.

    Under Leopard disk checks out fine, even under Snow Leopard "Verify Disk" doesn't see any problems. However Snow Leopard states that it can't use the partition because it "can't be booted" which is wrong because it boots fine into Leopard.

    Using the suggestion of some I've put the disk into an external enclosure, but same result. (Small benefit is that SL is happy to upgrade the install on the old drive (320G)).

    Does anyone know what SL is looking for that it isn't finding to convince it that the drive is bootable?

  • redpola Level 1 Level 1 (25 points)

    Did you see the message I marked as the solution to my problem (I originated this thread)? I have the same hardware as you, and a 500GB hard drive (as one partition) and the fix worked for me.

Previous 1 2 3 4 5 6 Next