Previous 1 5 6 7 8 9 10 Next 143 Replies Latest reply: Mar 15, 2010 3:17 PM by Jman5112 Go to original post
  • Jman5112 Level 1 Level 1 (0 points)
    Hey everybody, I am also having the yellow triangle on the boot up disk issue when trying to upgrade from 10.5.8 to SL...and the Disk Utility says "Partition failed with the error:MediaKit reports no such partition" when I try the partition adjustment. Same problem using DU from the SL dvd.

    + I am not running PGP or 3rd party boot managers
    + I am running bootcamp with winXP on a separate hard drive
    + No 3rd party apps have ever been used to partition
    + It is interesting to note that there is a tiny partition on the boot drive (I think bootcamp created it.)

    Any help short of format and reinstall is much appreciated!! Here's the results from terminal:

    sudo gpt -rvvvv show /dev/disk0

    gpt show: /dev/disk0: mediasize=500107862016; sectorsize=512; blocks=976773168
    gpt show: /dev/disk0: PMBR at sector 0
    gpt show: /dev/disk0: Pri GPT at sector 1
    gpt show: /dev/disk0: GPT partition: type=C12A7328-F81F-11D2-BA4B-00A0C93EC93B, start=40, size=409600
    gpt show: /dev/disk0: GPT partition: type=48465300-0000-11AA-AA11-00306543ECAC, start=409640, size=976101344
    gpt show: /dev/disk0: GPT partition: type=E3C9E316-0B5C-4DB8-817D-F92DF00215AE, start=976510991, size=262144
    gpt show: /dev/disk0: Sec GPT at sector 976773167
    start size index contents
    0 1 PMBR
    1 1 Pri GPT header
    2 32 Pri GPT table
    34 6
    40 409600 1 GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
    409640 976101344 2 GPT part - 48465300-0000-11AA-AA11-00306543ECAC
    976510984 7
    976510991 262144 3 GPT part - E3C9E316-0B5C-4DB8-817D-F92DF00215AE
    976773135 32 Sec GPT table
    976773167 1 Sec GPT header

    sudo fdisk /dev/disk0

    Disk: /dev/disk0 geometry: 60801/255/63 [976773168 sectors]
    Signature: 0xAA55
    Starting Ending
    #: id cyl hd sec - cyl hd sec [ start - size]
    1: EE 1023 254 63 - 1023 254 63 [ 1 - 976773167] <Unknown ID>
    2: 00 0 0 0 - 0 0 0 [ 0 - 0] unused
    3: 00 0 0 0 - 0 0 0 [ 0 - 0] unused
    4: 00 0 0 0 - 0 0 0 [ 0 - 0] unused

    diskutil list

    0: GUIDpartitionscheme *465.8 Gi disk0
    1: EFI 200.0 Mi disk0s1
    2: Apple_HFS Macintosh HD 465.4 Gi disk0s2
    3: Microsoft Reserved 128.0 Mi disk0s3
    0: GUIDpartitionscheme *465.8 Gi disk1
    1: EFI 200.0 Mi disk1s1
    2: Microsoft Basic Data Windows XP 465.6 Gi disk1s2
    0: GUIDpartitionscheme *931.5 Gi disk3
    1: EFI 200.0 Mi disk3s1
    2: Apple_HFS TimeMachine [MACPRO] 931.2 Gi disk3s2
    3: Microsoft Reserved 128.0 Mi disk3s3
    0: GUIDpartitionscheme *465.8 Gi disk4
    1: EFI 200.0 Mi disk4s1
    2: Apple_HFS Rendered Projects 465.4 Gi disk4s2
  • Jman5112 Level 1 Level 1 (0 points)
    Carl Muckenhirn wrote:
    It seems odd to me that the Installer would be this finicky about the partition table, when all it needs to do is operate within the existing partition.

    Well said, Carl!!
  • Mike Boreham Level 4 Level 4 (2,095 points)
    ManuP wrote:

    Same problem on a MBP without PGP installed. Apple Support advises me to reformat and make a fresh install but I would prefer to avoid re-installing all softwares.

    No need to reinstall all the softwares......erase......install......import everything from Time Machine or a clone........ gives same end result as upgrade install, but has more waiting around time during the import.

    Worked perfectly for me.
  • madsmith Level 1 Level 1 (0 points)
    Hey all,

    I put a new SSD in my macbook a few months back. I have no partitions, it says my map scheme is Master Boot System. I'm having trouble installing SL, the wiggle thing didn't work as there is no handle (b/c there isn't a partition?). I'll probably erase disk and use time machine to restore it - however, this still doesn't solve the GUID partition scheme thing. As you can tell, I really don't know what I'm doing... What should I do with my hard drive? Do I need to make a partition?

    Thanks much!
  • Boyd Porter Level 3 Level 3 (650 points)
    You've asked an unrelated question in an "answered" topic.

    Start a new topic here,!default.jspa?forumID=1337, and restate the question.

    It is a good one, but I don't know the answer.

    Have a nice day.


    Message was edited by: Boyd Porter
  • ManuP Level 1 Level 1 (5 points)
    Hi Mike,

    This is what I heard from a friend of mine and I'm now proceeding with the initial Time Machine backup (normally I'm using Superduper for backups).
    Thx for your advice anyway.
  • Mike Boreham Level 4 Level 4 (2,095 points)
    ManuP wrote:
    Hi Mike,

    This is what I heard from a friend of mine and I'm now proceeding with the initial Time Machine backup (normally I'm using Superduper for backups).
    Thx for your advice anyway.

    I did mine by importing from a Superduper clone, just as good and probably a bit faster than importing from TM
  • badpenguin Level 1 Level 1 (0 points)
    I have experienced the same problem, go to install SL and I got the "can't boot from boot disk" message.

    My MBP had three partitions, partition 1 for leopard, partition 2 for linux, partition 3 was linux swap. Created the second/third partitions by using disk utility to shrink the partition leopard was installed in, then allowed the ubuntu installer to create the linux partitions. IIRC I used rEFIt to set the partitioning scheme to MBR.

    Before attempting the upgrade I turned off FileVault on my account, got a full backup via Time Machine on an external USB drive, and removed rEFIt.

    Tried the "jiggle" the partition hack mentioned in this thread, didn't work.

    Tried deleting the 2nd/3rd partitions via disk utility, it just hung in "preparing to remove" for about 30 minutes before I gave up on that route.

    In a last ditch effort I booted from a ubuntu live cd, used fdisk to delete all partitions, and /dev/zero'ed the first 512 bytes of the drive.

    Booted from my leopard install DVD, re-partitioned with a single partition, re-installed leopard after un-selecting all optional components. At first boot after installing leopard I restored from the Time Machine backup.

    I then proceeded to successfully upgrade via the SL upgrade CD.

    I then discovered that Time Machine does not behave as I expected. For example it did not restore my copy of Xcode. I had to go into the optional packages on the SL upgrade CD and install it from there. I am a new mac user and had foolishly expected a Time Machine backup would back up everything, and a Time Machine restore would restore apps that I had installed beyond the base O/S install.

    I have installed and upgraded operating systems, literally, hundreds of thousands of times. From plain old DOS to OS/2 to all versions of Windows to pretty much every distribution of linux known to man since '93. Never have I had such a pathetic experience upgrading an operating system. Considering that includes all past versions of microsoft operating systems, that is saying a lot.

    Calling a partitioning scheme such as EFI "flexible" is a joke at best.

    What I would like to know, before experiencing such joy again, is how to get a partition table on a mac "back to normal" without a complete destruction of all data on the drive before hand. Is there any way to convert from a MBR partition table back to GUID without losing all data?
  • ForensicCPA Level 1 Level 1 (0 points)
    William absolutely it it dead-on. My Air had balked but my other boxes handled the 10.6 upgrade effortlessly. Thank you very much.
  • bluecrabby Level 1 Level 1 (0 points)
    Well I ended up doing an erase and install which, while frustrating, was quicker than I expected. I still would have greatly preferred an upgrade and install like my other Macbook which went very smoothly. It is disappointing that the SSD is what seems to be causing so much trouble especially since it cost a pretty penny to tack on.
  • Neal2K Level 1 Level 1 (0 points)
    Just wanted to add I had the same "can't boot from..." message. My MBP is setup with Bootcamp, OS X and Windows Vista, 50%/50%. I then added rEFIt. I just managed to get SL installed using the Linux method described above - booted from a Parted Magic CD, ran GParted, adjusted the HFS+ partition to be a little smaller, install then ran fine! Thanks to the community for your help - very frustrating!
  • James Reffner Level 2 Level 2 (360 points)
    That worked for me too! Excellent find!

    FYI: I moved it up and then immediately back to the exact place it was before. Then hit apply.

    It works! Thanks!!!
  • RADumas Level 2 Level 2 (295 points)
    William Maxwell wrote:
    Are there any affected users on this thread that do not have PGP desktop installed? Thanks.

  • bluecrabby Level 1 Level 1 (0 points)
    I did not have PGP installed.
  • Ron Khile Level 1 Level 1 (0 points)
    No PGP desktop installed.

    Message was edited by: Ron Khile
Previous 1 5 6 7 8 9 10 Next