Previous 1 2 3 4 Next 49 Replies Latest reply: Nov 16, 2009 8:45 PM by Gerald Gifford
gbod Level 1 Level 1
Anyone know if the Canoscan 8800F will work on SL? I'm not upgrading until I know for sure!

24 inch Al iMAC 2.8 GHz, 2gig ram, Mac OS X (10.5.1)
Reply by Louis Block on Aug 28, 2009 4:56 PM Helpful
This from Canon's support site:



+*The Flatbed Scanners to support Mac OS X v10.6 as of July 2009 are shown below.+*

*+The products which are not listed below will not support Mac OS X v10.6 in the future.+*
*+Flatbed Scanners to support Mac OS X v10.6+*

+ CCD Scanners+*

*+CanoScan 4400F, CanoScan 5600F, CanoScan 8400F, CanoScan 8600F, CanoScan 8800F, CanoScan 9950F+*
+ CIS Scanners+*

*+CanoScan LiDE 25, CanoScan LiDE 35, CanoScan LiDE 60, CanoScan LiDE 70, CanoScan LiDE 90, CanoScan LiDE 100, CanoScan LiDE 200, CanoScan LiDE 500F, CanoScan LiDE 600F, CanoScan LiDE 700F+*

*+Release Schedule for Mac OS X v10.6 supporting Software+*

*+The software to support Mac OS X v10.6 will be sequentially uploaded to our download website 2 or 3 weeks after the Mac OS X v10.6 release.+*



I just received my Snow Leopard disk. Looks like I'll have to wait until Canon releases their 500f driver before updating. At least its on there!!
Reply by Han Kessels on Aug 28, 2009 8:07 PM Helpful
I have a Canoscan 8800F. Just upgraded to Snow Leopard. The scanner works fine, with no special action required, both with MP Navigator Ex and Preview.

All replies

  • a brody Level 9 Level 9
    expertise.classicmacos
    Classic Mac OS
    Take your scanner into an authorized service center that has Snow Leopard installed on their machine and ask them to help you to see if it might be compatible.
  • William Maxwell Level 1 Level 1
    Check this KB and see if it is on the list. If it is not on the list, I would contact the vendor for support.
  • gbod Level 1 Level 1
    Nope, that was the first place I looked, therefore the forum question.
  • stevekn Level 1 Level 1
    I also have a canoscan LIDE 600F, also not on the list...

    Steve
  • LCee Level 1 Level 1
    The best purchase that I've ever made was to buy VueScan Pro and not have to worry about scanner drivers ever again. It is SL ready and will support your scanner and is constantly updated for new scanners.
  • Louis Block Level 1 Level 1
    This from Canon's support site:



    +*The Flatbed Scanners to support Mac OS X v10.6 as of July 2009 are shown below.+*

    *+The products which are not listed below will not support Mac OS X v10.6 in the future.+*
    *+Flatbed Scanners to support Mac OS X v10.6+*

    + CCD Scanners+*

    *+CanoScan 4400F, CanoScan 5600F, CanoScan 8400F, CanoScan 8600F, CanoScan 8800F, CanoScan 9950F+*
    + CIS Scanners+*

    *+CanoScan LiDE 25, CanoScan LiDE 35, CanoScan LiDE 60, CanoScan LiDE 70, CanoScan LiDE 90, CanoScan LiDE 100, CanoScan LiDE 200, CanoScan LiDE 500F, CanoScan LiDE 600F, CanoScan LiDE 700F+*

    *+Release Schedule for Mac OS X v10.6 supporting Software+*

    *+The software to support Mac OS X v10.6 will be sequentially uploaded to our download website 2 or 3 weeks after the Mac OS X v10.6 release.+*



    I just received my Snow Leopard disk. Looks like I'll have to wait until Canon releases their 500f driver before updating. At least its on there!!
  • Mntbikejack Level 1 Level 1
    Since this thread is specifically about the Canoscan 8800F under Snow Leopard, recommending Vuescan Pro when Vuescan Pro requires the Cannon drivers installed for the 8800F is bad advice. The Cannon drivers will not be available for a few weeks according to the Cannon support site..
  • Louis Block Level 1 Level 1
    Interestingly, also, the drivers for 10.5 have very recent creation dates (7/29/2009), though they appear to be the same drivers that have been available since at least December, 2007.
  • gbod Level 1 Level 1
    Thanks- I searched Canon's site and could not find this information. I'm sure it's tucked away in some obscure place.
  • Han Kessels Level 1 Level 1
    I have a Canoscan 8800F. Just upgraded to Snow Leopard. The scanner works fine, with no special action required, both with MP Navigator Ex and Preview.
  • gbod Level 1 Level 1
    Awesome! Thanks!
  • Tim McFarland Level 2 Level 2
    My Canoscan 9950F works fine, too.
  • Alancito Level 6 Level 6
    For those who've prematurely upgraded to Snow Leopard and found their scanner requires updated drivers not yet available, there is Apple's +Image Capture+ app in the Applications folder. Some scanners will work with this without the need for the manufacturer's software drivers. Read more in this Apple doc:

    _Mac OS X: How to scan with Image Capture_

    ...And for those who haven't yet upgraded to Snow Leopard and prefer not to wait for updated drivers, if +Image Capture+ works with your scanner and current version of OS X, it's likely to also work in Snow Leopard.

     ~ Alancito
  • DC.Ross Level 1 Level 1
    It doesn't work under Snow Leopard in the current form I have installed. PS CS4 crashes outright. When I try it in PS CS3, the beach just keeps spinning until you Force Quit.
Previous 1 2 3 4 Next