5 Replies Latest reply: Nov 13, 2009 10:30 AM by LegacyCode
Leigh Hatwell Level 1 (0 points)
Hi all

I've been using AFP file Sharing on, OSX server 10.5.x as a Time Machine server, and it's been working fine for the last year.
I was using external firewire drives, software stripped at a Raid 1 level.
Running on a Xserve 2,1 Quad Core 2.8.
Now I'm trying the same thing, but using an Xserve 3,1 QuadCore 2.26.
The big difference, is that I'm using Link Aggregation to connect to my network.
I have 4 ethernet connectors, of wich 3 are Linked as a Bond.
I can't get Time Machine share points to work...

Is anybody experiencing the same issues, is there a work around?

Thanks for any help, and I hope I was clear and that it makes sens....


Xserve 3,1 2.26 Ghz, Mac OS X (10.5.8), Xsan, DNS, OpenDir, Mobile Users
  • Camelot Level 8 (46,580 points)
    I can't see there's any correlation between link aggregation and Time Machine not working. I would think it's more likely to be a sharing setup.

    Do other sharepoints work? Can clients connect to other shared directories and transfer files?
    What happens when someone tries to use Time Machine? Do you get any kind of error message - either on the server or the client?
  • Leigh Hatwell Level 1 (0 points)
    Hi, thanks for your reply, and sorry I didn't check in before... :-/

    I also found that weired, but evrtything else works just fine.
    I'm using AFP, SMB, FTP and NFS and everything is doing great.

    I have a second identical server, only difference is that there is no Link aggregation
    setup. And Time Machine Sharepoints work fine.

    Aswering you question about what happens when someone tries to use Time Machine, the answer is Nothing. They can't even see the Time Machine Sharepoint.

    My other Time Machine server propagates it's services with no problems.

    Thanks for your help

    Kind regards

  • JLG89 Level 1 (45 points)
    Same problem here...running Server 10.5.8 on an Xserve G5, with link aggregation, and clients can't see the Time Machine share.

    I'm running 10.5.8 (not Server) on a second identical Xserve, also with link aggregation, and I was able to create a Time Machine share that works just fine.

    So, perhaps it's an issue with Server and link aggregation?
  • JLG89 Level 1 (45 points)
    More info...neither 10.5.x nor 10.6.x clients can "see" the server's Time Machine share.

    If I use the "defaults write com.apple.systempreferences TMShowUnsupportedNetworkVolumes 1" trick on a Time Machine client, then the server's Time Machine share does appear; however, I seriously doubt that this would be Apple's recommended workaround.

    I've tried disabling the Spotlight indexing and Time Machine function of the share in question, then re-enabling them. Didn't help. I even tried disabling the functions, manually deleting the invisible Time Machine-related files in the shared directory, then re-enabling the options.
  • LegacyCode Level 1 (0 points)
    I am also having the same problem. On an OS X Leopard Server with latest updates, when using link aggregation, the clients will not see the Time Machine server. They can mount the share just fine if I do it manually, but it does not show up in the Time Machine preferences and thus won't actually work for the TM backup.

    As soon as I remove the link aggregation, it works without a problem.