Previous 1 2 Next 19 Replies Latest reply: Nov 3, 2009 1:36 PM by modalshift
James Blandford-Baker Level 1 (5 points)
Trying to find an application using Snow Leopard results in the right icon being displayed next to the name but the name is in Chinese (Or Kanji) or something like that. All other spotlight list items are in English!

Any thoughts anyone?

Thanks

James

iMac Intel 2.4GHz 4Gb, Mac OS X (10.6), Time Capsule, Lexmark C530dn
  • F430 Level 1 (25 points)
    It's happening to me too. I did open up FontBook and resolved all the duplicate fonts but they still show up that way.
  • F430 Level 1 (25 points)
    It seems that spotlight is showing the app results in English now. The only thing I did was to fix the duplicate fonts and try searching several times and I could see the initial result come in Chinese and then heal itself.

    Everything seems to be fine now.
  • Magnus Lewan Level 4 (3,655 points)
    James, are you from Cambridge, Mass, or Cambridge, UK? (Both lovely places, btw.) Some other user reported that British English was not recognised by some applications in Snow Leopard, so you need to have (US) "English" as well high up in the list of Languages in System Preferences.
  • James Blandford-Baker Level 1 (5 points)
    That's helpful though it hasn't solved the issue in my case. It seems that the only applications that display with the Kanji (or whatever) fonts are Apple's own and not all of them. (Grab shows in Kanji but Font Book shows in English, for example). Opening Font Book results in a window showing 'Font Files missing!' with a long list of fonts that it says it can't display because they aren't where they should be but in fact they do display though some seemed scrambled (so Arial showed up the Arial Hebrew font for instance).

    Any more thoughts anyone? I think SN does have a serious Font issue of some sort...

    Thanks

    James
  • James Blandford-Baker Level 1 (5 points)
    Thanks Magnus. I'm in Cambridge, England (and very nice it is too!). I've tried your solution but that hasn't made any difference. I notice too that Airport Utility shows up in the spotlight list as 'AirMac' followed by some Kanji characters (ie English and Kanji mixed in the same name). Addressbook also show up in Kanji.

    Any more ideas.

    Thanks for an help!
  • Roger Traill Level 1 (55 points)
    The solution seems to be that you have to have "English" in your language list not one of the English versions, ie I know have "Australian English" and "English". Neither adding US or British English fixed it.

    I worked it out as I have a "clean" admin user and it worked fine, looked in the language list and "English" was in it.

    It seemed to take a couple of spotlight searches before it switched the chinese characters off.

    I had tried turning all the kanji type fonts off but some couldn't be turned off as they were needed by the system (?). This had no effect.
  • aboywholikesapples Level 1 (0 points)
    Same problem here: Spotlight functions correctly, however, when I search for a system application, it's name appears in Chinese characters. My friend, who has the same system as me, is experiencing the same anomaly.

    In online forums I've scoured, users experiencing this issue seem to think it's font-conflict related, but nobody appears to be certain. I haven't heard of a single circumstance in which a user has taken specific action to remedy the problem.

    I suspect this problem is very widespread, but only Spotlight users are noticing it; hence the low level of reports. Touch wood, it's not a major issue, but I like things to be right and it's going to drive me mad until I resolve it.
  • aboywholikesapples Level 1 (0 points)
    Oh brilliant. So if you're British, you have to set your language to "English" and suffer system wide Americanisms or for the purposes of Spotlight, the OS will assume you're Chinese?
  • peejkerton Level 1 (0 points)
    I just wanted to add my voice to this. British English settings, and I am having this trouble too. It also happens within finder. Certain filetypes (such as Mail, Safari Documents, Text files) are all appearing in Asian Characters.
  • James Blandford-Baker Level 1 (5 points)
    Thanks, Roger, your solution works! Brilliant. The good news is that 'English' as opposed to 'British English' only needs to be i the list of languages, it doesn't need to be the first in the list so it makes little difference to the way the rest of the system works.

    Thanks so much for working this one out. Snow Leopard is now just about perfect for me!

    James
  • aboywholikesapples Level 1 (0 points)
    Roger, you are spot on.

    I apologise for ever doubting you. I followed your advice and added a RESTART, which made all the difference. Now those dreadful symbols, which made me hate the Chinese have gone.
  • chip.r Level 1 (30 points)
    For what it's worth, after upgrading to 10.6 I'm having the same problem and I have "English" set in my language list. There were three other eastern European languages set which I unchecked and I've just switched to Australian English to see if the switch back to English makes a difference. So far no luck but I have yet to try anything with my font book.

    Here are some samples of what I'm seeing.

    !http://img.skitch.com/20090904-kn3yk6rf9y19nnmitn7fmeitb2.jpg! !http://img.skitch.com/20090904-qjr8eyg1ybi36hwknram9s5sb3.jpg!

    Thoughts?
  • oldgustaf Level 1 (20 points)
    Having the same issue here in wild west Wales. See here: http://discussions.apple.com/thread.jspa?threadID=2136693&tstart=0
  • oldgustaf Level 1 (20 points)
    Yes, thanks very much - that's me fixed also. What a relief - don't we all hate it when we have a glitch in the system.

    Now, if only I could get a driver update for my HP laserjet...
Previous 1 2 Next