Previous 1 2 3 4 5 Next 106 Replies Latest reply: Feb 20, 2015 3:10 PM by dirodaman Go to original post
  • -DrD- Level 1 Level 1 (0 points)
    Try using "show desktop" in particular with any mouse button, that one in particular has the issue and the rest of the expose functions appear to be unaffected. See my earlier post.
  • neon x Level 1 Level 1 (0 points)
    In response to Acid, this is definitely not a problem specific to Logitech mice, as I said earlier, a friend of mines mouse, which is just a little cheapy USB no name brand mouse displays the same issues, so solutions involving the Logitech Control Center software are a no-go for him.

    And -DrD-, I have found that it depends on which mouse button I assign to a particular function that causes that function to die on a log out. For example, if I assign button 5 to spaces and button 4 to show desktop, I will loose show desktop on a log out, but if I assign button 4 to spaces and button 5 to show desktop, it is spaces that will die...

    As an interesting side note, if my button is in a dead state, I can assign the dead function to mouse button 3 (the wheel button), log out and back in, and it will work, and can then be re-assigned to the button that causes the function to die, that is until the account has been logged out of. Deleting the plist file is not the only way to get the buttons working again...
  • DLevin Level 1 Level 1 (0 points)
    Perhaps a related problem. Using a Razer Deathadder and trying to play World of Warcraft to no avail after upgrading to 10.6. Basically, the game no longer recognizes buttons 3-5 - even though the OS seems to recognize them outside of the game. Testing on an older machine with Tiger and the very same mouse and driver and game seems to confirm that this is a problem with the upgrade to Snow Leopard. I have contacted both Razer and Blizzard to see what they say, but this seems to be an issue with all multi-button mice perhaps and their interaction with applications. (Also tried to use OverDrive generic driver instead of Razer driver, but didn't work either.)
  • -DrD- Level 1 Level 1 (0 points)
    Neon x - interesting. It would seem as though we different yet fairly similar issues at this point. With my mouse, I applied exactly what you laid out, and in both situations, the button applied to spaces works correctly, while the button applied to "show desktop" doesn't work in either case.

    In any case, I really hope someone at apple reads this thread and applies a fix for these issues ASAP. So far they're my only negative point on the new OS.
  • Rich in Berlin Level 2 Level 2 (290 points)
    I've got the same (Spaces) problem with a bog standard 3 button USB mouse.

    Used to have button three (scroll wheel) assigned to open Spaces, after upgrade it now works like Cmd-D (app switcher). Options for Spaces confirm the problem. Next to my setting "Middle Mouse Button" is a warning symbol, so apparently something else has already hogged the button? But what? I can't for the life of me find anything.

    Curiously enough I had this problem occasionally with 10.5, if I'd had to force quit applications (or finder?). Things were always back to normality though at worst after a restart. Maybe new login or even just restart finder, I cant remember.

    But now the problem's persistent. And like others have reported, it'll appear to be fixed, then comes back again.

    I hope Apple get on the case beacuse I use spaces all the time and just cant get it into my head (or really want) to hit F1 - it was the very concept of triggering it from the mouse that got me into using it.

    Message was edited by: Rich in Berlin
  • lmarrero Level 1 Level 1 (0 points)
    Any updates?
  • Panjandrum Level 1 Level 1 (0 points)
    My problem seems related but not identical. Still, it might help those of us trying to troubleshoot this issue:

    For me, everything works as it always did, except that my "desktop" exposé command doesn't function with any f-key or mouse button assignments. F-keys and mouse buttons continue to work for all other exposé functions, and I can access "desktop" through the hot-corner function.
  • leonifan_UK Level 1 Level 1 (0 points)
    Just to let people know, I have logged this bug with Apple via the ADC.

    I have had this issue since 10.5, but it certainly seems more frequent under 10.6.

    Forcing the Dock to restart is a 100% reliable repro on my machine - anyone else confirm? (I have a small AppleScript file to do this for me).

    For the record:

    - My mouse is a 5 button Microsoft Intellimouse (my favourite mouse
    - I assign Spaces to button 5
    - Initally, after the upgrade from 10.5 (I did an over-the-top upgrade with all installer defaults, not an Erase and Install), I couldn't use Spaces via the mouse at all. Deleting that .plist file solved that particular problem (but the intermittent version still exists).
    - In my case (after the .plist removal), logging out and back in solves the problem for me. Restarting also. I realise that this is not the case for everyone (and mentioned both this link and that fact in the ADC bug report).

    I, like others here, only really started using Spaces once I realised I could attach it to a mouse button (same for Exposé). Without this functionality, I doubt I will continue to use the feature at all.

    Hope this info helps others to match the problem - and that Apple can now track the issue down!
  • deake Level 1 Level 1 (0 points)
    For info, I've resolved this for my Logitech Laser mouse (doesn't show model) by removing the plist preference file first (made no difference even after restarting) and then by uninstalling Logitech Control Center. May not have been any need to remove the plist.
  • stylez7 Level 1 Level 1 (0 points)
    I've had this problem when upgrading to Snow Leopard on my 2009 Mac Mini.
    In my opinion, I believe it's Growl causing this.
    I did a zero out erase on my hard drive, did a clean SL install, and made sure the first program I installed was Adium and Growl.
    Make sure you install those two before any other application. After those are installed, assign your mouse buttons for Expose and it should work. Hope my solution works for you all.

    Message was edited by: stylez7
  • stylez7 Level 1 Level 1 (0 points)
    ok nvm that didnt work lol
  • cjemmott Level 1 Level 1 (0 points)
    Logitech five button laser mouse here with the same problem. The fifth button cannot be assigned to anything, but 1-4 and the scroll wheel work as expected. Hopefully this will be patched in 10.6.1...
  • leonifan_UK Level 1 Level 1 (0 points)
    Small update...

    I have noticed this failing fairly consistently on initial boot from cold. I can resolve it every time so far by logging off (not restarting) and logging back in.

    Not a nice workaround, but hopefully it helps some of you!
  • Topher Fangio Level 1 Level 1 (0 points)
    I can confirm that this solution works for me as well. Will attempt to figure out exactly what the logout/login does that the bootup isn't.

    Message was edited by: Topher Fangio
  • leopard3 Level 1 Level 1 (0 points)
    i just came back to my iMac from labor day weekend and spaces and expose seem to work fine now. but still can't use my magnifying glass button to work for "switch application", which i have really come to love. what's going on here. i told my friends and girlfriend not to buy snow leopard yet. maybe if enough people do this Apple will get the message.
Previous 1 2 3 4 5 Next