1 2 3 4 Previous Next 124 Replies Latest reply: Aug 12, 2010 3:42 PM by amurepinho Go to original post
  • 15. Re: Problem connecting to my Windows (SMB) share in 10.6
    gambideluxe Level 1 Level 1 (0 points)
    That's the same what I experienced.

    Try this:

    1. Click menu Go - Connect to server ...
    2. enter smb://192.168.0.32 as the server.
    3. enter the *192.168.0.32\user name* and password I've been using.
    4. Select the smb directory I want.
    5. At this point SL throws a userid password error.
  • 16. Re: Problem connecting to my Windows (SMB) share in 10.6
    Dean Knowles Level 1 Level 1 (0 points)
    Hi

    I loaded last night SL and have no issues. I had some minor problems as mentioned here but it was OK will both my Windows PC's one with XP and the other with Vista

    There was another post on a solution that also worked fine which was

    1. Find actual Computer name of the Windows PC by right click on ->My Computer then slect properties to locate computer name
    2. Then CMD+K in finder
    3. Type "smb://[computer name]:139" then hit the "+" key on right to add to your list

    I assume 139 (or 193 I cant remember which)is a port, but then before this I use to get the IP Address in finder, but now get the Computer Name,

    Both ways work fine with IP or not

    Dean
  • 17. Re: Problem connecting to my Windows (SMB) share in 10.6
    drekka Level 1 Level 1 (10 points)
    Haven't tried specifying a port. However ... I just got it working. I telnetted into the DLink and changed it's security setting from SHARE to USER. I read another posting that tried this. It worked for me. Will have to look up exactly what this does at some stage

    I'f off to figure out why my Canon printer driver has disappeared

    Thanks for your help.

    ciao
    derek

    Message was edited by: d4rkf1br3
  • 18. Re: Problem connecting to my Windows (SMB) share in 10.6
    Jamie Kelly Level 3 Level 3 (975 points)
    Hi everyone,

    Same problem here, installed Snow Leopard over the weekend and only discovered this show-stopper this morning as I tried to login to sharepoints here at work (Monday mornings hey

    Seems the problem is DNS related; if you set your DNS settings to use a specified DNS server like OpenDNS, the problem goes away;

    https://www.opendns.com/start/device/apple-osx-leopard

    This bug didn't let me connect to Macs or PCs on the Windows network in the office. You can connect if you type the raw IP address into the Connect to Server command. But you cannot use the Sidebar to connect.

    It has something to do with Windows Reverse DNS lookup not working from what I can tell. By specifying OpenDNS this bypasses the bug.

    Please fix ASAP!

    Regards,

    Jamie
  • 19. Re: Problem connecting to my Windows (SMB) share in 10.6
    Bob2010 Level 1 Level 1 (0 points)
    Having similar problems with a NAS using an Addonics NAS adapter. With Leopard I could connect as Guest, but after updating to 10.6, I get a connection failure error saying that the server doesn't allow guest access. That is untrue since I have enabled Public/guest access on the adapter. It's the default anyway. In short there appears to be some undocumented differences (well at least not mad known widely) in the way SMB access is implemented in Snow Leopard. I've tried several of the things mentioned in this thread to no avail. Addonics seems to be very Windows centric and has no info. Any help by others with experience with the Addonics adapter would be greatly appreciated.
  • 20. Re: Problem connecting to my Windows (SMB) share in 10.6
    tributepower Level 1 Level 1 (0 points)
    I have exact the same problem. But now i think i konw where's the problem is.

    1. Connect to my Linux Server with Samba at Home
    Works. Samba Server has password encryption enabled

    2. Connect to several Samba Servers in my company
    Does'nt work, because all server have the password encryption disabled

    3. Try again with server at home, but switched password encryption off
    Does'nt work.

    I have no idea, how i can use the company servers. It's not possible to activate the password encryption for this servers.
  • 21. Re: Problem connecting to my Windows (SMB) share in 10.6
    Bryan Patrick Level 1 Level 1 (15 points)
    I was able to see the other Windows XP computer and begin to connect. I was then presented with a login screen. I tried using the usual user name and password - no luck. I then formatted the user name as as follows:

    user name: computer name\user name
    password: as normal
    And it worked. Specifically in my case:

    user: cwy-pln2152\administrator
    password: planning

    This is what worked for me your mileage may vary.
  • 22. Re: Problem connecting to my Windows (SMB) share in 10.6
    manuel deschamps Level 1 Level 1 (0 points)
    I tried everything and had no luck:

    1) encrypted passwords: on/off
    2) security: share/user
    3) public shares, etc

    I was able to connect using the smb client but I wasnt able to mount the share. Using public shares allowed me to view the files but not to modify them.

    I decided to dump Samba and switch to NFS
  • 24. Re: Problem connecting to my Windows (SMB) share in 10.6
    Robynhub Level 1 Level 1 (0 points)
    Same problem here. Works only w/o auth.
    I can't upgrade leopard in a production environment with this bug.
    It's very important for me fix this bug asap.

    If may help I use samba 3.0.33 on gentoo linux. Auth it's working on OSX Leopard, XP, Vista and Linux.

    Thanks in advance.
  • 25. Re: Problem connecting to my Windows (SMB) share in 10.6
    lamune Level 1 Level 1 (0 points)
    same problem , np with win 7 shares tho

    smb://192.168.3.100/f$ works for a win 7 box

    smb://192.168.3.1 does not work for a debian box, saying invalid username or pw, works if i used my old machine with 10.5.8
  • 26. Re: Problem connecting to my Windows (SMB) share in 10.6
    Dan DeRusha Level 1 Level 1 (0 points)
    We experienced the same issues with smb and invalid password attempts. If you try

    smb://server.domain.com/File_share
    The server prompts you for authentication
    username: domain\username
    password: putinyourPW

    I was able to access all our servers again. The key was placing the domain name in front of the username. Problem solved!!!

    Message was edited by: Dan DeRusha
  • 27. Re: Problem connecting to my Windows (SMB) share in 10.6
    yalej Level 1 Level 1 (0 points)
    Bob2010,

    I have the exact same setup and the exact same problem. I'm hoping a patch or some discovery will fix this.
  • 28. Re: Problem connecting to my Windows (SMB) share in 10.6
    Rastikan Level 1 Level 1 (0 points)
    Hi there,

    we are both having the same hardware. I have a Macbook Pro 17", a DNS-323 NAS and Snow Leopard. Did you have any luck with connecting to your NAS?

    Some people are talking about adding the domain next to the username (e.g.: domain\username)
    But is that really domain or machine name? From varying post it isn't clear. Also, for most of us at home, we don't really have a domain ( I think ) so in that case are we supposed to put the workgroup instead? (e.g.: WORKGROUP\username )

    Anyway, I tried all it still doesn't accept.

    I too can't connect to my NAS since moving (have hard time to say Upgrade...as right now I have less functionnalities then I did a week ago. I can't print, can't scan, can't connect to my NAS, can't use logmein.com anymore (unless I use the 32bit version of Safari). Also, I don't have my Antidote (french spell checking software) listed in applications services as before.
  • 29. Re: Problem connecting to my Windows (SMB) share in 10.6
    Rastikan Level 1 Level 1 (0 points)
    Oh one interesting thing to mention:

    Although I can't connect to my NAS the usual way (Finder CMD-K) I did before Snow Leopard, TimeMachine IS able to do so on the other share of my NAS (a DNS-323 unit ) which has the same user/password ...

    I guess both Finder and TimeMachine must be using different authentication scheme.
1 2 3 4 Previous Next