Previous 1 2 3 Next 124 Replies Latest reply: Aug 12, 2010 3:42 PM by amurepinho
Ekim Neems Level 1 Level 1
Hello all,

My Windows shared folders worked fine in Leopard but seem to be broken in 10.6 - if I do a Go -> Connect to Server... in finder and put in: "smb://192.168.10.7" I get "Unabled to connect to server, check the server name or IP and try again"

The weird thing is, it appears in Finder under the Shared section, and I can't login through there either. It just hangs on "connecting" forever.

Any ideas? Thanks!

Windows XP Pro
  • donv (The Ghost) Level 5 Level 5
    Could your IP be 192.168.1.107? I am not having problems with smb shares.

    Message was edited by: donv (The Ghost)
  • Ekim Neems Level 1 Level 1
    It's definitely the right IP, as I can connect to the computer via VNC and can ping it.
  • Badler050 Level 1 Level 1
    exact same problem here. any help would be greatly appreciated. work find before. id simply got to connect to server and have the following typed in smb://192.168.1.101/f and then it would ask for user name and password and it would connect. since upgrade it wont. trying to connect to windows 7 machine
  • Don Lozz Level 1 Level 1
    Do any of you have the Firewall turned on, on your Snow Leopard Macs? I found that there is a bug in the firewall preventing you from connecting to windows shares and setting up windows printers. Try turning the firewall off and try connecting to you windows boxes again. It should work.
  • brian.coates Level 1 Level 1
    I think I may have found the culprit - System/Library/CoreServices/NetAuthAgent

    Add that app to your firewall exceptions list and you can have both Windows SMB and your firewall. At least it worked for me...
  • gambideluxe Level 1 Level 1
    Doesn't work for me.

    Need another Solution.


    Greets
  • gambideluxe Level 1 Level 1
    The Problem was that I from now on have to specifiy the right server where my user account exists.

    this user: gambideluxe
    becomes
    this user: companyservergambideluxe


    this may helps in some cases.

    Message was edited by: gambideluxe
  • CKTaylor Level 1 Level 1
    This solution does not work for me. Keep getting the message "Invalid user name or password". Tried it also using a guest account with the same results. Server is a Windows2000 machine, connection is via SMB. This is a real problem.
  • JasonM Level 1 Level 1
    I just wanted to throw my hat in the "samba shares do not work in 10.6" ring also...

    MacBook Pro will not connect to our company samba shares. I do not have another machine freed up yet to test another system so I do not know if this is an irregularity with the MBP or not at this point.

    Normally, we could always use the smb://servername.domain/sharename approach to get things working fine. However, this no longer works and only gives the standard "You entered an invalid username or password" error.

    I tried disabling the firewall and also tried disabling IP6, but neither fixed things so far. I also tried changing the username to the full companyserver\username login and no luck there either.

    I will post anything else I run into if I find out something new.
  • adijk Level 1 Level 1
    Regarding the samba shares, I had the same problem. After adding 'public = yes' in the smb.conf for the share i wanted to connect to, on a FreeBSD box, my problem was solved...

    Hope this helps,

    Regards
  • donv (The Ghost) Level 5 Level 5
    I turned my firewall on. I still have no problem connecting to my smb shares. Using the firewall advanced tab, did you allow smb shares?
  • drekka Level 1 Level 1
    Same issue here. Setup:

    MacBook Pro 17"
    DLink DNS-323 NAS.

    Tried to connect and every attempt I get told I have an invalid username or password.
    Activated a guest account on the NAS and can get in no problems.

    Still trying to figure this out.
  • gambideluxe Level 1 Level 1
    @d4rkf1br3

    Did you try to specify the right server (your nas), where the user-account exists?
    e.g. user: 192.168.1.5\\{yourusername}

    Message was edited by: gambideluxe
  • drekka Level 1 Level 1
    I've currently got the NAS connected to the ethernet port directly because I was transferring some large files and wanted speed. By default the DLink sets itself up with 192.168.0.32 as an IP. So i've been connecting to that. Here's what I do:

    1. Click menu Go - Connect to server ...
    2. enter smb://192.168.0.32 as the server.
    3. enter the user name and password I've been using.
    4. Select the smb directory I want.
    5. At this point SL throws a userid password error.

    I'll also add that previous to the 10.6 upgrade, I had my password for the NAS in my keychain and after the 106 upgrade it stopped working.

    Could this be something to do with encryption? Just a thought.

    ciao
    Derek
Previous 1 2 3 Next