Previous 1 6 7 8 9 10 Next 137 Replies Latest reply: Feb 22, 2013 1:57 AM by Londoner86 Go to original post
  • cashman112 Level 1 (0 points)
    Add me to the list.

    2008 MBP
    Firmware Revision: DA09

    Can't burn CD-R from itunes, or from finder. Won't even try to burn DVD's until this thing gets fixed. I get the above mentioned errors in finder (the "because because" one) and the same mentioned in iTunes.

    Have tried refreshing PRAM as someone else suggested, but obviously nothing. Have changed the burn speeds to everything recommended by the CD-R including down to 1x.

    Maybe my local friendly (not) Amsterdam Apple retailer will magically solve this by laying hands on it and saying "Steve Jobs is amazing" three times.
  • distantbombs Level 1 (0 points)
    wow, I just tuned into this thread having upgraded my Macbook to Snow Leopard from Tiger last week and discovering I can't burn dvds anymore. CDrs yes, DVDs no.. My ancient copy of Toast doesn't even launch, which is fair enough I suppose, although others seem to have no trouble running it on SL - anyway, figured I needed to upgrade to Toast 10 but thought I'd check out the forum first and glad I did.

    Amazing this has been ongoing for 16 months with no resolution!! What gives??

    I've had much the same error messages as everyone else, even using Disk Utility or Burn, tried various brands of media, all failed..

    this is pretty astounding, a major flaw to leave unchecked. If nothing is resolved real soon I'll have to go back to Tiger, which worked just fine.
  • Matt W (TechnicalMac) Level 1 (25 points)
    NOT FIXED IN 10.6.6. Not that I expected it...

    I burned two coasters on a 2x DVD-R/RW in a MacBook (10.6.5) and 3 with a 4x DVD-R/RW in a MacBook Pro. Data was burned from 3 different sources, twice from externals via FireWire, and once from the internal disk AFTER repairing permissions and applying the 10.6.6 combo update in Safe Boot. I've covered my bases. I also believe it's a Mac OS issue. This is going to be expensive if I have to set up a special burning machine running 10.5.

    "The disc can’t be burned because because communication between the computer and the disc drive failed (error code 0x80020022)"

    Very sad. It's as if Steve killed support for discs.
  • Wayne Cater Level 1 (0 points)
    I am having the same problem. Googled the issue and I wound up here.

    I have thought to go back to Tiger, BUT I cannot easily. I need Safari 5+, and Chrome for my HTML5 development. Those browsers only run Mac OS 10.5 or greater. I don't have Leopard. I skipped that version completely.

    Any suggestions?
  • szent thomas Level 1 (0 points)
    same reply
    I am having the same problem. Googled the issue and I wound up here.

    anyhelp with this issue? this is new for me
  • DamenS Level 1 (0 points)
    I'm having the same problem, and like everyone else here, the problems only commenced when I upgraded to Snow Leopard. I've owned Macs since the Classic II and own a reasonable amount of AAPL shares. I think I am getting to the stage where this will be my last Macintosh computer due to the exponentially increasing level of hardware difficulties I have experienced in each computer "upgrade" cycle - and more importantly Apple's decreased level of willingness/ability to address/acknowledge said products since their rapid expansion and increased focus on iPOD,iPAD and iPHONE.

    Two Logic Board replacements on eMac (First one due to faulty ATI graphics card, second one soon after as the first replacement board was faulty), one macbook pro which can only access one memory module (common problem), two logic board replacements on my newish Macbook Pro (due to nVidia graphics problem for first one and then finding they had used faulty logic board which required replacement again for the second) and a battery which imploded and then started swelling, taking out the trackpad with it - apparently this is "normal" behaviour.

    Seriously, I will keep the Apple shares as they have further to run, but it is sounding as though Windows 7 (I can't believe I am saying this) is a more mature and stable operating system where things (like burning DVD's) just work and when there is a hardware problem, I can address this myself with a firmware update or hardware replacement. As I have not used Windows and have so much Apple software, I am currently researching "Hackintosh" options - at least then I will be in control of my hardware/software compatibility options and should be able to circumvent - to some degree at least - this increasing ability of Apple to deny or ignore problems and leave them unaddressed and unacknowledged for 1.5 years ... for me Snow Leopard has been Apple's "Vista" and Apple is adopting more and more of Microsoft's bad habits each day.
  • desireecross Level 1 (0 points)
    After working my way through a spindle of DVD-Rs (now coasters) I have found this topic!! I have just upgraded to a newer MacBook Pro which is running SL 10.6.6 and have found I can't burn DVDs. My last MacBook Pro was running Leopard and I didn't have a problem. Until I did a bit of research on the web I thought I just had a dodgy drive but after reading about everyone elses similar problems I ran heaps of tests. I've used toast, the finder, different media, different speeds. I've reset the PRAM, repaired disk permissions but I still get the error messages when verifying. Here's the weird thing and what makes me think it's software related... I can burn disks from files or DVDs ripped with my last Mac no problems at all. The files are stored on an external drive but they also burn fine when they're dragged to the new Macs HD. I migrated all my data from the last Mac to the new one using migration assistant so I don't know if that's screwed with anything? Aaargh! So frustrating!
  • Gavanj Level 1 (0 points)
    Dear Apple,

    I just switched from a PC to a Mac. First "upgrade", my isight stopped working. Second software upgrade and my isight is working again, but I can't burn DVDs. This is a basic computer function. Please release another software update ASAP.

  • EZ Jim Level 7 (22,030 points)
    Welcome to Discussions, Gavanj

    Gavanj wrote:
    Dear Apple,

    I just switched from a PC to a Mac. First "upgrade", my isight stopped working. Second software upgrade and my isight is working again, but I can't burn DVDs. This is a basic computer function. Please release another software update ASAP.


    (1) You are NOT writing to apple here. Read this:

    You can offer comments or suggestions for improvements directly to Apple from:

    Pick the product most closely associated with your concerns.
    You will not get a response, but you can be certain that the responsible

    Apple people will see your input for consideration in future products.

    (2) While you are waiting for the next update, the current Combo Updates sometimes fix issues that arise after an OS X update. Try the 10.6.7 Combo Update using the following technique:

      • Backup your Mac and turn off Time Machine

      • Disconnect peripherals and restart Mac

      • Use Disk Utility to repair permissions

      • Download and install

      • Repair permissions again immediately following the restart that finishes the update.

      • Test DVD burning. Reconnect needed peripherals and test again.

     (• Turn Time Machine on again when you are satisfied that the update worked.)

    Message was edited by: EZ Jim

    Mac Pro Quad Core (Early 2009) 2.93Ghz Mac OS X (10.6.7)

    MacBook Pro (13 inch, Mid 2009) 2.26GHz (10.6.7)

    LED Cinema Display; G4 PowerBook 1.67GHz (10.4.11)

    iBookSE 366MHz (10.3.9); External iSight; iPod4touch4.3.1
  • MEPK Level 1 (0 points)
    I'm completely new to this forum and trying to figure out why I can no longer burn DVDs. I get the error message: "The disc can’t be burned because because communication between the computer and the disc drive failed (error code 0x80020022)".
    Can someone please explain to me in the simplest non-techy terms what I should do?...if there is a solution out there.
    Thanks for your time.
  • benrobertsabq Level 1 (0 points)

    Same problem here. I can no longer burn DVDs after updating to Snow Leopard.


    Trying to burn from Disk Utility, not any 3rd party software, so it shouldn't be an incompatibility issue there.


    Tried with a couple of different sets of DVDs (DVD -R DL, DVD -R) which used to work fine before I updated to Snow Leopard. 


    Error is: "The disc can’t be burned because because communication between the computer and the disc drive failed (error code 0x80020022)".


      Model Name:          MacBook Pro

      Model Identifier:          MacBookPro4,1

      Processor Name:          Intel Core 2 Duo

      Processor Speed:          2.5 GHz

      Number Of Processors:          1

      Total Number Of Cores:          2

      L2 Cache:          6 MB

      Memory:          4 GB

      Bus Speed:          800 MHz

      Boot ROM Version:          MBP41.00C1.B03

      SMC Version (system):          1.27f3


    MATSHITA DVD-R   UJ-867:


      Firmware Revision:          HA13

      Interconnect:          ATAPI

      Burn Support:          Yes (Apple Shipping Drive)

      Cache:          2048 KB

      Reads DVD:          Yes

      CD-Write:          -R, -RW

      DVD-Write:          -R, -R DL, -RW, +R, +R DL, +RW

      Write Strategies:          CD-TAO, CD-SAO, DVD-DAO

      Media:          To show the available burn speeds, insert a disc and choose View > Refresh


    Guess I'm looking at a trip to the Apple Store so they can tell me to buy something.

  • benrobertsabq Level 1 (0 points)

    FIXED. For me anyway.


    I played with System Prefs a bit and now I can  burn DVDs again.


    Here's what fixed it for me:


    System Preferences.


    CD's & DVD's


    Previously my preferences were set like this, note the "Ask What To Do" in the first two options and burning failed:

    Screen shot 2011-06-15 at 7.13.45 PM.png



    Set your preferences like this instead, "Ignore" in the first two options.

    Screen shot 2011-06-15 at 7.13.03 PM.png


    Save your changes to prefs and exit.


    Insert a blank DVD.


    Wait for it to Spin up.


    Click "Burn" in Disk Utility, and off it goes as normal and writes the DVD.


    Makes absolutely *no* sense to me, but I made 5 coasters from two different sets of DVDs previously with my prefs set to Ask, and  now after setting them to Ignore, just burned 4 different properly working disks.


    Let me know if this helps anyone?

  • 1photographer Level 1 (0 points)

    2008 MBP. latest SL 10.6.8 with all updates installed as of 7/28/2011


    memorex DVD-R didn't work.


    DVD-RW works
    attiva 16x DVD+R works (burned at 4x speed)


    try diffent media. lot of people have success with DVD-RW.

  • lschong Level 1 (0 points)

    So having the same problem as most folks here - my macbook pro (late 2008 intel) stopped burning DVDs with any program after an upgrade to snowleopard - after much digging around, I found this post:



    The solution is to go get a CD/DVD optical lens cleaner disk, run it, and then magically, the drive can burn DVDs again.


    I tried it last night, it totally works.

  • BobLa Level 1 (0 points)

    Your suggestion worked for me. However, the first time I ran "Repair Disk Permissions" it only solved the problems for burning photos onto a CD but not songs from iTunes.  I then ran the "Verify Disk Permissions" and then ran "Repair Disk Permissions". This solved my problem and I can now burn disks again using my Mac Book Pro running Snow Leopard version 10.6.8  with the 2GHx Intel Core Duo processor.


    Thanks for your suggestion.

Previous 1 6 7 8 9 10 Next