Previous 1 2 Next 29 Replies Latest reply: Jan 15, 2010 3:26 PM by parags111
kmellem Level 1 Level 1 (0 points)
After installing Snow Leopard, I have a problem where Airport won't turn on in my iMac. Selecting "Turn Airport On" from the Airport menu bar icon doesn't work, and neither does clicking the "Turn Airport On" button in Network Preferences. Trying either just leaves airport off. My ethernet connection works fine. I'm not sure what the problem is. Any help or suggestions would be appreciated.

iMac 3.06 GHz Intel Core 2 Duo, Mac OS X (10.6)
  • Carolyn Samit Level 10 Level 10 (95,985 points)
    HI,

    Try deleting this file.

    com.apple.airport.airportutility.plist

    /Users/YourName/Library/Preferences. Drag that file from the Preferences folder to the Trash, empty the Trash and *restart your Mac*.





    Carolyn
  • AirPort-Guy Level 4 Level 4 (1,000 points)
    Any error messages in your system log?

    airportutility.plist is exclusively for AirPort base station configuration using the AirPort Utility and has nothing to do with the AirPort card.
  • JAlex F Level 1 Level 1 (0 points)
    I have the exact same issue, I believe.

    Airport will not turn on. I have only a hollow diamond on the top bar and if I go to network preferences, I cannot add in Airport. I've tried adding a new location, etc, but when I add an interface, there is no airport selection.

    In my system log, I get this:

    Aug 28 22:34:42 MacBook-Pro Apple80211 framework[233]: airportd MIG failed (PowerEnable Event) = 5 (Input/output error) (port = 23839)
    Aug 28 22:36:57 MacBook-Pro Apple80211 framework[233]: airportd MIG failed (PowerEnable Event) = 5 (Input/output error) (port = 23839)
    Aug 28 22:37:07 MacBook-Pro Apple80211 framework[233]: airportd MIG failed (PowerEnable Event) = 5 (Input/output error) (port = 23839)


    Of course it worked a few hours ago under Leopard. Thanks for any help; I hope that doesn't indicate hardware issues.
  • Pete H Level 3 Level 3 (570 points)
    Try deleting /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist and restarting. If that doesn't work, try deleting the entire contents of the /Library/Preferences/SystemConfiguration folder.
  • JAlex F Level 1 Level 1 (0 points)
    Thanks, Pete. I did do that and still no luck. I've been on with Apple tech this morning (escalated twice to an Airport specialist) and here is what we've tried:

    - deleted all of the associated preferences, trashed, etc
    - reset SMC
    - reset PRAM

    None of this worked. So we just tried booting to the 10.6 DVD (holding down C as it restarts) and surprisingly enough there is still no airport support then (no icon in the bar).

    To the OP -- can you try that? Boot to the 10.6 DVD and see if you have any airport support? It would be good if we both have the exact same issue that we try the same things to confirm.

    I just noticed the OP is on an iMac and not an MBP like me so it really confounds things to say we're not even on close to the same hardware but having similar issues that look like they are hardware related.
  • kmellem Level 1 Level 1 (0 points)
    Thanks for all of the responses.

    After I was unable to fix the problem last night (I didn't get a chance to try all of your suggestions), I put my iMac to sleep. When I woke up this morning, AirPort was working perfectly and I am no longer experiencing any problems. I'm not sure what changed, since I didn't take any action myself and a restart didn't help, but it seems that the problem has been solved.
  • Bansh Level 1 Level 1 (0 points)
    I have the exact same problem. The airport symbol at the top remains gray and empty when you try to turn airport on. Going into network preferences and clicking the button to turn airport on also does nothing. Ethernet is also working just fine. If yours fixed itself, I'm just going to wait and see if mine does the same before deleting stuff as mentioned above.
    Everything worked fine before installing Snow Leopard.
  • Bansh Level 1 Level 1 (0 points)
    putting it to sleep didn't work for me, we'll see what happens overnight =(
  • JedW Level 1 Level 1 (0 points)
    Noticed same problem today. Actually didn't notice this immediately as I don't normally use Airport, normally connected via Ethernet on my desktop iMac Intel.

    Exact same problem: Now Airport won't turn on since Snow Leopard installed.
    Tried: Zapped PRAM, removed the .plist file.... So "fixing itself" is only solution? Puhleeze Apple. Thank god I don't use Airport normally. But if I did? Totally *****.
    That plus "losing" my HP 5610 Printer due to HP's not having a driver available? Thats TWO huge boo-boos.

    The speed is nice but considering reverting to 10.5.8 until some of these issues are sorted.

    ARGH!!!!
  • William Kucharski Level 6 Level 6 (14,890 points)
    So what would you like Apple to do about your HP printer?

    HP decided not to support it anymore.

    That's Apple's fault how?
  • RussJP Level 1 Level 1 (45 points)
    Hi all
    I had almost the same problem, but my Airport would turn off. Anyway, I deleted the Automatic location in my Network Preferences and created a new location for Airport. Make sue you export your Airport settings to desktop first to make things easier.
    I then imported the settings to the new location and nowit's working fine.
    Hope this helps.

    Russ
  • internetmarine Level 1 Level 1 (25 points)
    I want to confirm the solution of creating a new location.

    I converted to SL and had a great experience. I was traveling and new wifi spots were fine.

    When I got home, the normal Airport link with a Snow Airport wouldn't work at all.

    That is when I discovered that I had to open the lock to get out of grey mode for many preferences.

    Created a new location after getting rid of the old made the link work fine.
  • JedW Level 1 Level 1 (0 points)
    Seconding (thirding?) this solution:

    Changed location from "Automatic" to a new location. Doing so re-enabled Airport to be able to be turned to "On".

    So thats pretty easy fix to any who encounter this problem. Thanks all for posting this solution.
  • Bansh Level 1 Level 1 (0 points)
    This worked for me as well! Thanks =) I am using the airport that is built into the Imac. I do want to add that under network preferences, there may be a yellow dot beside Airport, which usually indicates some sort of problem. Under status, it would also say "Airport has the self-assigned IP address 169.254.XXX.XX and will not be able to connect to the Internet." This is a change with the upgrade to SL, because it's actually looking for an external router (which doesn't exist because I'm using the built-in thing), according to tech support. So, just because you don't see a GREEN dot, it doesn't mean that there is a problem =)
Previous 1 2 Next