Previous 1 4 5 6 7 8 Next 246 Replies Latest reply: Nov 16, 2009 4:03 PM by Todd Wolseth Go to original post
  • Richard Richards Level 1 (5 points)
    Amending this one more time. There are a lot of posts on this thread, so let me summarize my problem. I was trying to recover my HP Laserjet 6MP now that OS 10.6 has done away with Appletalk. My focus was using the 6mp parallel port and a $20 Belkin USB-to-Parallel cable I purchased at Fry's.

    I abandoned an earlier attempt to hook my HP Laserjet 6MP via the Belkin USB-to-Parallel cable to my USB hub system. As I stated earlier the printer would get recognized as a USB mounted 6MP, and properly added with the 6MP Gutenberg driver. The first attempt to print was successful, but all other print attempts would end up stalling. This existed either on my iMac with 10.6, or hooked directly to the USB port on my PowerbookG4 running 10.5. So Snow Leopard was not the problem.

    As a last try I hooked the USB end of the Belkin USB-to-Parallel cable into an Airport Express that was on my system. Using my iMac with 10.6, I opened the Airport Utility but the Airport Express showed no USB printer attached. I made a minor change to this Airport Express's config, and restarted it. When it came back on line - the Airport Express recognized there was a HP Laserjet 6MP attached.

    Went to System Preferences-Print&Fax, and was rewarded with recognition of a Bonjour HP Laserjet 6MP. Added this to my iMac with the auto detected 6MP-Gutenberg driver, and printing is now perfect under Snow Leopard with no hang-ups. Have added it also to a MacBook Pro with 10.6 and it works perfect as well.

    Don't understand why it works via Bonjour, but not as a USB printer - but at least for now my trusty Laserjet 6MP is back in operation with Snow Leopard. For info I tried both an Airport Express "G" and "N", and both recognized the printer.
  • Janaki Kuruppu Level 1 (25 points)
    I don't know if I'm just lucky, but I have a LaserJet 3055, which, according to the list provided by HP, should only support printing, and not scanning (and we really need our scanner!). i tried running the HP Setup Assistant, and it didn't list the printer in the USB list. I followed HP's workaround suggestions (which didn't work), and then i did the following, which now has me up and running:

    1. ran HP uninstaller (both for HP software, and also HP EWS configuration)
    2. downloaded the most recent driver on HP's site (version 8.2 (03/17/2008) 24 Mar 2008 for Mac OS 10.5)
    3. restarted after installation, as prompted
    4. ran HP setup, and now everything works!
  • bbadon Level 1 (0 points)
    The following solution for the HP LaserJet 2100M was posted by siu-85 on the HP user forum. It also works on my 2100TN:

    1. Print out a configuration page by pressing the Go and Job Cancel buttons simultaneously.
    2. From the configuration pages, get the printer IP address (it shows on page 1 under Printer Information, or on page 2 under Protocol Information)
    3. In Snow Leopard Print & Fax Utility (under System Preferences):
    3. a. Select the IP icon at the top
    3. b. Select the Add Printer plus sign "+"
    3. c. Select Protocol "HP Jetdirect - Socket" from the drop-down menu
    3. d. Enter the IP address into the Address field
    4. Hit the Add button

    Once the IP address was entered, the Add Printer utility found the printer and auto selected the 2100 series driver.

    So far, the print function seems to be working just fine (although I haven't tried every possible configuration). However, HP needs to issue an updated driver so that others don't have to go through this work-around.
  • HP Mac Architect Level 3 (530 points)
    To be clear, there is no need to install Rosetta for ANY of our 10.5 solutions to get them running on 10.6. All of the HP printers that were supported on 10.5 were supported with Universal print drivers. That is why we dropped some printers back with the transition to Intel that happened with 10.4.10. If we couldn't do an Intel driver we didn't consider it supported. As for the main problem you'll find at the moment with the 10.5 drivers, its with 64-bit Snow Leopard applications since the drivers are not 64-bit. So if you happened to install Rosetta that's fine to get PPC apps running but is not needed for our solution.

    Just trying to help.

  • HP Mac Architect Level 3 (530 points)
    Regarding the Deskjet 5655, that device made our list of unsupported devices. The Apple Website mentions the Photosmart C5500 series, but the Deskjet 5550/5551 are also unsupported. I don't know any driver that will work, other then installing the 10.5 driver. The problem is where do you get the 10.5 driver as we never posted it to When I'm in the office on Monday I'll look into this problem and get back to. Sorry I couldn't be more help over the weekend.

    Just trying to help.

  • HP Mac Architect Level 3 (530 points)

    Regarding the LaserJet 1015 and the Airport Express, I've seen several different problems reported here ranging from simple to hard to fix. I'll give you my thoughts from simple to hard:

    1) Restart your Express. Believe it or not this seems to fix most issues after the upgrade.
    2) Make sure your Express is running the latest Firmware. I have heard several issues caused by this.
    3) Delete and re-install the HP software (fully described elsewhere). If you are seeing it connected via USB, but not the AE its possible you still have the 10.5 drivers, and not the 10.6 drivers provided for your device installed.

    If none of these fix the problem please post back any additional details you have and we'll see what we can do.

    Just trying to help.

  • HP Mac Architect Level 3 (530 points)

    To difference between USB on an network and USB directly connected is really simple to explain. When connected to a local USB port the driver sees that as a local printer, when connected to the USB port on an Apple Airport base station, the print driver sees that as a network connection. As you said the 6MP doesn't have a native USB port, likewise the driver isn't written to look for it on the USB bus.

    Just trying to help.

  • Andrew Chantrill1 Level 1 (5 points)
    Many thanks for your suggestions.

    I have unplugged the Airport Express many times today while using USB so it's been restarted probably ten times. I believe it is running the latest update; I use Software Update and know the Airport Extreme updated only recently; I'll check tomorrow that the Express is up to date.

    The real puzzle is that it's screwed wireless printing from my PowerBook, which is still on Leopard.

    It could, of course, be a coincidence, but I've never had a problem before in four years with it, and to go AWOL within minutes of completing the SL update is implausible.

    I'm really reluctant to delete all HP s/w and re-instal as I have to have a printer working this week and currently the HP2605 is working fine.

    If you have any tests I can do that would narrow it down then please shout!

    Thanks once again.

  • TripleChime Level 1 (110 points)
    The HP JetDirect 300X external print server can also be used to network older HP (and probably other brands) of printers that have AppleTalk and parallel ports. The 300X attaches to the parallel port and converts the printer into an Ethernet printer. I just checked eBay and these are readily available for cheap.

    I have been using the 300X for a couple of years with my HP 5MP (made in 1994) and it works great, and does NOT require AppleTalk, so it should still work with Snow Leopard. (My upgrade will be arriving in a day or two so I'll be installing it then.) I did upgrade the firmware on the 300X, and I had to set up a static IP address for the 300X/5MP via Telnet using the Terminal, as I never have been able to get DHCP (don't know why), but once it is set up it works fine.
  • Richard Richards Level 1 (5 points)
    Thanks for the explanation.
  • Robert Young4 Level 1 (15 points)
    I have a HP 4000N and a HP 4050N working fine under 10.6. Both were originally setup as IP print queues however, and NOT using AppleTalk.
  • Feek Level 1 (0 points)
    Can you tell me which driver you've used for the HP 4000N? I have the same printer and the only drivers I'm being offered are a generic postscript driver or an LJ4 driver.

    Under 10.5 I had an LJ4000 driver. This all seems very odd to me, that the driver existed before but now it doesn't.
  • CycloneJimmy Level 1 (0 points)
    Ed, I have a C4480 PhotoSmart HP all in one, and I'm thinking the same thing you are, but bawed on what I'm reading from many others, there are many brnads of printers involved in this snafu, so be careful. My printer still works, but Snow Leopard doesn't recognize the Scan function. I wish I had waited, too. 10.5 was so seamless. It's like living a Windows nightmare.
  • jbm5186 Level 1 (0 points)
    I just clicked on the link you inserted from HP on the printers that should work with 10.6. Is this a new list? Because when I installed snow leopard on Saturday, my printer would not work - it's a office jet 5610 - the list says the 5600 series is supported, so my question is do you know how recent this list is?

    thanks so much!
  • maggiecda Level 1 (0 points)
    Apparently a lot of models made the list but are not really supported. Andrew let us know that over the weekend. I thought HP would have released the drivers that made the list by now....but No such luck.
Previous 1 4 5 6 7 8 Next