Previous 1 5 6 7 8 9 Next 246 Replies Latest reply: Nov 16, 2009 4:03 PM by Todd Wolseth Go to original post
  • rkaufmann87 Level 8 Level 8 (47,985 points)
    I found an Apple Article that helps address connection problems for those using Airport Extreme or Airport Express. Please carefully read it paying attention the portion that states:

    +With Mac OS X v10.6 you can quickly add a "Nearby Printer"--a nearby printer is a printer connected to the USB port on an Apple Time Capsule or AirPort base station, a network capable printer that supports Bonjour, or a printer being shared by another Mac. Snow Leopard uses Bonjour technology to find nearby printers.+

    The link to the article is: http://support.apple.com/kb/HT3771

    Regards,

    Roger
  • PConvertee Level 1 Level 1 (0 points)
    I, too, lost my printer driver during the upgrade to 10.6. My printer is an HP Officejet 5610xi All-in-One. Tried the HP site only to find their driver was dated 2005 and would not install.

    I searched the Apple Support site and found the link to download the 10.6 HP printer drivers. When I clicked on it I was take to the Apple download page for Ricoh printer drivers? Weird? Sent a enquiry.
  • lindenburg Level 1 Level 1 (0 points)
    Worked for me too!
  • FerDeLance Level 1 Level 1 (0 points)
    Here's some further info on my issue trying to get OSX 10.6 to see my HP Laserjet 6MP which is on my LAN connected through an Asante Localtalk-to-Ethernet converter. Thanks to Andrew and others for pointers.

    If I set one of the other 10.5.8 computers on the LAN to share that printer, then my MacBookPro with 10.6 sees it as a "nearby printer" and can print to it.

    So that makes it look like it's not an issue of losing Appletalk...it's an issue of getting the 10.6 machine to recognize the 6MP behind the Asante Ethernet adapter.

    In earlier OS versions that adapter has worked transparently, with no need of or mention of setting an address for it. Nothing in the Asante documentation says anything about setting or detecting an xx.xx.xx.xx address for the adapter. And if it has an address, printing a config page on the 6MP won't show it, since the 6MP still thinks it's being served by Appletalk!

    Any ideas on how to get 10.6 to recognize this setup without the intervention of sharing by another computer on the LAN? Normally I don't keep that 10.5.8 machine on all the time. Otherwise my next step will be to install a parallel-to-Ethernet print server on the 6MP.
  • WMTA Level 1 Level 1 (10 points)
    Back in my happy days as a 10.5.8 user I had a Laserjet 4 and a Laserjet 6MP on my TCI/IP network, running as apppletalk devices and printing happily. Since they are HP printers they ran cheaply and are essentially, indestructible. Then I foolishly upgraded to 10.6 and bingo... no more appletalk printers. I have found and installed gutenprint and gotten the LJ 4 back but the 6MP did not have a TCP/IP interface and was originally a localtalk device with a plug for a 2 wire telephone line connector. (Some of you may not be familiar with this but, I am not lying... we used to do it this way) The 6MP sat on my network using a dongle made by the people who made phone-net connectors but the printer does not know what it's IP address is and I am not smart enough to find it out. I feel sure that, if I can find a piece of software that will tell me what devices are on my network and what their IP addresses are, i can get my ancient but still very functional printer back into action.
    And, by the way, Apple you SHOULD have warned us before you let us install a new OS that doesn't support older appletalk devices. turkey
  • wrauschuber Level 1 Level 1 (0 points)
    I agree - HP printer is not working and I would like to go back to 10.5 and have APPLE refund my "Snow Leopard" purchase. I am also having problems with MAIL. Snow Leopard is useless. I will be forwarding this email to an Apple Exec - My Cousin.
  • solo89 Level 1 Level 1 (0 points)
    I Hope you all can be this lucky, but I have a HP Laserjet 2550n connected over bonjour. I kept getting bounced back and forth from the HP site to Apple back to HP and back to Software update. Finally I went into my System Preferences, Printers & Fax and under the drivers menu for my printer I reselected the HP laserjey 2550 series driver.... and it works just like in Leopard. Who know I was going o have such an easy fix!

    Good Luck!
  • hellsbennett Level 1 Level 1 (0 points)
    Hey Davinian, Andrew is just trying to help. He's not to blame for this hitch. It's annoying (I am in the same boat) but blame HP / Apple, not Andrew. He's not the face of either oganisation.
  • Akky Level 1 Level 1 (0 points)
    Not sure if I have missed something or not but I would like to add that my Canon Pixma scanner is not very happy with Snow Leopard either.
  • rkaufmann87 Level 8 Level 8 (47,985 points)
    Sorry to hear about your Canon however this thread is about HP printers. You might want to start a similar thread for Canon, I'm sure they are having similar issues.

    Regards,

    Roger
  • Wan Chai Man Level 2 Level 2 (395 points)
    Sounds like a Vista upgrade....
  • Jedi0077 Level 1 Level 1 (0 points)
    Should be marked as such. This update was advertised as Leopard "finely tuned" no new features. Does not deliver I feel like a windows user all over again.
  • TripleChime Level 1 Level 1 (110 points)
    This IS an issue of losing AppleTalk. The LocalTalk-type connection requires AppleTalk to work, so all Ethernet -to-LocalTalk adapters will NOT work without the AppleTalk protocol. Ethernet-to-parallel print servers use TCP/IP (a different protocol) so they don't require AppleTalk.

    There is no IP address when using an Ethernet-to-LocalTalk adapter since TCP/IP is not involved in this configuration (AppleTalk autoconfigures). The Ethernet-to-LocalTalk adapter is actually using what is called 'AppleTalk over Ethernet' or sometimes "Ethertalk". Modern networking requires an IP address for each networked device.

    The best solution for anyone with an AppleTalk printer that will work under a different protocol, such as parallel is to use the other protocol, e.g. use an Ethernet-to-parallel print server. These are cheap (check eBay) nowadays.

    (And yes of course you can get a new printer, BUT I still run my 15-year-old HP 5MP printer the most because it uses less energy and it is quiet enough to run in the middle of the night without waking anyone up or making the dogs bark. My newer laser printers, though WAY faster, require so much power that they make all the lights dim while they are actively printing, and they clatter quite loudly. I doubt they will have anywhere near the longevity of my HP 5MP.)
  • eflyguy Level 1 Level 1 (0 points)
    Same issue here. Neither of our two Mac's will print to our L7700 since the upgrade, even though it is shown as supported.

    After finding and reading this thread, I d/l'd the full driver package (that should already be installed, right?) and installed it. Removed the printer (had done this already with no luck) and added again but as IP printer - did not show up under the default section (why??)..

    Anyway, it appears to work on my MacBook now - just printed a complex job from Acrobat without issue, and the status is showing up as it should.

    I am technical enough to figure this out but I feel sorry for those who aren't - especially in light of the most recent TV ad's regarding problems with PC's. Bad form, Apple..
    ..a
  • WMTA Level 1 Level 1 (10 points)
    If your printer has an IP address, you can download Gutenprnt for drivers and load the IP address and get to em that way. I was able to save my trusty 6MP by sharing it from my G4 cube.

    And yes, this WAS a bush league play, Apple.
Previous 1 5 6 7 8 9 Next