Skip navigation

Blurry/pixelated icons at random in Finder windows

150133 Views 473 Replies Latest reply: Apr 10, 2014 9:21 AM by jenmenke RSS Branched to a new discussion.
  • maulrat1967 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 24, 2011 12:49 AM (in response to KANahas)

    same result in Lion again for me:

     

    The action “Run AppleScript” encountered an error.

    Check the action╩╝s properties and try running the workflow again.

  • KANahas Level 1 Level 1 (0 points)

    Hmm.... Curious. How far do you get through the app before it throws this error?

     

    > If it occurs after the dialog, but before the Dock/Finder restart (as in they don't restart), then it is potentially a problem. Likely, the unix command "find" exited with something other than 0.

     

    > If the problem occurs after the Dock/Finder restarts, the cache has been successfully been cleared, but there might be a problem with some of my AppleScript syntax. It's kind of annoying, but the task was completed successfully despite the error.

     

    Also, while testing on SL, I found that this error would occasionally randomly occur. Running IconFixer again usually fixed the problem for some reason.

     

     

    --KAN 

  • maulrat1967 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 24, 2011 1:55 AM (in response to KANahas)

    option A ... after the dialog but before the Dock/Finder restart ... after I click Fix My Icons I get a password prompt (the typical system user password prompt when you make changes) and as soon as I click OK the error is instantaneous

  • jaba23 Level 1 Level 1 (0 points)

    I've created a simpler but similar app for cleaning the icon cache some time ago - you can still grab it here if you want to try it: http://cl.ly/2o1O3W2j0N0l37411x3c

  • Tim Murray2 Level 1 Level 1 (85 points)

    My system has not has blurry icons for a few weeks now other than apply any OS update that's come out since then. I didn't do anything specific to fix it ... they just went away.

  • Couchcowboy Level 1 Level 1 (15 points)

    Yeah, my blurry icons seem to have gone away since upgrading to Lion. I've had lots of other problems with Lion, but at least it improved this one. Or is it because I've had to restart my computer so often? Hmmmmm.....

  • jaba23 Level 1 Level 1 (0 points)

    Here's an updated version of the Icon Cache Cleaner app: http://cl.ly/170M050L3N1Q421Z2944

  • Dolphbucs Level 1 Level 1 (55 points)
    Currently Being Moderated
    Sep 26, 2011 2:46 PM (in response to jaba23)

    Thanks for posting that. From time to time it hangs with Lion ( I think the various desktop wallpapers reloading in Mission Control sometimes causes an issue ) but still easier than logging in and out.

  • Notary Sojak Calculating status...
    Currently Being Moderated
    Oct 3, 2011 10:09 AM (in response to jaba23)

    Thank you jaba. We'll give this a try.

    I finally got my wife set up on her new MacBook Pro (early 2011) ThunderBook bought when they were released in March. It has a clean install of Snow Leopard from the DVD. Rather than using the utility to suck her account setup from her old MBP to her new one, lest it bring over any flaky or corrupted pref files, we painstakingly went through every Control Panel and app Preference by hand, then transferred her several hundred Gig of working graphics files via Target Disk mode. All was well until this Saturday when suddenly the Finder icons for her graphics began degrading - view a folder of documents with Photoshop-created icons and it looks fine, scroll down and several begin to look like garbage, scroll back up the the ones you were looking at a second ago and now some of those look like garbage too.

    She had this happen once on her previous MBP running Leopard and a reboot fixed it. She rebooted her SL MBP and the icons looked fine for a while but then began degrading again - exactly as reported in this 2-year-old thread. Her normal workflow employed the same trigger the OP had - several folders in the Dock that had thousands of files with custom preview icons. We figured out a clumsy way around that bottleneck and suddenly all her icons were fine again - no reboot needed. Until this morning when virtually all files with custom icons look like garbage. Hard to tell which image you are looking for when they all look scrambled pay-TV channels.

     

    We tried stripping all custom icon previews and turning on "show preview icon" in View Options and the icons then cleared up. However, now the folders take minutes to display their contents in the Finder or a File Open/Save dialogue.

     

    This is not an acceptable way to try to work. Hopefully your Icon cache Cleaner app will help.

    I expect no fix from Apple. If they ever did reply to my Feedback or emails I expect the "solution" would be - "You have too many image files in your folders. You should be using iPhoto or a professional asset management application to manage them instead of the Finder."

    I don't think Leopard can be installed on these ThunderBooks, otherwise I'd just do so.

     

    Message was edited by: Notary Sojak

  • Warchild13 Calculating status...

    I've tried all the apps, scripts etc and the icon problem is worse for me in Lion than it ever was in Snow Leopard and this is also on brand new hardware.

    I did migrate my files over from my old Snow Leopard iMac. I keep thinking that there's a hidden pref file I need to delete or something, and yes, I have deleted every pref file I could think of that could be causing this ugliness.

  • SeBiG Level 1 Level 1 (0 points)

    Same here with me. Lastest iMac 27", System 10.6 (No Rosetta anymore? Bye, Lion!) ***?

     

    This problem occurs to me after a while, when I do "a lot of icon stuff" (assigning several new icons to files & folders etc.) - still, when I reboot my Mac, all Icons are displayed as they should. Still, this new "it's a not a bug, it's a feature" from Apple looks like a cache problem and is definitively annoying.

     

    @ KANahas, starting IconFixerNG, the "Are you sure you want..." Splash Screen is displayed; after pressing the "Fix My Icons!" button and entering an admin pw the "AppleScript"-Error is displayed.

     

    Entering your app's package content and starting the MacOS/Application Stub, the terminal displays several error messages on my Mac:

     

    "Application Stub [878:903] No application name for definition file at path: /Library/Automator/Office.definition"

     

    "Application Stub [878:903] Error loading /Library/ScriptAdditions/QXPScriptingAdditions.osax/Contents/MacOS/QXPScripting Additions: dlopen(/Library/ScriptingAdditions/QXPScriptingAdditions.osax/Contents/MacOS/QX PScriptingAdditions, 262); no suitable image found. Did find: /Library/ScriptingAdditions/QXPScriptingAdditions.osax/Contents/MacOS/QXPXScrip tingAdditions: mach-o, but wrong architecture"

     

    "Application Stub: OpenScripting.framework - scripting addition "/Library/ScriptAdditions/QXPScriptingAdditions.osax" declares no loadable handlers."

     

    Maybe, this helps you in fixing the bug.

  • com.ben.genius.plist Calculating status...

    Lion Blurry Icon Fix

     

    1: Power off your computer

     

    2: When computer is powered down with the left hand hold Shift + Control + Option  and with the right hand hold the Power button for approximately 3 seconds the computer will not start on this step.

     

    3: After step 2 is completed with the left hand hold Option + Command + R and with the right hand press the Power button then hold the P key till the computer chimes then resets and chimes a second time. Release all keys after the second chime.

     

    4: Once the computer resets, in Finder press Go on the top menu bar and select Utilities from the drop down menu. In Utilities select Disk Utility, Once it opens select the name of your mac's hard drive from the list on the left. Under the First Aid tab select Repair Disk Permissions and allow it to finish it should take approximately 3-5 minutes to complete. After the permissions repair is complete return to Finder.

     

    5: In Finder hold the Option key and press Go on the top menu bar and select Library from the drop down menu. Find the folder Preferences and delete the file: Library/Preferences/com.apple.finder.plist After empty the Trash containing the file.

     

    6: Open Safari and navigate to the following address

    http://cl.ly/170M050L3N1Q421Z2944

    Download the Icon Cache Cleaner.zip

    Unzip the file and open the application, this will erase the icon cache files located in the system folders and reset safari, it will not reboot your computer just reset safari all other applications will remain open.

     

    This should have fixed the problem if you have the problem again try the steps over, if not contact apple although they will likely have you follow the same steps I outlined here.

  • MaestroCreep3k Calculating status...

    So, to sum it up:

     

    1. Zap PRAM

    2. Repair Permissions

    3. Delete Finder .plist

    4. Run 3rd party program (Icon Cache Cleaner)

    5. Reboot (and cross fingers)

     

     

    Unfortunately this will not solve the problem permanently, this is just a temporary pacifier. Not trying to sound like a stick in the mud but I've tried this long ago with only temp results.

  • Dolphbucs Level 1 Level 1 (55 points)

    And, simply restarting the system gives you the same results ( as has been stated here several times ).

  • MaestroCreep3k Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 23, 2011 4:00 PM (in response to Dolphbucs)

    thank you Dolphbucs .... what I wanted to say but didnt have the heart to do

1 ... 15 16 17 18 19 ... 32 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (10)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.