Previous 1 23 24 25 26 27 Next 479 Replies Latest reply: Mar 4, 2015 9:13 PM by TeriPettit Go to original post Branched to a new discussion.
  • Tracy Valleau Level 1 (35 points)

    Of course, I did -not say- it was "confined" to dmgs:  "I'm fortunate because I -can- reproduce the problem 100% of the time, at least with .dmg files. (Note that I'm NOT talking about the dmg file icon itself, but once you mount it and double click, the icon of the app it contains is pixelated, just like the Toast 11 issue above.)"


    As a developer, it's important to be able to reproduce a problem. You, specifically, can not reproduce it 100% of the time, which simply makes my point that the problem is "non-trivial."


    It's beneficial to this conversation that I -can- consistently reproduce it (but it's consistent only with dmg files for me), because that means I can make changes and correctly check to see if the problem goes away. You cannot do that because, as you point out, sometimes it happens for you and some times it does not. That makes it harder for you to track down than it is for me.


    As I noted previously, it is also the case for me sometimes a finder  icon will appear correctly and sometimes it won't.


    All of this taken together is what makes me suspect that there is a failure to determine the monitor resolution correctly each time it is looked up when deciding what icon to display... or something similar.

  • David Losada Level 1 (10 points)

    Sorry, Tracy. I didn't want to sound harsh but just clarify an aspect of the problem. English is not my native language and sometime it's difficult to find the correct "tone".


    Do you remeber the pixelated Mkvtoolnix icon in a previous post? Well, If I dig into the package look what happens:


    Captura de pantalla 2012-09-27 a la(s) 09.57.14.jpg


    The full res icon is there.


    But the Finder can't "penetrate" the package to read it:


    Captura de pantalla 2012-09-27 a la(s) 10.00.17.jpg


    Creating a new user account does cure it. But the rrot account is not affected. If I login as root, all the icons look perfect.

  • ASid Studios Level 1 (0 points)

    I started to see it this week, I just did this now and it fixed everything, Im not sure how long it will last though.


    While the Computer or laptop is running, Unplug the computer and remove the battery (if you can) When the power is off. Press and hold the power utton for 20 seconds. Reboot Computer and the blurry icons or in my case. image icon previews will be restored.


    Welcome to the world of PC with OSX updates.

  • donazipe Level 1 (30 points)

    One more on dmg files... I monted a dmg file, and the app within showed no icon. Copied to the main drive, no icon either... Ok, we all know that.

    Then, I don't know why, the menubar crashed... that means systemUIserver crashed... after few seconds, the whole parade of menubar icons showed up, and everything on the menubar was back.

    I remounted the dmg file and now... the icon was there, FULL resolution.

    mmm... just a coincidence?

    Next, I tried on purpose, on my other mac. Opened the same dmg image, no icon. I went to activity monitor, and I choosed "quit" for the systemUIserver process. Again, little icons in menu bar disappear, then the parade of icons in the menubar that come back... Then, opened the dmg file, and the icon was there, full resolution.

    Copied on the drive, and now too, icon in full resolution...

    Mmm... Does this silly bug has something to do with systemUIserver? does a menu extra in there interfere with icon display?

    (One more thing... I have my main drive subdivided in two partitions... macosx and windows via bootcamp. When I boot, both icons appear as the general drive icon. If I choose "get info", the personalized icon appears in the upper left box and then, suddenly, the personalized icon appears on the drive in the finder...

    all this is really puzzling me...)

  • Tracy Valleau Level 1 (35 points)

    Well, I'll be darned. I killed systemUIserver after reading this, and got exactly the same result: nice, shiny crisp icons in a dmg that an instant before was massively pixilated.


    Whee!  Something else to investigate!  Back soon if I find anything!


    Thanks, donazipe... I think you're on to something! 

  • Tracy Valleau Level 1 (35 points)

    Folks might want to try this and see if it works for you:


    Make an applescript from this single line:


    do shell script "killall SystemUIServer"


    (put a carriage return at the end) and save it out as an application.


    Then run it and see if your icon issues go away.


    I've some reason to think this isn't a permanent solution, and the script may need to be run again if the problem returns between reboots, but so far it's clearing things up for me.


    (A quick look at the console, searching for systemuiserver, shows that MenuMeters is putting in a very old routine called "menucracker".... the only other reference to is from Apple's own "eject" from core services...)

  • Tracy Valleau Level 1 (35 points)

    Nope... close, but no cigar.  I killed MenuMeters, hence MenuCracker, rebooted, and got the blurries again. Ran my killall SystemUIServer script, and got the nice icon.  Unmounted the .dmg I was testing with; remounted... and was right back at blurry again.


    So now I guess the question is why that particular symptom.   Back to the grind....


    (Can we get Apple to pay us for our time?)

  • ASid Studios Level 1 (0 points)

    This worked for me, no debugging no hacks, plain and simple. 24 hrs later and everything is still working as normal. Nothing is blurry.



    "I started to see it this week, I just did this now and it fixed everything, Im not sure how long it will last though.


    While the Computer or laptop is running, Unplug the computer and remove the battery (if you can) When the power is off. Press and hold the power utton for 20 seconds. Reboot Computer and the blurry icons or in my case. image icon previews will be restored.


    Welcome to the world of PC with OSX updates."

  • Tracy Valleau Level 1 (35 points)

    Well, four more fruitless hours, yanking out things; rebooting; killing systemUIserver... sigh...


    I can say that killing systemUIServer makes the _next_ dmg mount with a clear and crisp icon.... but usually only the next one.


    So, to at least avoid corrupting my icon database, I'm keeping the applescript to kill the uiserver on my desktop. Now (if I can remember) before I mount a dmg to install software, I'll run that first. That way I can at least drag over a good icon.


    What a load of nonsense....

  • David Losada Level 1 (10 points)

    Tracy Valleau wrote:


    I can say that killing systemUIServer makes the _next_ dmg mount with a clear and crisp icon.... but usually only the next one.


    What a load of nonsense....


    Exactly! I've prepared the script and the effect is exactly whay you say: after executing it, the next mounted dmg has crisp icons in it. But it doesn't last. And the icons in the HD are still pixelated. Look at the TechTool installer icon in the dmg after executing the script and at the installed application in the hard disk.


    Captura de pantalla 2012-09-30 a la(s) 11.25.55.jpg




    What the h... has Apple done with SystemUIServer on Mountain Lion?


    By the way, I've open a new discussion in the Mountain Lion section about this, since now it's affecting Mountain Lion. Is there a way to consolidate both of them?


  • donazipe Level 1 (30 points)

    First, thanks to Tracy and David for trying killing systemUIserver...

    Here there's another "me  too". I prepared the script... mounted image (ie, googlechrome.dmg), pixelated icon. Run the script. Mount again the image: icon is fine, full resolution. I eject the mounted disk, when I retry, pixelated icon is back... sometimes this happens on the second try, sometimes it is ok, but then it become pixelated after some time...

    I come back with my previous hypothesis: there is something in the menubar, linked to systemUIserver, that is causing this problem?

    Let's try to draw a picture. I have an iMac mid 2011, and a MacBookPro i5. On Both 10.8.2. The blurry icon bug appears on both.

    I have those menu applications on both macs:





    growl 2

    desktop utility




    hardware growler






    and, of course, some apple menu:

    keychain, airport, sound, timemachine, bluetooth, spotlight, notification center

    I don't think these have something to do, since they are not affected by killing systemUIserver. But who knows...

    Similarly, I would tend to exlude dropbox and littlesnitch, since they are installed on my girlfriend mac, and she has never seen this bug.


    I have some other menus either on the iMac or the MBPro (not both);









    I would kindly ask you if you have any of these (in particular, apps I have on both macs) running on your mac... Hoping we could track down the culprit(s)...


    For Tracy: the intuition about the old routine (menucracker) was pretty good... too bad it didn't solve the problem :-(

    I will try to check console to see if something else comes out... But at the same time, I think it could be worth to dig down extra menus...


    Thanks for all your efforts!




    PS: I agree with David. We should continue this discussion on the other thread:

    I will start to post on the other one too... hoping that somebody at apple reads that one too...

  • donazipe Level 1 (30 points)

    Continuing on:


    with some extra info on console errors for SystemUIServer...

  • ASid Studios Level 1 (0 points)

    Two days and counting and i fixed my low rez issue of icons and image thumbnails. All is good in my mac. :)

  • MoonRunner Level 1 (0 points)

    I have had the exact same problem. Never noticed any issue with .dmg files, only finder and folder icons, half blurry, half sharp and Photoshop CS6 not writing icons. When comparing what you have in the menu bar compared to mine, one thing I notice, I removed Fantastical a week ago, not because of the problem, I just went back to my previous program and I have not had any problems since then. The only other thing I did was in the Preferences.


    I went to Prefs >Displays clicked on Scaled and changed the resolution, as soon as the monitor changed I reset it to my default resolution and left it at Scaled, then I restarted. When I checked after the restart it reverted back to Best for built-in display again.


    I have no idea if either had anything to do with it but so far so good. After many restarts and starting up with external back-ups the problem has not come back and I sure hope it stays that way.

  • Notary Sojak Level 1 (135 points)

    I finally got a reply to my bug report on this issue in Snow Leopard. I was asked to see if we have the same problem in Mountain Lion because they are not going to fix it in SL. Rather a bummer for those of us who need to stay with SL for whatever reason.

Previous 1 23 24 25 26 27 Next