Previous 1 2 3 Next 35 Replies Latest reply: Feb 22, 2010 6:16 PM by stuffaman Go to original post
  • Mel Mann Level 1 Level 1 (70 points)
    I'm having a similar problem with my Epson Stylus Photo 900 attached to a MacBook Pro I just upgraded to SL. Using the Gutenprint driver I can print but have no real color management (where are my paper profiles?) and I can't check levels via Utility directly (crashes) or using Lite (printer not registered). I uninstalled the Gutenprint driver and returned to my SP900 driver and now I have no access to print controls - they have lines drawn through them in the dialogue box.

    I print out of Photoshop CS4 and Lightroom 2.4, and prior to SL upgrade had the control over this old printer that I needed to print. Now I have no control. Is there a fairly simple fix to this enabling the full print control I had before and access to Utilities, or should I just buy a new printer and send the bill to Apple?
  • -fisho- Level 1 Level 1 (0 points)
    Install, and then install, worked perfectly for me. Awesome, many thanks.
  • sf_artist Level 1 Level 1 (0 points)
    I have an epson stylus photo 1270, and just migrated to snow leopard on with a imac i5. I've tried EVERYTHING mention here, install latest epson drivers, uninstall gutenprint, and reinstall epson drivers, and CAN'T get any epson printer utility apps to work. I have and tried 4 version of Epson printer utility (regular and lit). They either 1. crash, 2. say my printer is not register or 3. startup but can't see my epson 1270.

    What am I missing here? the heads needs cleaning, but how when the utility doesn't run? Can't even test the print quality until this is run. This is the most frustrating part of my migration.

    Any suggestions out there?
  • sf_artist Level 1 Level 1 (0 points)
    Well, I'm replying to my own post. This has taken hours to fix with too many install and uninstalls of the printer and drivers. I'm so frustrated with Epson.

    For an epson 1270, you need to use the epson11874.dmg driver file and find version 2 of the Epson Printer utility. Version 3 and 4 doesn't work on the old 1270 printer. Plus all of the newer epson driver files don't support this older printer.
    These instructions should work: 1. remove the 1270 from the printer list, 2:install epson11874.dmg drivers, 3: re-add epson printer with driver driver 'EPSON SF 1270", 4: start up 'EPSON Printer' in the /Library/Printers/EPSON/InkjetPrinter/Utilites/ directory.

    Good Luck, Selina

    I guess this is epson way to get new photo printer sales.
  • Douglas McMillan Level 1 Level 1 (45 points)
    Thank you so much for this. I had a clogged print head and couldn't find the utilities using the standard Snow Leopard driver. I followed your instructions and hey presto it works!
  • stuffaman Level 1 Level 1 (0 points)
    Here is a tip to find out what ink cartridge needs replacing on the Photo 900 (maybe it works with others as well ... I don't know) when the red "replace ink" light is on when using Snow Leopard (since I switched to Snow Leopard my Epson Printer Utiities won't work to show me ink levels):

    Just press the ink button once and here's how to tell what cartridge needs replacing:

    Both lights flashing, Red light flashes quicker than green light: color cartridge is out

    Both lights flash at same speed: Black is out

    If ink light stays solid: Both cartridges are out

    Hope this helps. Alan Miller
Previous 1 2 3 Next