Previous 1 2 Next 21 Replies Latest reply: Nov 16, 2009 10:03 AM by randomdeanna Go to original post
  • Chris Kohuch Level 1 Level 1 (10 points)
    Agreed. I'll be filing a bug report as I use the encryption certificates for occasional financial communications with my brother who lives in East Asia. I'm worried though about how quickly something like this might get fixed as it is something of an edge case. Just to clarify, were the expired certificates that were crashing the security framework issued by Thawte or by someone else? Mine were self created using Keychain Access and DotMac (now mobile me).

    Chris.
  • chamois Level 1 Level 1 (5 points)
    Hi Chris,

    I checked and I was mistaken. They are not Thawte certificates, they were self-created for my mac.com email address just like you!

    Gilles
  • nkingsbury Level 1 Level 1 (0 points)
    ** cskemp - you have saved my bacon ! **

    Deleting the RSS folder worked and my day has lifted from utter despair.

    Thank you thank you thank you ....
  • Chris Kohuch Level 1 Level 1 (10 points)
    Sigh, still now working in 10.6.1 Guess I need to really sit down and formulate a proper bug report.

    Chris.
  • Ryan Vetter1 Level 2 Level 2 (460 points)
    What I did:

    Deleted the RSS feeds in the RSS folder; trashed the com.apple.mail.plist file; repaired permissions; updated to 10.6.1; restarted...

    Then Mail asked me to set up new accounts, instead of asking me to import my mailboxes. Initially, Mail crashed and Mail told me my mailboxes were damaged. So then it kept trying to import my mailboxes and folders, but kept crashing after importing only 1. So I did the above, and now it works.

    But let me say, don't import anything. Just trash the preferences file, restart, and recreate your mail accounts. It somehow, magically, pulled everything from the Mail folder in the library after creating these accounts, without any manual intervention. But you will likely have to rebuild each folder (click the folder, Mailbox>Rebuild). Then, all of your messages will be indexed and drawn up in those folders.

    I think like others have stated this is a bug in Snow Leopard, related to the Keychain certificates, in addition to something with the RSS folder.
  • Chris Kohuch Level 1 Level 1 (10 points)
    Interesting. I finally broke down, did a backup and upgraded my main machine (MacPro Tower) to 10.6.1 and the problem (DotMac certificates) crashing the security framework doesn't exist at all on this machine. So it appears the problem is isolated to my MacBook. I doubt that it is hardware related so I'm going to go back and do a clean install of snow leopard, then import my settings / mail / keychain data and see if the problem is software related and goes away.
  • randomdeanna Level 1 Level 1 (0 points)
    cskemp, the Address Book thing is what worked for me-- thank you SO much.

    "then, still searching for something, i read another post about the smart groups in address book again. so this time, i deleted the ~/library/application support/address book/AddressBook-v22.abcddb file."
Previous 1 2 Next