Previous 1 2 Next 24 Replies Latest reply: Nov 17, 2009 5:38 AM by timblewee Go to original post
  • Fullstop102 Level 1 Level 1 (0 points)
    I have had this same issue for a while with iPlayer. On 10.5 and 10.6. At first I thought it was to do with leaving it on a second display when I closed the display (it used to disappear before when I did that.)

    I thought the new gathering of windows may fix it in 10.6 so I could at least see it, but it seems it isnt loading like other people have said in either 32 bit or 64 bit modes.

    It works in the safari browser and even after a reinstall of iPlayer it still doesnt work. Does anyone know if there are any component files that would need to be deleted too, as I think this may be the answer.

    Thanks
  • JimmySpags Level 1 Level 1 (0 points)
    There's another thread going on Real Player on Snow Leopard. Down loaded Real Player 11 that comes with Snow Leopard would not show video. Recommendation to Download Real Player 10 from download.com and lock into dock. I did this and got video to play. BBC Iplayer radio also works. If you have Gmail, do a Google Alert for "Real Player Snow Leopard" to follow any progress from Real Player. They say there's a codec problem with RP 11 and Snow Leopard.
  • Richard Cartledge Level 2 Level 2 (435 points)
    Try
    http://sourceforge.net/projects/iplayerdownload/
    It is much better but if a programme has an age warning/adult content, you must first have agreed to this via the iPlayer site in Safari. Set the Download folder to Movies and you can watch them in Front Row too.
  • Strolls Level 1 Level 1 (50 points)
    Treating this as a random-problems-with-iPlayer-on-Snow-Leopard thread - and not replying specifically to Jay - I had some problems with this when setting up my mum's new MacBook yesterday.

    The way I fixed it was:
    - Quit / force quit iPlayer.app and move it from Applications to Trash.
    - Download the latest version of Adobe AIR http://get.adobe.com/air/ - install from the .dmg
    - Reboot & check that it it installed ok - http://kb2.adobe.com/cps/407/kb407625.html - the version shown should be the same as on the download page (1.5.2 at present).
    - Quit Safari completely.
    - Open Terminal and type `find . -iname "\iplayer"` (including the " quotes, but not the ` ones)
    - +*Check the results carefully.*+ In my case this found one or two iPlayer .plist files in Library/Preferences, the iPlayer downloads folder in Movies but these were eclipsed by +_a whole bunch_+ of cached Safari history files. All this stuff was moved over from my mother's homedir on her old machine.
    - If the results are OK to delete type `find . -iname "\iplayer" -exec rm -rf \\{} \;`
    - Open Safari, go to the BBC website, watch some iPlayer & click on the "download" button to the bottom right of the play window. It now works requires the reinstallation of iPlayer & subsequently works perfectly.

    I believe that the BBC try to be "clever" and make the movie files you've downloaded inaccessible (from outside the player) so that you can't watch them more than 2 weeks after download. After transferring a user to a new machine, I suspect there's no harm at all in deleting the downloads folder - they probably won't play on the new Mac, anyway. The stuff in the Safari caches folder is definitely safe to delete, and may very well have been the cause of my mother's problem.

    If there's anything else showing up that you're unsure of you can move it instead of deleting it, and you can save the terminal output using Apple-S so that you can later figure out where the files come from, if you need to. I'm pretty sure that for 95% of people it'll be safe to delete everything the find finds, but there's sure to be someone who's saved something important in his Documents with "iplayer" in the name, so do check carefully.

    Stroller.
  • Nuntius Level 1 Level 1 (0 points)
    This fixed it for me..after not having the program window open for the last week. Thanks
  • Robert Hemmerdinger Level 1 Level 1 (0 points)
    This worked for me....MANY THANKS!
  • Robert Hemmerdinger Level 1 Level 1 (0 points)
    Well all is working but now I'm having a strange little problem.
    When I go to download a program it takes me to the page that says I don't have iPlayer installed (and of course I do).
    I go though the process of reinstalling and it says I have the current version would I like to just run that -- I select yes, run now and hey presto all is good and it starts to download the program. Weird eh?

    Any ideas? To me it looks as if iPlayer install didn't do something to tell my browser I have iPlayer installed. Or does iPlayer look each time to see if you have it installed?
  • Rick Mosser Level 1 Level 1 (0 points)
    I had the problem of iPlayer Desktop not opening a window.

    Viewing on line worked ok. I have just fixed this by trashing ~/Library/Application Support/Adobe/AIR
  • Gingapunk Level 1 Level 1 (0 points)
    Trashing the Air folder in /library/aplication support as mentioned sorted it for me.
  • timblewee Level 1 Level 1 (0 points)
    Hi

    I was having problems with iplayer and a couple of other applications after upgrading to Snow Leopard. List Below

    BBC iPlayer not loading properly
    Photobooth not recognising isight camera
    itunes not recognising iphone when connected
    Spotify was unable to stream music

    I have since found a solution. It might work for you too.
    I had to do the following after updating adobe air, which also stopped bbc iplayer working.

    run Disk Utility (/applications/utilities/disk utility)

    select your OS X boot drive from the left pane

    Then click the Repair Disk Permissions button

    Leave it do it's thing (took about 20 mins on my machine)

    When finished shutdown the computer and remove the battery

    restart the computer using the AC Adapter

    when the computer has restarted shutdown again and insert the battery

    then restart the machine again

    everything on my machine was now working

    Hope this works for you. I don't know what it does but it works plus the machine seems to working a lot faster than before
Previous 1 2 Next