Previous 1 2 3 4 Next 57 Replies Latest reply: Feb 15, 2010 3:43 PM by blackhorse16a Go to original post
  • Mark Booth2 Level 1 Level 1 (45 points)
    OK, new problem apparently associated with what I did to fix Street View. Now that I've cleaned up my font duplicates and conflicts, the default font I'm getting in Safari is NOT the font I have chosen. I have Safari preferences set for Times 16 as the regular font and Courier 13 as the fixed width font. Yet, I do not get Times as my regular font anymore. The default font I am getting is a sans-serif font and Times is certainly not a sans-serif font.

    This is only happening on my Mac Pro. On my MacBook Pro (where I have Snow Leopard installed too), it also shows that I have Times 16 and Courier 13 selected and those are the fonts being used.

    I have confirmed that I have Times in my Root/Library/Fonts on both my Mac Pro and MacBook Pro. I do NOT have Times in my User/Library/Fonts on either computer. Yet, they two computers behave differently with regard to which default font is actually displayed.

    I've attempted to select a completely different font, restart the computer and then change it back to Times 16 and restart the computer again. No luck fixing it.

    If the MacBook Pro was behaving the same way as the Mac Pro, at least THAT would make sense. But the two are behaving differently with the exact same set up.

    Any ideas?

    Mark
  • Professor Pizza Level 1 Level 1 (0 points)
    I have the problem too. And I checked to see if it is different with a guest account and lo! It works.

    If I stat Google earth from the administrator account, it does not display a samll window (as with the guest account) - it goes full-screen and the dock is disabled. I have to quit Google earth to go to any other app.

    Another clue - the Windows version works perfectly with Parallels Desktop. I guess that rules out graphics card driver issues, OpenGL problems etc. etc.
  • nickoberg Level 1 Level 1 (0 points)
    moving the arial fonts to the trash and starting up street view (then "putting back" the fonts) helped! amazing how this is the fix! thanks!
  • Andrew Otwell Level 1 Level 1 (10 points)
    Ah, this is fascinating. I'm writing this in November, and actually started noticing the problem not with Google Street View, but with text in Flash movies. The Flash movie would work perfectly, except some text would simply not render. Google Street View not working for me was a secondary symptom. (FWIW, I experienced the exact problem seen by others here: GSV didn't work for the Admin account, did for a Guest, no amount of prefs/plist trashing or plugin reinstalling would fix it.)

    I'm not at the computer experiencing the problem right now, but this fonts thing is hugely encouraging. I'm looking forward to trying this as a fix!
  • Dave Rensberger Level 1 Level 1 (0 points)
    Trashing and restoring the Ariel fonts worked for me too! How weird!
  • Andrew Otwell Level 1 Level 1 (10 points)
    Well, I'll be. It worked for me too. Here's exactly the fix I used:

    - In USer/Library/Fonts, I moved the "Arial" font to a folder on my desktop. This was simply the file "Arial". (I also removed the file "Times New Roman" since I had duplicates).
    - In Mac HD/Library/Fonts, I confirmed that there were other versions of Arial, I suppose newer ones. I have the following. Note that these have the .ttf extension. You may have a different set:

    Arial Black.ttf
    Arial Bold Italic.ttf
    Arial Bold.ttf
    Arial Italic.ttf
    Arial Narrow Bold Italic.ttf
    Arial Narrow Bold.ttf
    Arial Narrow Italic.ttf
    Arial Narrow.ttf
    Arial.ttf

    In other words, I didn't do anything to my Mac HD/Library/Fonts folder.

    I quit and relaunched Safari, then Google Street View worked correctly. (Also my problem with text in some Flash movies not showing up also was resolved).

    Thanks Apple community! You are collectively geniuses.
  • Rich_A Level 1 Level 1 (0 points)
    OMG! Finally!! My Flash Player 10 problem is finally resolved! You guys ROCK! Font conflicts?! You've got to be kidding me!!! I dumped all the fonts in my ~/Library/Fonts and it resolved the issue I've been having with Flash 10 for a month.
  • Scott Fannen Level 1 Level 1 (20 points)
    Well, I just noticed over the last couple of days that Google Street View wasn't working on my Mac OS 10.6 MacBook too - for the life of me, I would have thought I must have used Street View since I upgraded to Snow Leopard the day it came out!

    Anyway, after seeing people reporting success with deleting user fonts, I wondered if deleting the font cache (using Onyx) would help - it didn't. Again, I saw the same problems - it didn't work under my user but did under a spare user account I had. Same problem in both Firefox and Safari.

    So, a visit to the my user folder/Library/Fonts/ and deleting the 2 Arial fonts there (which left plenty of Arials in my shared font folder) and it worked immediately.

    Weird solution - but it worked. Thank you folks!

    For the sake of anyone searching for this answer - some keywords - Firefox Safari Flash Adobe Google Street View Streetview not working doesn't work
  • bandwidth films dot com Level 1 Level 1 (0 points)
    thank you! This works a treat!
  • Kenneth Smith1 Level 1 Level 1 (0 points)
    Yesireee !!!! Me too!!
    Same symptoms. Streetview did not work in all browsers AFTER I migrated to my new iMac running SL from G5 desktop running Leopard. Did not work in migrated account, I should add. But did work in new Testing account.

    So frustrating. Then I found this Discussion. Eliminating Arial Fonts sounded wacky. But I did and now I am sending you my .....love. Geek love, baby. And many, many thanks.
  • nosebagger Level 1 Level 1 (0 points)
    I have been struggling for the past few days to get EWQL PLAY (a music sample library) working after upgrading to Snow Leopard, and had all but given up.

    I was also having problem with Street View, but not too concerned about it, when I happened to google this thread. Not only did moving Arial fonts from my user font folder to the Desktop and back cure Street View, it also cured PLAY!

    Thank you so much for this!

    Tom
  • Allan Eckert Level 8 Level 8 (48,050 points)
    Hi Tom;

    Your problem has nothing to do with the problem that the OP start this thread with, hence it is considered thread jacking.

    I suggest you start your own thread for your question.

    Allan
    tiger
  • blackhorse16a Level 1 Level 1 (0 points)
    Wow! Did the same as Scott Fannen and didn't even have to restart Safari.

    It really works. So... is this a Google bug?
Previous 1 2 3 4 Next