Previous 1 2 Next 24 Replies Latest reply: Sep 23, 2009 2:20 PM by Scott Aronian
inforr Level 1 Level 1 (0 points)
Has anyone had any success with printing wirelessly to Lexmark printers after the upgrade to Snow Leopard? I have a X4550 printer and I am having no joy. The driver for the 3500-4500 series is included as part of 10.6 but CUPS is reporting the following error:

"Backend /usr/libexec/cups/backend/lexnet3 does not exist!"

The port that it is set up to print to is prefixed lexnet3://x.x.x.x:1

Mac OS X (10.6)
  • John Blanchard1 Level 5 Level 5 (5,030 points)
    It sounds like part of the software wasn't installed. Have you tried downloading the driver from Lexmark and reinstalling?
  • BuckRadio Level 1 Level 1 (0 points)
    Having the same issue. I can install drivers and print with usb but no WiFi printting in Snow. I did find this link from the past that has the same sound to it when Lepord was first released?

    http://discussions.apple.com/message.jspa?messageID=5893126#5893126
  • inforr Level 1 Level 1 (0 points)
    Reinstalling the driver from the Lexmark website appears to have resolved it. It does prompt to say the version is older than what is installed.
  • trevorhogg Level 1 Level 1 (0 points)
    For me, installing the drivers from the Lexmark site restored my wireless printing but then I wasn't able to scan (I would get the message "the software for this printer was installed incorrectly. Please reinstall"). Reinstalling resulted in no change.

    Also, every time I tried to print wirelessly the printer would be paused and I'd have to open the print & fax preferences and un-pause it to get it to print.

    For now I'm just going to live with using the USB cable... unless of course anyone has any more ideas.

    Thanks.
  • adamsfbay Level 1 Level 1 (20 points)
    I have been able to get my Lexmark X7675 to print wirelessly with Snow Leopard, every time.

    I have both a Brother MFC-9440CN (Ethernet) and the Lexmark X7675 (WiFi), and in both cases in SL it's clear you are better served NOT installing the manufacturer's software at all, but rather use the capabilities built into SL. Of course, I installed both manufacturer's packages first, so the first few steps here were to ensure I "undid" that step:

    1. From the SL DVD, optional installs, install ALL the printer drivers for all brands. You can be more selective if you like, but it's not that much space for less future headache. Find the Lexmark utilities on your Mac, and delete them. Find Lexmark pref files under user/library/preferences and /library/preferences and delete them.

    2. Open System Preferences: Print and Fax. Delete the Lexmark printer there if there is one. Then right click in printing list and select "Reset Printing System"

    3. Go to your Lexmark printer, and use its menu system to determine its IP address. On the X7675, it was printed out in a settings page.

    4. With this information in hand, return to System Preferences: Print and Fax. Add a printer. Protocol = LPD. Address = the IP for your wireless Lexmark. Name = what you want to call it. Under Print Using, "Select Printer Software" and find your printer name from the list. Add the printer.

    5. Believe it or not, open your browser. Enter this URL: http://localhost:631 Select "Printers" from the top menu bar. In the new page, click on the name of the printer you've just added. In the second drop-down list which now says "Administration" select "Modify Printers" and enter an Admin username/password when prompted.

    6. Select "LPD/LPR Host or Printer" and then enter lexnet3://ip.address:1/ where ip.address is the IP you've already identified for your printer. If it's 10.0.1.14, this should read lexnet3://10.0.1.14:1/

    7. Save. Go to /Library/Printers/Lexmark/PDEs folder and delete the entire PDEs folder.

    8. Open up Software Update. It may find a "new" Lexmark driver package. Install it.

    9. You should be good to go. Print a test page from your computer. Tip: in SL, when you've sent a job to the printer and its icon opens in the dock, I like to right click/options/"keep in dock" for future easy access.
  • p_styx Level 1 Level 1 (0 points)
    I have followed your instructions, but lexnet3://ip.address:1/ is being rejected by SL as being a "Bad device-uri scheme "lexnet3". Funny, because this worked in Leopard.
  • trevorhogg Level 1 Level 1 (0 points)
    Gave that one a try and got this when I tried to print:

    "There is a problem communicating with the printer. Make sure the printer is powered on and connected to the computer. Delete or hold the job and try again."
  • adamsfbay Level 1 Level 1 (20 points)
    That's odd - did you change the URL using Safari ... at http://localhost:631 and then select "LPD/LPR Host or Printer" as the type? and replace lexnet3://ip.address:1/ with your actual IP addy?

    Sorry if this doesn't work for you ... I've removed the printer and redone it and it works fine.

    Lexmark X7675
  • adamsfbay Level 1 Level 1 (20 points)
    Information on Lexmark site about Snow Leopard:

    http://support.lexmark.com/index?page=content&id=OS12&locale=EN&userlocale=EN_US

    Specifically:

    "USB connected printers are fully supported by the drivers included on the Mac OS X 10.6 install DVD. For wireless printers you will need to download new drivers from www.lexmark.com"

    Note that lexmark.com only has install packages for Leopard. So, it appears a Snow Leopard-specific drop of Lexmark software for wireless functionality is in the works.
  • p_styx Level 1 Level 1 (0 points)
    How did you manage to change "lpd://ip.address" into "lexnet3://ip.address:1" with SL? In CUPS after selecting LPD/LPR Host or Printer a new screen is presented to enter the printer connection. The examples presented here show the possibles formats, none of them being "lexnet3://ip.addres". OK, I fill in "lexnet3://ip.address:1" anyway and push the Continue button. The next screen lets me change the printer description. Again push the Continue button to enter the last screen, which lets me push the Modify Printer button, which presents the error message "lextnet3 is not a valid URI". Any suggestions? In Leopard the "lexnet3" prefix was accepted
  • scribbledehobble Level 1 Level 1 (0 points)
    I'm using a Lexmark X4850 and had the same problem of "lexnet3://ip.address:1" not working. After a lot of fiddling around and going through the CUPS help, I found that the following works (or seems to):

    Instead of selecting LPD/LPR Host or Printer, I selected AppSocket/HP JetDirect, then the address I entered was: "socket://ip.address"; after that, the rest was straightforward and that got the printer working.

    Of course, the scanner doesn't work over wifi so I have to break out the usb cable for that.
  • p_styx Level 1 Level 1 (0 points)
    Thx, this trick works for me too, don't know why though.
    I am using an X4550.

    Indeed, scanning doesn't work over Wifi; waiting for a new printer driver from Lexmark is the only option, I am afraid
  • Scott Aronian Level 1 Level 1 (30 points)
    Good to know that it worked. I tried it with my X4530, but couldn't get past it asking for an Admin password in the browser interface. I haven't assigned a password so the field was left blank, but that didn't work.

    I'm hoping the updated driver is available next week as promised.
  • Kurt S. Level 1 Level 1 (20 points)
    have a look into my todays topic : http://discussions.apple.com/thread.jspa?threadID=2141533&tstart=30

    This resulted from 10.5.8 lexnet3://192.168.xxx.xxx:1/ into

    10.6 uses LPD lexnet3://0020000xxxaxx:1 now the MAC adress is used

    Hope that helps
Previous 1 2 Next