Previous 1 2 Next 26 Replies Latest reply: Nov 11, 2009 10:07 AM by donv (The Ghost)
Ronald C.F. Antony Level 2 (435 points)
Here's the story: installed SL last night on my MacBook Pro, 4GB RAM, install was "successful" and upon reboot it was stuck at the Apple logo and the spinning progress indicator below. Since I didn't know what it was doing, I decided to go to bed, and in the morning it was still at the same spot, so obviously it wasn't just updating indexes, caches etc. which should be clearly be finished in 6h+ time.

So I tried zapping PRAM, rebooting, nothing worked. I couldn't even mount the machine in target drive mode, because the file system was supposedly screwed up, even though prior to the install it was fine and there were also no SMART errors.
So running DiskWarrior 4.2 (SL compatible version) on the drive fixed the drive. Still not bootable.
So I boot again from the install DVD, to be safe, do another disk repair and permissions repair, and install again: same symptoms: stuck at the Apple logo.
Trying a safe-boot (shift key), shows a progress bar (probably for fsck) and when that is done, back to the same: Apple logo and spinning progess indicator for ever.
Trying to force 32-bit or 64-bit boot modes (holding 3 2 keys, respectively 6 4 keys) has the same consequence: Apple logo, spinning progress indicator.

Given that Apple supposedly moves incompatible apps out of the way, and given that I reinstalled twice, checked the disks, have no SMART errors reported, etc. this is a fairly sobering experience.

If anyone has a good idea how to approach this short of completely rolling back to 10.5.8, please let me know.

(And, yes, you can talk geek talk, I'm a computer professional and developer, so I generally know what I'm doing)

PowerMac G5DP, MacBook Pro, iMac G4, PowerBook G4, NeXT, Mac OS X (10.6)
  • Carolyn Samit Level 10 (102,820 points)
    HI Ronald,

    You've really done your homework!

    *"So I boot again from the install DVD, to be safe, do another disk repair"*

    When you booted from your install disk, what exactly needed repairing? What types of errors were found specifically???

    Also, can you boot from the install disk one more time and check to see how much space there is available?

    Right or control click the MacintoshHD icon. Click Get Info. In the Get Info window you will see Capacity and Available. *Make sure you always have a minimum of 10% to 15% free disk space at all times.*


    Message was edited by: Carolyn Samit
  • Ronald C.F. Antony Level 2 (435 points)
    The first time around, the errors reported seemed to be rather severe, the kind DiskUtility didn't want to attempt to repair (forgot the precise message). DiskWarrior fixed these issues successfully. Also, prior to the install, the disk checked out fine. So whatever issues arose were due to the install, and/or reboot attempts.
    The second time, there wasn't anything to repair (DiskWarrior did the job), I just wanted to make sure DiskUtility agreed with that assessment). I even repaired permissions before the second install attempt, and there two minor permissions problems showed up (postfix related, which is essentially unused on a OS X client machine anyway)
    Now, of course, I have to force a shut-down each time I try to regain control over the machine, so I run DiskUtility before I attempt any other operation to recover from that (even though the journal should prevent disasters) and the file system checks out fine each time (as it should).

    The drive is a 500GB drive, with somewhere between 40-50GB free, which should be adequate (the 10-15% thing is a bit a thing of the past when drives were smaller, having 5-10x the free space requirements of the install and 40x the amount of what is likely the biggest single file on the drive, should be ample)

    So thanks for the concern, but the sort of obvious things like these I think I got covered, after all, this is about the 10th major revision of NeXTSTEP nee OS X I'm installing on various computers.

    I remember with Leopard there somewhat similar issues related to an incompatible version of APE/Haxies, but a) not even SafeMode boot works (and APE/Haxies aren't loaded in SafeMode), and b) Apple supposedly moves dubious software out of the way, and they are certainly aware of APE/Haxies given how widely these are used.

    Also, it seems from skimming the forums here, that I'm not the only person with the same or similar issues.

    One issue that comes to mind: does 10.6 (unlike 10.5) do anything relevant with the EFI partition? If so, maybe that EFI partition has become corrupted, but since DiskUtility so nicely hides the existence of this partition from users, it might be somewhat difficult to fix such a problem, if that truly were the cause. Plus, of course, one would hope, that the installer would nuke/recreate the EFI partition as needed, curing such potential issues.

    Verbose mode boot (v key) doesn't seem to work, either, so there are no meaningful diagnostics to be gathered. So maybe setting the boot-args value in pram may be worth a shot...
  • Ronald C.F. Antony Level 2 (435 points)
    Well, I went ahead and used
    nvram boot-args="-v -x"
    to force verbose, safe-mode boot.

    The boot gets stuck right after the message

    DSMOS has arrived.

    DSMOS of course stands for "Don't Steal Mac OS". That means that
    a) either Apple's anti-piracy provisions don't realize that this was an upgrade on an original MacBook Pro from an original Apple SN Retail DVD of an Leopard install that was made from an original Apple install DVD, OR
    b) whatever comes directly after the copy protection stuff gets loaded hangs the system before it outputs any message.

    While that narrows down the issue for an Apple engineer familiar with the boot process, it of course doesn't help me much, lest I were to try installing some Hackintosh kext, but I really don't want to have to hack an original Mac....
  • Tobin Richard Level 2 (155 points)
    I've hit the same problem.

    Install went fine on my laptop and has toasted my desktop.

    I can live with only the laptop for a couple of days but it'll get annoying very fast.
  • James Shepard Level 1 (5 points)
    Same here..... installed fine on my old 2.0Ghz Core Duo MBP but has toasted my 24" iMac at home....
  • Ronald C.F. Antony Level 2 (435 points)
    Here som additional data points. I proceeded to wipe the disk clear and install SnowKitty from scratch. That went without a hickup. Then I used Migration Assistant to transfer my programs and settings and data onto the new install from a TimeMachine backup.

    a) MigrationAssistant got stuck transfering NetworkSettings or something like that for well over 7h while showing 7 minutes left on the transfer for the entire time. Eventually I had to quit MA.

    b) upon rebooting: same issue as before.

    Result: something in my programs and settings is making 10.6 choke, but it's not clear what.
    Worse, even if I were to bite the bullet and started installing everything from scratch, I would have to do a full reboot after each third party software I install, to see if that prevents the system from booting, then noting that software as off-limits, erase the disk, and start again from scratch, without that software, and continue until I'm done with each potential offender. This could take days, or weeks to complete. Obviously, that's not a viable option, at least not as long as I'm not getting paid to do debugging for Apple...

    So at this point, I'm in the process of giving it one more try, installing from scratch, transferring only data and programs, but not the network settings, from the old backup, just in case some settings are what's causing the problems; the settings are easy enough to recreate. But if that also fails, SL is a non-starter, because there's currently no viable way to figure out what is the problem, since neither an upgrade nor an install plus MigrationAssistant lead to a working setup.
  • Peter Hinson Level 1 (0 points)
    Same problem here-
    Apple logo, spinning progress bar, the fan going like crazy.
    Installed on a month old, fairly fresh MacBook Pro system. 300gb of free space (500gb Seagate drive). Nothing unusual was installed on the machine.

    I was upgrading from 10.5.7, I believe the 10.5.8 upgrade had downloaded but not installed.
    I'm unable to access the install CD via holding 'C' at boot or preform a target disk boot.

    I'm afraid to even try installing on my heavily customized desktop!
  • Ronald C.F. Antony Level 2 (435 points)
    I may be getting a little bit closer to what's the deal here, but not close enough to have a solution:

    Since I previously first installed from scratch, and then manually called up Migration Assistant, I now tried to migrate data and settings directly during the install.
    This time I was lucky to be at the computer at the right time: I was down to 4 minutes remaining, when time zone, then computer and finally network settings were about to be transfered.
    As it got stuck with network settings, the time slowly went up from 4 minutes to 7, and there it stuck.

    So it's the same 7 minutes indicated before.

    Needless to say, when I force rebooted the machine after several hours of "7 minutes waiting", it exhibited the same problems.

    I will now try a last time, just transferring data and user settings, but not transferring computer settings, just to see if that helps.

    In any case, to some nay-sayers who replied to some comments of mine in other threads: yes, this is Apple's problem, because at that stage during the boot no third party thing should be loaded that should not be defeatable with safe-boot, and safe-boot won't help.
    IMO, it's Apple's responsibility to make an OS that as long as the executables that Apple supplies are present and not corrupted through hardware issues, the system will boot into safe-mode no matter what. If settings are missing or settings files are corrupt, they should during a safe-boot either be recreated or replaced temporarily with hard-coded defaults that allow the system to come up to the point where the user can take control.
    It's not acceptable that some sort of incorrectly upgraded or transferred or otherwise corrupted settings or preference file prevents the system from going on-line.

    Worse, I have a sneaking suspicion that if the user manually sets the password for the System.keychain, the migration software has trouble, but that's just that, a sneaking suspicion, because that's just about the only "non-standard" thing in my setup, and that's actually something any decent sysadmin would do; after all, why would you trust a system that holds key data (pun intended) guarded by a key that you don't know, can't retrieve and might possibly be accessible by some sort of undocumented back-door.

    Anyway, drum-roll, we'll see how this renewed attempt works out in 5h from now or so.
    If things work then, I'll have to redo all my settings, which is annoying but doable, if not, it's back to 10.5.8 for the indefinite future.
  • Jake126 Level 1 (0 points)
    I'm having the exact same problem. I tried the Shift reboot thing and nada. If you figure something out please let me know. I installed it just fine one system but the other is doing exactly as you described.
  • mattn3 Level 1 (0 points)
    Also having the exact same problem. Can't get DVD out, can't try to fix disk, can't boot off the DVD, can't do safe reboot, can't do anything but turn the computer off, turn it on again and then watch it spin away.

    There's enough people having this problem that it's fairly safe to say this is a problem with 10.6, but what? And how do I get my computer back?
  • cnewmanx Level 1 (0 points)
    Is ANYone from Apple monitoring this thread?
    I'm stuck at this point as well and no matter what key combination I seem to try it is still back to the same spot.
    It said reinstall SL if this happens on the knowledge base article but how do you get through the spinning indicator to reinstall?
  • mattn3 Level 1 (0 points)
    Having seen the knowledge base article (here's the link for people who need it: ) I'm hoping this is my problem too. But I also have no clue how to reinstall, since my mac is now in a state where there is absolutely no way to reach it. I have a call in to apple tomorrow and hopefully they'll tell me what to do.

    But if this is indeed the problem, all I have to say is, this is a major screwup by Apple. If I understand this correctly, it says that if you tried to upgrade when you had downloaded 10.5.8 but not restarted yet, you will kill your computer? Isn't this kind of an obvious possibility? It's just this kind of inattention to detail I expect from Microsoft, not Apple.
  • Slazareth Level 1 (0 points)
    I am almost certain that this is what I did. I had the software update pop up and ask to install but never rebooted to let it run before upgrading to SL. Dear Apple, please get us a fix for this ASAP. This is incredibly unacceptable. How hard would it have been for you to implement a check to see if someone had downloaded but not installed an update. Looking forward to a response from Apple on this. Ridiculous.
  • Tangu Level 1 (0 points)
    Exactly the same thing is appening to me too on my iMac 24", maybe it download the 10.5.8, but i didn't install it, i put the Snow Leopard dvd and install it.

    Now i have the spinning apple logo too.

    The FAQ didn't helping me:
Previous 1 2 Next