Previous 1 2 Next 25 Replies Latest reply: Jan 31, 2012 9:45 PM by peter218
thelostpatrol Level 1 Level 1
Can I get this to stop? I press play or pause in another app and iTunes launches and plays music on top of whatever else is already going.

It's really annoying. Started with 10.6.

MBP 15" 2008, Mac OS X (10.6), 2GB RAM
  • Yakovedees Level 1 Level 1
    This has happened to me also.

    Only after I have installed Snow Leopard, and it is really starting to grate on me.
  • Someone12345 Level 1 Level 1
    Yeah, I got hear from google trying to find out how to stop the exact thing! Anyone?
  • samsam51 Level 1 Level 1
    Yep, i have the exact same problem. Since I upgraded to Snow Leopard the play/pause button on the keyboard opens itunes when pressed. Still looking for a solution, any suggestions?
  • Nilse1 Level 1 Level 1
    Same thing happens here. Annoying
  • McMursu Level 1 Level 1
    Yeah, I have that same problem. I currently let it start and then put it on a store and minimize it. Annoying, but gets you around for now.
  • ChrisHillTucson Level 1 Level 1
    Yeah, I don't use iTunes to play music. Imagine that. I've looked in Keyboard Shortcuts and didn't see anything obvious. Neither in the iTunes preferences.
  • deergomoo Level 1 Level 1
    I also have the same problem, it's most annoying and I can't find any way to stop it. Surely Apple realises that there are other media applications out there that respond to these keys? It's really annoying pausing Spotify then playing again only to find that iTunes starts playing with it.
  • peakz Level 1 Level 1
    *For Snow leopard users*: Ok i didnt find an answer for this problem, but i tried to work my way around(for people who wants to watch videos on VLC and pause it with the apple remote/keyboard and itunes keep opening)

    *option 1*: open itunes and let it run but click on itunes store and hide itunes or minimize it. continue with watching videos on VLC and music won't play.

    *option 2*: Use Front Row to watch all your videos. To do so install PERIAN for quicktime(which allows you to play all formats in quicktime) and put all your movies in your "movies" folder. Enjoy watching movies through front row.

    *option 3*:(this one worked partially. ) Rename itunes in applications folder to "itunes_off". In order to do this you might need to make your user privileges to" read and write". right click on itunes and click on "get info" then go in privileges and click on little lock icon, enter your password and then change your user setting to "read and write". After this rename itunes to something else. But this solution didnt work correctly for me. it stopped opening itunes for a while but when i restarted my mac it started opening it again. Try if this works for anybody. And keep me posted.
  • peakz Level 1 Level 1
    I talked to apple care, they said the problem is not with snow leopard( What else are they going to say?)I think it is kind of true. We just have to wait for VLC, Plex, and Spotify updates in order for this problem to go away. It has nothing to with Apple. Just be patient for updates or 10.6.1 where they will fix a lot of issues with Snow Leopard.
    Just follow my above mentioned work around or
    launch quicktime at start up and hide it
  • Patrick Sikorski Level 1 Level 1
    How is this not an Apple problem? The other software that people use with the Apple Keyboard/Remote is working fine. It is (Apple's) iTunes that keeps popping up randomly when people push play to do something else.

    My story is, is that I press play on the Apple Remote to snooze the music that Aurora (alarm clock app) is playing, and when I snooze the music from Aurora, iTunes starts playing my rock music. That is not what I need to hear at 7:30 in the morning.
  • Examinus Level 1 Level 1
    This happens for me too and it's very annoying. It's certainly a problem with Snow Leopard or iTunes in Snow Leopard. Either way it's an Apple problem!
  • adriaaan Level 1 Level 1
    Also found this thread via Google. This is extremely annoying, especially since I barely even use iTunes, the music buttons are almost exclusively used with Spotify for me. Fix it Apple!
  • CHarvey Level 1 Level 1
    See this thread also:

    http://discussions.apple.com/thread.jspa?threadID=2122639&tstart=0

    There are some more fixes/hacks there-none of them are perfect though.
  • t0ms65 Level 1 Level 1
    Not only it is annoying because it keeps starting iTunes whenever it's not already started, whatever other software you might be using - but what is really annoying is that you can't change the behaviour. All is needed is a setting in the keyboard mapping preferences.
Previous 1 2 Next