Previous 1 2 3 4 Next 48 Replies Latest reply: Dec 28, 2009 10:06 PM by OWC Larry
sergeBmp Level 1 Level 1 (0 points)
Hi,

I've been trying to install Snow Leopard on my 2.8Ghz MacbookPro unibody (late 2008) with 6GB of RAM (4GB+2GB module).

At first, I did an upgrade of my existing Leopard drive, and when booting back in 10.6, everything was crashing (could not open a single web browser but Safari, for instance), and I was getting kernel panics each 10 minutes.

Then, I erased my boot disk and tried a clean install - I was getting kernel panics when installing! After 5 tries, it finally installed, and then I couldn't get through the welcome wizard the first time it boots.

So I removed the 4GB RAM module, and re-installed a 2GB one, and then everything was fine, not a single problem.

Take into consideration that that 4GB ram module was working perfectly under 10.5.8 (even while using the computer under a lot of stress) and passed all the hardware test.

Has anyone been successful at running Snow Leopard 10.6 on a late 2008 Macbook Pro unibody and 6GB of RAM?

MacBook Pro, Mac OS X (10.6), Macbook Pro unibody 6GB RAM kernel panic
  • Mike Evangelist1 Level 4 Level 4 (1,110 points)
    It could be that Snow Leopard stresses the RAM in subtly different ways than Leopard did, revealing faults that were previously masked. I'd recommend contacting the RAM vendor for a replacement.
  • sergeBmp Level 1 Level 1 (0 points)
    Yes, that's always a possibility (although unlikely in my opinion).

    This is why I'd like to know if anyone is using 10.6 with a late 2008 unibody MacBook Pro and 6GB of RAM.
  • deh2k Level 4 Level 4 (1,765 points)
    Along the same vein, Snow Leopard may be using some of that 6GB that was not used with Leopard.

    Have you tried taking some of the RAM out to see if that helps?
  • sergeBmp Level 1 Level 1 (0 points)
    Yes, removing the 4GB module and replacing it by a 2GB resolved the issue, but it still doesn't tell me whether the RAM module is bad or 10.6 has problem with late 2008 unibody MacBook Pro with 6GB of RAM.

    Since the hardware test pass fine with the 4GB ram module, and I ran 10.5.8 with it for a long time often under max memory usage, and that 10.6 kernel panic and crashes very quickly with it, I lean to think that the problem is 10.6.

    Hence, I'm asking whether anyone has tried 10.6 with 6GB of RAM with a MacBookPro unibody late 2008.
  • Foole Level 1 Level 1 (0 points)
    I have the same uMBP 2.8 late 2008 unibody 6gb and had the same problem with the system lockup after it was installed. The installation seemed to go fine. (your mac has stopped responding, power down, etc). But after this happened a couple of times things have been working OK for more than 2 hours with the same 6gb installed. I did update little snitch and reinstalled Softraid. I was accessing 2 sata drives through an expresscard when the lockups occurred. We'll see.
  • Leslie Bonney Level 1 Level 1 (5 points)
    Exact same MBP with exact same problem. Worked fine under 10.5.8 now Kernel Panics under SL.

    Sorry no answers.
  • ssn637 Level 1 Level 1 (30 points)
    Wow, this is really interesting! I own a UniBody MacBook Aluminum 13" 2.4 GHz 5,1 (October 2008) and ordered a 4 GB RAM module from OWC to max out my system to 6 GB for virtual machine use. I'd just performed a clean install of Snow Leopard a couple of days ago and was excited about the new operating system along with that additional RAM. But guess what? When I inserted the new 4 GB stick I suffered a kernel panic within minutes! I tried moving the module around between the two slots and inserting it on its own without the additional 2 GB module and the same lockups occured every time!
    Who ever would have thought this might be a problem with the new operating system rather than an incompatibility with the new module? OWC even agreed to refund my purchase but before I send the stick back I'll go ahead and install the original Leopard operating system and try again. Based on your experience I'm convinced the new stick will work and prefer more RAM than a newer operating system. Thanks to all of you for having posted this; I'd have never suspected an issue with Snow Leopard otherwise. In fact, I was hoping to be able to upgrade to 8 GB of RAM with 10.6. Turns out we may be better off with 10.5.8, at least for now!
  • Jeff Daggett Level 1 Level 1 (0 points)
    Well, Apple did specify 4GB as the upper limit for the Late 2008 unibody MacBook, and under Snow Leopard perhaps that is now the strict upper limit? I upgraded to 6GB, which seemed to be fine just running Safari, but when I began to put a load on the machine -- attaching an external monitor, working in Excel and, finally, just working in Mail -- kernel panic. (Vista under bootcamp also choked.) I've just reverted to 4GB to see if the kernel panics continue. So far everything seems normal, but I'll need a couple days to know for certain.
  • ssn637 Level 1 Level 1 (30 points)
    I stopped by the Apple Store and asked about RAM upgrades for the 2.4 GHz Aluminum MacBook. To my surprise, their database showed this model capable of 6 GB total. I guess Apple has updated their original restriction of 4 GB for this unit. So I made an appointment to bring my notebook in and they agreed to add a 4 GB module at a price comparable to those offered by third-party suppliers such as OWC. I'm curious as to whether or not they have problems with Snow Leopard. But if they guarantee this upgrade and I have lockups in 10.6 with it later I can always ask them to replace the 4 GB stick with one that works. I'll let you know how it goes.
  • alex_berth Level 1 Level 1 (0 points)
    How did it go finally since got the same issue here?
    One workaround is to use the 9600, it seems to solve more or less the kernel panic, but this is obviously not acceptable.
    Seems like a huge bug in SL as far as I am concerned, someone must have forgotten to test this in SQA!!! Steve where were you?
  • Jeff Daggett Level 1 Level 1 (0 points)
    Since returning to the original Apple-installed 2G x 2G memory modules, I've had no problems. Snow Leopard feels snappier to me, so I'm going with the 4G for the moment.

    I've not yet checked in with OWC, where I bought the 6GB kit. The (seemingly) offending 6GB kit consists of one Nanya 2GB 1066 PC3 8500S module and one Hynix 4GB 1066 PC3 8500S module. I remain inclined to think it was something about Snow Leopard that led to the kernel panics. For the moment I'm opting for the stability of the original 4G under Snow Leopard. Has anyone found that their 6GB kit works on the return to Leopard?

    Has anyone been able to get a 6GB kit to work under Snow Leopard? If so, what is the composition of your kit?
  • ssn637 Level 1 Level 1 (30 points)
    I've been forced to revert to the original 2 x 2 GB RAM configuration even after the Snow Leopard 10.6.1 update, after having tried both a 6 GB and 8 GB upgrade with the Unibody MacBook 2.4 GHz (Late '08). Even with Apple-provided RAM the system suffered a kernel panic within minutes in anything above 4 GB. When starting up the notebook under battery power the kernel panics occured almost immediately. I tried running the system without any USB devices attached, without any Airport hard drives connected, and even with wireless and bluetooth disabled to no avail. In all cases the system was running in 64-bit kernel mode. I just don't understand why the late '08 MacBooks can't handle as much RAM as the mid-2009 models with the same hardware.
  • CelloCello Level 1 Level 1 (0 points)
    Similar issues for me: after upgrading from 4GB to 6GB, I get kernel panics within a few minutes of startup every time, running 10.6.0 and 10.6.1 on a MBP 5.1 (late 2008).

    Strangely, I get panics even with just a single 4GB stick inserted. Therefore, I initially thought this was bad RAM (Kingston DDR3) but have the same issue with a brand new replacement from the vendor. The RAM was installed carefully and since it seems very bad luck to get two consecutive sticks of bad RAM, I'm wondering if there is another issue here...
  • nydennis Level 1 Level 1 (0 points)
    Could this be because the ram modules are not a pair? Would two paired 4gig modules work?
Previous 1 2 3 4 Next