12 Replies Latest reply: Sep 5, 2009 11:59 PM by -Boon-
fogster3215 Level 1 Level 1 (0 points)
I upgraded to Snow Leopard last night. I normally import photos into iPhoto by hooking up a SanDisk card reader for my camera's CompactFlash card. iPhoto pops up and imports the photos.

Now, I connect the card and the reader and the OS sees the disk, but iPhoto does not pop up. If I manually open iPhoto, it does not recognize that there's a card to import from.

I've tried disconnecting and reconnecting a few times, to no avail. Any idea what I might have to do to get this to work again?

MacBook Pro, Mac OS X (10.6), MacBook Pro
  • LarryHN Level 9 Level 9 (73,045 points)

    Welcome to the Apple user to user assistance forums

    1 - check the iPhoto and image capture preferences to be sure that the selection action when a camera is connected is "open iPhoto"

    2 - if that does not help quit iPhoto and delete the iPhoto preferences - "your user name" ==> library ==> preferences ==> con.apple.iPhoto.plist - launch iPhoto and reset any user preferences you have changed and if you have moved the iPhoto library repoint iPhoto to it

  • fogster3215 Level 1 Level 1 (0 points)
    Thanks for the help. Unfortunately, it still doesn't work. Perhaps this is a Snow Leopard issue and not an iPhoto issue.

    The iPhoto preferences show that "Connecting camera opens: iPhoto." If I launch Image Capture itself, it doesn't show the card connected. The card is auto-mounted on my desktop as a removable drive, however. Removing the com.apple.iPhoto.plist did not help.

    It almost seems like the OS is no longer detecting the digital camera card as a card of photos, as much as a random removable drive?
  • LarryHN Level 9 Level 9 (73,045 points)
    ALthough Snow Leopard is only three days old I suspect that if this were a SL bug many others would have seen and reported it

    The card is auto-mounted on my desktop as a removable drive

    See what format the card is? If it is mounting as a drive and iPhoto and image capture do not respond it might be a card format issue - it should be FAT any FAT formatted drive mounted will be seen as a photo device.

    Can you see the photos using the finder while it is mounted?

  • fogster3215 Level 1 Level 1 (0 points)
    The card is shown as FAT-16. It's worked for the past ~6 months this way, and has not been reformatted since.

    I can view the photos in Finder just fine.

    (By "Snow Leopard bug," I meant to imply that perhaps something specific to my arcane setup might have stopped working, not that SL won't see any cameras or card readers attached.)
  • LarryHN Level 9 Level 9 (73,045 points)
    That should work -- restart your Mac and see if that may help

  • fogster3215 Level 1 Level 1 (0 points)
    Rebooted a couple times, and moved the card reader between USB ports. Still not recognized in iPhoto.

    I'm going to manually copy the contents of the card over to my computer, and then reformat the card, in the hopes that it just happens to have become corrupted at the same time I did an OS upgrade.
  • fogster3215 Level 1 Level 1 (0 points)
    Reformatting the card did not help. It still shows up in Finder, but not in iPhoto.
  • Terence Devlin Level 10 Level 10 (135,530 points)
    If you drag the images to the desktop can you import them?


  • fogster3215 Level 1 Level 1 (0 points)
    Yes. The problem is that I don't clean the card off after every import, so it's importing a ton of photos that have already been imported. iPhoto's importer is smart enough to recognize images that have already been imported, but apparently not when you do it this way.

    Whoa! Okay, after the import was about an 1/8th of the way into importing the folder on my desktop, iPhoto popped up and noticed the card that's been plugged in for the past 30 minutes with my one test photo. This doesn't make any sense, but I'm not complaining.
  • Stephen Schwartz1 Level 2 Level 2 (255 points)
    Same problem here. FAT32 formatted CF card inserted via the ExpressCard slot on my MacBook Pro mounts fine on the desktop but is not seen by iPhoto. Image Capture has no problem seeing it and I can even set IC to open iPhoto when the card is inserted, but it still doesn't show up in iPhoto.

    Very frustrating...
  • Terence Devlin Level 10 Level 10 (135,530 points)
    Copy the files to the desktop then reformat the card in your camera. See if iPhoto sees it then.


  • -Boon- Level 1 Level 1 (0 points)
    Hi fogster3215,

    I had the same problem you did when you upgraded to SL. When I was in Leopard there wasn't a problem with iPhoto recognizing my SD card as a camera. Only after the SL upgrade it didn't work and I was left disappointed.

    However, after some lengthy searching (that's how I found this discussion) and testing, I finally found a quick and easy fix (well I can't guarantee that this is a perfect fix, unless apple resolve this issue at their end).

    Try installing this System Pref App called "Cameras" (http://www.flexibits.com/). I used it and it worked out well for me after a few tries (more on that in a moment). It's a 32-Bit app but it can run on SL, so no problems there.

    Problem encountered:
    The first time I installed it, it detected my SD card and I could use it with iPhotos like before. But only after I restarted my Mac it didn't work properly. Note that at this point I had my USB mouse plugged into the Mac.

    This may or may not happen to you but if it does, read on.

    The solution I managed to find is to UNPLUG any devices connected to your Mac, BUT LEAVE the SD Card (or the desired Camera) connected to the MacBook and then restart.

    After I did that it worked flawlessly (for now).

    I hope this helps.

    P.S. If all else fails, reformatting your SD Card on your camera MIGHT help. Just don't forget to back it up.