Previous 1 2 3 Next 41 Replies Latest reply: Apr 22, 2010 9:03 PM by Junebug172 Go to original post
  • bneely Level 5 Level 5 (5,255 points)
    Correct; Address Book is unable to set images for Exchange 2007 contacts.
  • fmdolan Level 1 Level 1 (0 points)
    I'm not sure that's the whole story, though, because I don't have Exchange and my address book wouldn't accept images either -- until it did, that is. That's a mystery, but I'm not complaining....
  • xrayspec Level 1 Level 1 (0 points)
    I had the same problem. I went to the info box for Address Book and ticked off the box that says "Open in 32-bit mode".

    Now adding / editing images works again.

    But it's definitely a bug...
  • Marco Mueller Level 1 Level 1 (0 points)
    Yes, Apple support just confirmed, that this is not supported.
    Thought that the most advanced OS with full Exchange 2007 support should be able to do this.
    Entourage does it somehow, even though pics added with Entourage end-up as attachments to the contact and will not sync to iPhone via ActiveSync. It seems the iPhone itself is the only thing working. Adding a photo to a contact and syncing via ActiveSync shows the photo in Outlook 2003, Outlook Web Access, Entourage and Address Book when connected to the Exchange system so Apple wins and looses at the same time :-/
  • O.L. Level 1 Level 1 (5 points)
    I can confirm that completely:

    Problem was: could neither d&d photos in the address book nor use the "Choose Custom Image" menu option with success. Only way it worked was copy images by CMD-c and paste in the image box by CMD-v. But then I could not crop the image in any way.

    Getting the info box in finder for the Address Book.app (CMD-i) and checking the "Open in 32-bit mode" option worked perfectly. Now d&d works and you get the nice cropping window.
  • JayLowe Level 1 Level 1 (5 points)
    This worked for me. I pasted the image in the box and it moved in perfectly. When I double-clicked on the box, the image crop window came up and I was able to adjust the picture.
  • fmdolan Level 1 Level 1 (0 points)
    Thanks for this. When I get info for the application, I can't find the option you speak of. Can you tell me where it is?
  • JayLowe Level 1 Level 1 (5 points)
    It's because you have a CoreDuo mac. Those are 32-bit only; mine didn't have the "run in #-bit mode" because there is only 32-bit.

    Just try the copy-paste trick.
  • fmdolan Level 1 Level 1 (0 points)
    Thanks. Mine actually began to work normally again, just out of the blue.
  • O.L. Level 1 Level 1 (5 points)
    Perhaps a dumb post, but just for the case:

    Tested the pasting and cropping again and suddenly it worked for me also in 64bit mode. But then it stopped working again. I found the reliable error source: When starting the Address Book.app directly, everything works find; however, when I open a contact via quicksilver, pasting and cropping images does not work.

    I post this here, because I myself am so used to use quicksilver, that I can imagine other people report this problem for the same reason. So, if you're a quicksilver user, try starting Address Book directly.
  • JayLowe Level 1 Level 1 (5 points)
    Brilliant. I second this. The problem only exists after I open a contact/Address Book via Quicksilver. Opening Address Book directly solves it all.
  • John566 Level 1 Level 1 (5 points)
    Checking 32bit mode also fixed mine. I'm running a 2008 MacPro w/ Snow Leopard and MobileMe.
  • NewMacMan Level 1 Level 1 (55 points)
    Was having the same issue. Whereas previously I was able to add photos by editing the vcard from "within" address book's main window, I now have to double-click the vcard, open it up in it's own window, then edit and drag and drop photo. That seems to work consistently.
  • bigphaty Level 1 Level 1 (0 points)
    I've had this problem too, noticed it today. Rebooted and still having the problem. So I opened console, cleared the display and watched it while I tried to reproduce the problem. And of course, while the mechanic is watching, the car won't make the noise. It worked as it should, although I did get this (probably unrelated) message: GrowlHelperApp[166] * attempt to pop an unknown autorelease pool (0x807600)
  • Zectbumo Level 1 Level 1 (0 points)
    I had the same problem. I quit AddressBook and set it to 32-bit mode as mentioned above and it worked. I quit AddressBook unchecked 32-bit mode, and now it still works. Maybe all I needed to do was reopen AddressBook. I hope this is the last time I encounter this problem. Oh, and nothing was posted by AddressBook in Console All Messages.

    Message was edited by: Zectbumo