13 Replies Latest reply: Oct 28, 2009 10:20 AM by mikey_23
{MollyC} Level 1 Level 1 (0 points)
Although Snow Leopard seems to have fixed my airport problems (yay!), now I am having printing problems. I print to a Brother MFC-8440 via the wireless network. I have the printer driver installed, and my computer connects to the printer, but either it sends the job, the printer acts like it will print, and nothing comes out, or the printer sends out pages of gibberish until I hit the cancel button on the machine.

When it does print, I get something like this:

ERROR NAME;
undefined
COMMAND;
{this part changes each job}
OPERAND STACK;

Any ideas? I've tried deleting the printer and adding it back in, but that doesn't seem to make any difference. This printer is on the list of supported printers, and the driver version is correct (1.4). The Brother website has not updated it's page for Snow Leopard, but I think it uses the Leopard driver anyway.

Thanks.

3.06 GHz iMac, Mac OS X (10.6), 4GB Ram
  • John Blanchard1 Level 5 Level 5 (5,030 points)
    This is a PostScript error. Does this occur with all documents? Even something simple from TextEdit?

    Does the same jobs fail if you use a direct connection to the printer instead of printing wirelessly?
  • {MollyC} Level 1 Level 1 (0 points)
    Yes, it happens with all documents, even TextEdit.

    Connecting directly to the printer is not feasible for me, as the printer is on the opposite side of the house. I guess if needed I could move my iMac temporarily to try to connect it directly, but that's obviously not a long term solution.

    I am using the CUPS driver; I believe under Leopard there was a CUPS driver and a non-CUPS driver. Would this make any difference?
  • Charles Dyer Level 4 Level 4 (2,620 points)
    Go to System Preferences/Print & Fax and delete the print setup for the 8440. Go to the printer, turn it off. Physically unplug the power. Wait 30 seconds. Plug it back in, turn it back on. Go back to the Mac and add the printer back. Print again and see if it works now. That cured my HL-2070 when it misbehaved a few years back.
  • John Blanchard1 Level 5 Level 5 (5,030 points)
    {MollyC} wrote:
    Yes, it happens with all documents, even TextEdit.


    Thank you. I thought it might be something document specific.

    I am using the CUPS driver; I believe under Leopard there was a CUPS driver and a non-CUPS driver. Would this make any difference?


    That might make a difference since there isn't a Brother driver available on Snow Leopard. If the above advice does not work and you are using the CUPS Snow Leopard driver, you could try installing the Brother driver from 10.5 to see if it works.
  • Emmanuel Lazard Level 1 Level 1 (5 points)
    After upgrading to 10.6, I wouldn't be able to print on my Brother HL-5170DN. I'm having exactly the same answer from the printer (ERROR NAME... COMMAND STACK) whichever software I use. (Remark: my printer queue wasn't upgraded, it had disappeared.)
    I've tried all solutions:
    - re-add printer in control panel,
    - reset printer queue and re-add printer,
    - reinstall drivers,
    - revert printer to factory settings.
    None worked.
    Finally, I saw that there was another PPD for 10.5 (Brother HL-5170DN series.gz), so I copied it and put it in my 10.6 /Library/Printer/... folder.
    Now it works...
    I hope they will upgrade their drivers soon...
  • {MollyC} Level 1 Level 1 (0 points)
    Well, unplugging the printer completely and reinstalling it didn't help any. I am having trouble locating a 10.5 driver on the Brother website, as the download is for scanning, which I don't do from my computer, so I don't care if I have that functionality. Brother seems to recommend the CUPS driver. Also, the scanner utility wants to know the IP address of my printer - how do I find that out?

    Is it likely that if I connected my computer directly to the printer that it would work? I don't think this is a network problem - my machine even recognizes the Toner Low message on the front of the machine, so clearly they are communicating in some fashion. I don't think connecting directly is going to solve this.

    Unfortunately I am not overly tech-savvy with Macs so don't even know where else to look for things.

    There is only one Brother file in the Library/Printers Folder.
  • Emmanuel Lazard Level 1 Level 1 (5 points)
    The drivers are in /Library/Printers/PPDS/Contents/Resources.
    At least, that is where I put the 10.5 driver I grabbed from my other Mac.
  • {MollyC} Level 1 Level 1 (0 points)
    Well, unfortunately I don't have access to my driver from 10.5. I did back up my whole system via Time Machine but I have no idea how to grab just the driver from it. And I can't find the 10.5 driver for the printer only (just the scanner) on the Brother site because it says it's all packaged in the 10.5 OS.

    Hmmm. . . maybe I'll just have to wait a few weeks to see if any other Brother drivers come out. I've been reading the Printers forum and see that others using Brother haven't had much difficulty.
  • hoyalawya Level 1 Level 1 (10 points)
    Hi, Molly.

    I just figured out the fix for this for my Brother MFC-8820DN, which should run on similar hardware and drivers as yours.

    I was able to install the 10.5 drivers from the "Optional Installs" option on the 10.5 installation DVD. In other words, I did not even have to use Pacifist to abstract them. An option popped up in seconds inviting me to install printer drivers and I clicked the "Brother" option.

    I was unsure what would happen when I attempted to install 10.5 drivers on top of 10.6, but it went fine.

    I then opened the Print & Fax Preference Panel and deleted the printer I had created under 10.6 and clicked the button to add a printer.

    This time, the panel offered me two options for the Brother 8820DN and I chose the familiar one from 10.5, "Brother MFC-8820D BR-Script 3."

    I then successfully printed documents from Microsoft Word and Preview (a PDF). Under the Brother driver that came on the 10.6 installation disc, I could not print from either program. I would get that "Operand" gibberish on the pages and the printer sometimes would print multiple pages until I intervened.

    So, for now, installing the 10.5 driver from the installation disc likely will be the quickest and simplest way to get your Brother MFC working again under 10.6.

    Good luck.
  • {MollyC} Level 1 Level 1 (0 points)
    Thanks, I will try that tomorrow. I do have the install disk from when I purchased my machine; hopefully that will work for me as well.
  • {MollyC} Level 1 Level 1 (0 points)
    Yay!! It worked. I was able to get the necessary driver from my Leopard install disk.

    For some reason I still can't print through Entourage, but I can now print from Word and Firefox. I can work around Entourage by printing as a pdf, then printing the pdf. It's not very direct, but still better than not being able to print at all. I'll go search the other forums to see if there's an Entourage workaround, and perhaps it will work after a restart.

    Thanks so much for everyone's input.
  • jbinders Level 1 Level 1 (0 points)
    If you can get an a 10.5 disk, try http://www.versiontracker.com/
    and look for the Brother MFC-8440 BR-Script 3. Hope this helps
  • mikey_23 Level 1 Level 1 (0 points)
    I just wanted to say, that I had to do the same thing but for a Brother HL-5170DNLT. Going back to my Leopard Install CD and using the 'optional installs' option I just installed the 'Brother' printer drivers. Once I switch to using the 'BR-Script3' driver everything worked!

    Thanks for the help before I asked for it!