Previous 1 40 41 42 43 44 Next 694 Replies Latest reply: May 22, 2014 3:56 PM by SantaFe67 Go to original post
  • beckmart Level 1 Level 1 (25 points)

    Thanks, mopppish, for your hint on switching off the external drive!

     

    I'm working with OS 10.6.5 and I had never seen that problem since I upgraded to OS 10.6 many months ago.

     

    Yesterday I had such a crash the first time:

    Finder does nothing any more, can be stopped immediately, but relaunch with the dock symbol has no effect. (no Finder at all).

     

    Today it happend again - it seems to have something to do with my external FireWire hard drive, as the crash happened while Time Machine was preparing a backup to that drive.

     

    When I finally switched off my external FW400 drive, the finder was responsive again immediately!

     

    Strange, I'd like to know how to avoid that problem in the future.

  • mopppish Level 1 Level 1 (10 points)

    ****.

    It just happened again. I had rebuilt launch services yesterday in hopes that it would help. Unplugging my external drive did indeed make everything make to normal, but only after Logic crashed again and I got the old "this disk was not properly ejected message".

    Guess I'll be spending a good part of tomorrow doing a new system install...

     

    EDIT: Really, Apple? I can't say d - a - m - n?

  • surigo98 Level 1 Level 1 (0 points)

    Found the solution on Cnet:

    http://reviews.cnet.com/8301-13727_7-10365239-263.html

     

    Basically it has to do with drives that are mounted mines was a network drive but it can also be externals. I went into terminal (you can get there through spotlight or quicksilver, if you have that app installed) I used the command "mount" and copied the mounted drive's name(and path) then used: umount -fv DRIVENAME after unmounting a few network shares my finder started working when I hit the right one. So good to not restart anymore.

  • arnj Level 1 Level 1 (5 points)

    This is a very serious issue that needs to be fixed by Apple.

     

    I just spent two days getting my MacBook Pro (mid-2010 model) back to working condition. It was out of commision, and I rely on it for business. I'll be getting a backup laptop in the near future for these scenarios.

     

    I've been working on Macs for years, and have never seen such an unsolveable mess as the dreaded

    *The application Finder.app can't be opened.* -10810 dreaded error.

     

    I'm posting this in hopes that it will help someone else in their troubleshooting. I think I tried just about everything. Keep in mind that I've got some extensive Mac hardware/software troubleshooting experience (not bragging, but offering for reference so you can have an idea about the competence of my attempts).

     

    I'm ashamed to say that my Time Machine HDD was elsewhere (for bi-locating backup purposes), and the backups were about a month old. I just hadn't gotten around to getting a replacement TM drive, so naturally, the problem popped up during this gap. Thanks Mr. Murphy.

     

    Here's my config:

    • MacBook Pro 4 2.66ghz i7/4gb ram/500gb hdd
    • Snow Leopard (recently updated to 10.6.7
    • Regularly cared for with Onyx and left on so Mac native cleanup scripts can run.
    • No AV permanently, but install/uninstall Norton and scan periodically
    • 2nd Apple 20" Cinema Display (circa about 2006-7)
    • slim Apple keyboard
    • Apple bluetooth mouse
    • Firewire audio interface
    • a couple of USB hdd's for Time Machine

     

    Here were my symptoms:

    • Overall slowness accumulating over the last few months.
    • Glitchy behavior after updating to 10.6.7 (occasional slowness, pinwheeling)
    • Made the eggregious mistake of closing lid when Photoshop CS5 was open with unsaved work (I was tired.. it was late). This is when the real trouble began.
    • Later that night, tried to wake Mac, which had never been an issue. It took about 30 minutes.
    • Tried to save document in Photoshop. No luck. Forced quit and lost work.
    • Tried to shut down multiple times. Waited a good 30 minutes again. No luck.
    • Forced power-down.
    • Upon power-up, which took forever (even after Finder appeared), Finder then "flashed" (appeared/reappeared) and ultimately crashed.
    • Spotlight no longer could bring up apps, like Terminal.
    • In fact, NO APPS would launch, at all. Tried from dock, spotlight etc. This included Terminal, which made things severely limiting.
    • Tried shutdown. Had to force again.
    • Started up again, got 10810 error. Apps still would not launch. Shutdown/restart not possible. This was now the permanent state of affairs until the end, with various dock appearances, dissapearances, Finder "flashes", icon dissapearances, items not being draggable.. and on and on.

     

    What I tried - none of it worked:

    • Many many many reboots.
    • Zapping PRAM and resetting PMU.
    • Booted up in Safe mode (still could not launch apps, including Terminal)
    • Booted up in Safe mode / held down shift again after login (this supposedly blocks any auto-starting apps for the account).
    • Booted in Safe mode >console. Terminal ran fine. This is the only time Terminal would run outside of booting to the install CD.
    • Tried the umount suggestions per the CNET article (and many other places) http://reviews.cnet.com/8301-13727_7-10365239-263.html
    • Booted w/ cmd-shift-v. Tons of disk0s i/o errors.
    • Booted to Snow Leopard install CD. Ran Disk Utility. Checked HDD and repaired permissions. No disk errors, and very few permissions issues (some help file w/ a bunch of jpgs needed repairing).
    • Tried deleting all the standard preferences files (see this thread and others) via >console Terminal.
    • Reinstalled Snow Leopard over top of existing install. Same symptoms.
    • At this point, I'm definitely thinking it's hardware. Booted into the Apple Hardware test (cmd-d) and ran extended testing. No issues.
    • Ran DU from install disk a few more hundred times. Zapped PRAM and PMU.
    • Even read somewhere that a low battery warning from a BlueTooth mouse could cause this. Put in fresh batteries. Really.
    • Created new admin user from >console. Tried logging in w/ Safe and non-safe. Same symptoms.
    • At this stage, everything was getting worse, not better. Icons vanished both in Safe and non-safe mode.
    • Followed some ill-advised advice to CHMOD the /private/tmp directory to 1777. Got vertical black/white bars upon reboot instead of gray or blue screen. Now only Safe mode brought up a useful visual.
    • Attempted launch services rebuild.
    • I'm sure I'm forgetting some things, but that's about all I can remember from the 18 hour marathon.

     

    How I fixed it.

    • Had Time Machine backup, but didn't want to restore the System via this thinking that it would bring back old ca-ca (would use TM to get back my docs et al).
    • Did one more backup via Terminal using ditto (an awesome command) of libraries, docs, photos, movies music etc. One MUST use ditto, because Finder copying wreaks havoc on permissions and resource forks. Ditto's faster and much less error-prone.
    • This part sucked. But I had to DELETE THE PARTITION and REFORMAT with erasing Zeroing out free space.
    • Reinstalled Snow Leopard.
    • Got system update 10.6.8 Combo via Software Update. Installed fine.
    • Mac is behaving fine now. I just need to reinstall all my apps. Fun fun.

     

    In retrospect, I should have just thrown in the towel and reinstalled much sooner. I was lead down the road of hopefulness by various posts about this chronic Snow Leopard Finder/apps issue. I was trying to "save time" and not having to bring everything back from TM / reinstall all my apps.

     

    In retrospect, the 2-3 hours of reinstalling things was probably healthier for my Mac going forward here, as I had "migrated" user directories from several Macs ago, and things were probably not as clean as they should have been anyway. I definitely should have known better.

     

    I also didn't call Apple support, as history has taught me that it's usually an immense waste of time. That may or may not have been true on this issue, but I probably should have "given in" at some point and called the "Geniuses".

     

    This is a very serious issue with Snow Leopard that has remained unrepaired by Apple. I think if we still are seeing it with Lion, this die-hard Mac fanboi may consider moving to the Evil Windoze Empire, or Ubuntu. I cannot afford the lack of productivity.

     

    Sending Mr. Steve and Feedback a message about this. Grrr...

  • Decodex Level 1 Level 1 (0 points)

    Honestly, I migrated to MAC thinking it will have less problem than Windows. Now that I see this thread I am now questioning if MAC is even better than Windows. In my 17 years of using Windows I rarely have problem as severe as described in this thread. Best of all, since 2005 I never had to worry about this problem because I started using Acronis TrueImage which basically boots before OS and can restore the partition byte by byte so I never had to worry about catastrophic failure ever again on Windows.

  • arnj Level 1 Level 1 (5 points)

    While this is a really serious problem, this is the first I've seen that was this unsolveable in 20 years of Mac usage.

     

    I've been using Windows and been a Windows server sys admin for many of those years, and anectdotally speaking, the Windows problems like this are quite a bit more common. I've had to redo so many Windows servers in the middle of the night with bizzarre unsolveable issues that it makes my head spin. There are countless hours of my life lost to my wife's successive Windows laptops that she keeps insisting on buying that end up having myriad errors, problems and infections. This has absolutely not been the case with my Macs over the years.

     

    Windows 7 is a vast improvement over the dogs XP and Vista, but there are still ongoing troubles. And don't get me started on the crappy untested hardware that's out there.

     

    I still say, knowing both of them very well, and using both for work that the Mac is by far the superior platform.

     

    Any type of computer is bound to have problems from time to time. The question is, how often (and how impactful)?

     

    I just landed on a rotten egg on this one. It happens.

  • beckmart Level 1 Level 1 (25 points)

    @ Decodex:

     

    I'm using Macs at home since more than 15 years and this is the first problem which is so serious that I can remember.

    (I had much more strange problems with the Windows machines of my wife.)

     

    I think MacOS and especially OS X is a very stable platform, but this issue shows that nobody's perfect and that having a recent backup or clone at hands can be very important at each and every moment.

    Anyway, the very very severe symptoms that arnj encountered, are really disturbing.

    :-(

     

     

    p.s.

    in general, I've become very slow in upgrading to a new OS X update, as I fear such issues.

    I'm still on OS 10.6.5 and I did not have this issue any more since my report above in this thread.

     

    Message was edited by: beckmart (added "p.s.")

  • Decodex Level 1 Level 1 (0 points)

    arnj :

    LOL! You must have been living in he11 for the past 20 years!! A WINDOWS ADMIN who is a MAC DIEHARD!

  • Decodex Level 1 Level 1 (0 points)

    @ beckmart

     

    Okay, so this is just the first such event in MAC.

     

    On a related note....so what do you guys suggest for a good backup program? (remember I am still very new to MAC platform, just started using it for the past year or so)

     

    As I understand TIMEMACHINE only backup user data, but not system/OS/program. So in event of catastrophic failure like this thread, it will still require me to install everything manually which could take hours.

     

    Is there anything that's like Acronis trueImage or Norton Ghost on Windows platform that let you back up the whole hard disk byte by byte ??

     

    Any suggestions?

  • beckmart Level 1 Level 1 (25 points)

    @Decodex:

    Time machine can (IMHO) backup everything, if you want, but the standard options exclude some system files as caches, logs, etc.

     

    I admit that I never had to restore a whole disk with Time Machine yet.

     

    TM is fine and I use it regularly (and it some times saved me when I accidentally deleted or changed a file, I still needed).

     

    In addition I'd suggest (as you want to) to regularly clone the whole drive to another volume (partition or disk image).

    You can do that with onboard tools:

    * "DiskUtility" (is part of OS X)

    or with 3rd party apps:

    * CCC (Carbon Copy Cloner) is great, free and can clone a disk byte by byte or just do incremental backups (also scheduled)

    * SuperDuper can do even more, but only in the paid version.

    Both tools are worth a look. There might be others as well.

     

    If you clone your startup disk to a firewire drive, you can easily boot from this clone, if ever your system should be damaged.

    And if this clone is (relatively) recent, there is nearly no loss and you can just go on working (or work on another mac, if yours should be damaged).

     

    As I've heard (as said above I never had to do that yet) recovering a system from TM backup might take some more time and you can not just boot a TM Backup, you have to restore it to another disk to have a usable system partition.

  • ds store Level 7 Level 7 (30,315 points)

    A 'hold c/option bootable' burned ISO of PartedMagic to cd and a couple of 'hold option bootable' time staggered/rotated free Carbon Copy Clones on powered external Firewire/USB drives are my recovery options.

     

    Along with a free WinClone copy (runs from OS X) of a Windows Bootcamp partition on another drive.

     

    Supposedly Clonezilla while c/option booted from a PartedMacgic or Linux cd has the ability to clone a entire drive, differnt formatted partitions and all, but I haven't gotten around to trying it, also OS X needs to be "blessed". Which CCC does.

  • bigstick Level 1 Level 1 (0 points)

    I have never had this error before until I upgraded to the latest system update. This was the one released last week (around June 20th?) in preparation for 10.7 Lion.

     

    Now I have the same problem occurring intermittently on my Mac Pro in the Office, and my MacBook Pro at home.

     

    In both cases, the problems were caused by connecting to external storage devices. One was a DVD which was burned on a PC without the session being closed (or something like that - the burn process had a problem somewhere) the other was a USB memory stick.

     

    Restarting fixes the issue - temporarily.

  • arnj Level 1 Level 1 (5 points)

    @Decodex: Yes, there have been many times when Windoze sys admin has definitely been less than fun - thankfully I'm not doing it anymore. I was in bliss when xserve came out, but alas, the $$ didn't seem to follow that kind of work.

     

    At least I have serious ammo when the Mac vs. PC argument comes up!

     

     

    @bigstick: In my crazy amount of research on this issue, it does seem that the 10.6.7+ updates have kicked in your variant (external storage causing the problem) for many, and then restarting / detaching drives temporarily fixed things. But only temporarily... posing a pretty big problem for people relying on massive external media and server storage.

     

     

    Helloooo ... Apple? Listening?

  • arnj Level 1 Level 1 (5 points)

    I do wish to report that several days after a full zero-ing out hard drive reformat, and full system reinstall (along with all my friggin' apps), my Mac is operating at peak performance, and literally better than when I first got it.

     

    That tells me that something was possibly brought over via Migration Assistant over a year ago when I first purchased the laptop (I brought in my multi-year User info from subsequent Macs).

     

    Once again, I learned my lesson (again), and will not **** around with "fixing" these issues when they get this serious. Reformatting and reinstalling turned out to be the ultimate fix for my scenario.

  • redcard78 Level 1 Level 1 (0 points)

    I've owned macs since 2003 and never ever had I had a problem up until a few days ago, when I received a brand new Macbook Pro i7. I migrated all of my data from my older 2006 Macbook Pro and hoped that this new notebook would blow away my previous one.. Well for my suprise, I started doing my very first Time Machine Back up and this new MacBook Pro started behaving like I've never seen a mac behave before. The finder which is essencially the only way you can operate the computer, started freezing and continued to become unresponsive. I would have to be foreced to do a hard reset on the computer. After serveral time machine back up tries I gave up after finder becoming not-responsive. Then I opted to manually dragging my most valuable files into my eternal hard drive, and again, the finder becomes unresponsive and there is not way to get it to force quit, I have to hard reset the machine. After only 32 hours of having this new laptop, I've had to hard reset this computer at least 18 times... The best part is yet to come.. I called Applecare support and they said: "Oh, this is typical, all you have to do is back up your data and do a fresh clean installation of OSX and reinstall all your programs." Yay!!!!!! Are freacking kidding me??? How can I back up my data if the **** finder won't allow me to copy anything to my external hard drive?

     

    I'm really, really ****** off!!! Apple charges so much more money for their machines but when it comes time to provide you with a solution to a problem they just easily blow you off!!

     

    I'm about to smash this thing against the wall and put it up on youtube!!

Previous 1 40 41 42 43 44 Next