Previous 1 41 42 43 44 45 Next 694 Replies Latest reply: May 22, 2014 3:56 PM by SantaFe67 Go to original post
  • arnj Level 1 Level 1 (5 points)

    If you know how to use Terminal, you can (and should) copy your stuff with a command called "ditto". It preserves permissions and resource forks of OSX files. Some Googling should get you the info on how exactly to run it. The Finder cannot handle certain mass-copy operations, but ditto can.

     

    But most importantly, you absolutely SHOULD NOT have to be going through this. I'd call back Apple Care or go to an Apple Store and INSIST that this is an out-of-the-box defective product, and they should give you a new one or a refund, period. Be firm and insistent. I once spoke to an Apple Store manager after many many unsuccessful hours on the phone with Apple Care. I had a laptop that was two years old, and had been repaired 3 times. I insisted they give me a new laptop, and pointed out the Lemon Laws in our state. They gave me a newer and better laptop that I used for three more years. The Apple Store manager pulled some strings that the phone care people would not.

     

    Be kind and courteous, but insist on being taken care of. My experience with Apple is that they will do the right thing ultimately.

  • bigstick Level 1 Level 1 (0 points)

    I couldn't agree more. Golden rules with complaining are:-

    1. Don't lose your temper

    2. Don't be discourteous with people who have nothing to do with your problem and aren't in a position of superiority which will allow them to make major decisions

    3. Be assertive, not aggressive. There's a big difference between telling someone "You sold me this POS, you can **** well make it work or give me a replacement", and "I understand you can't make these decisions but what have sold me isn't fit for purpose. I think I'm perfectly entitled to a replacement, please can I speak to someone who has the authority to make this decision"

    4. Remember that most people try their best to be helpful and do a good job. Unless you are an Apple Senior VP, you can't wade in threatening people and being unpleasant. That seldom works.

     

    Apple replaced my 3 year old Macbook Pro that had a 5th DVD drive failure with a brand new Core i5 model. For free. I didn't ask for it - they offered. I didn't have to get agitated, I just calmly pointed out that I relied on my laptop for work, was getting fed up of having something keep failing, and being without it for a week and a half while it was being fixed.

     

    To come back to the main subject, this is the machine I'm having trouble with at the moment. It isn't just the USB Finder issue, I'm having random performance slowdowns that are totally uncharacteristic of my machine. It's a bit like a 3 year old Windows system

     

    I don't want to have to reinstall my current OS, then install the brand new one maybe 2 weeks later. I know deep down that this is the best solution, but I'm also worried that transferring all my data, applications and preferences back might reintroduce the problem...

  • bradhs Level 1 Level 1 (0 points)

    The application finder can't be opened -10810 .... Seems to happen every time I put my computer to sleep late at night then come in the next morning.

     

    I am connected to network shares and believe that's the problem.  Everything eventually locks up.  I even get the window that lists all my network share and tells me they are unavailable with options to ignore or disconnect all.  Pressing either option locks up the computer even further.

     

    Any ideas?

  • aidanjones Level 1 Level 1 (10 points)

    I've been having the same problem myself and I've tried everything to fix it. But, I have a workaround for the time being (Hopefully this will be fixed when Lion comes out):

     

    1. Either set your browser to open files after download or set them to download to a folder you have on your Dock so that you can open them without having to go to the Finder to open them.

     

    2. Download muCommander. It's a free Finder like program and its the best one that I've tried. There's a version that runs right from the browser (http://www.mucommander.com/webstart/mucommander.jnlp) cso that you don't have to mount anything. Just double click the file (Or it should open if files are set automatically to open) and your done. It should work perfectly fine. The only thing I've noticed is that you can't read or write to other peoples user accounts. And if you really don't like muCommander, after you download it you can download a program called XFolders (http://www.kai-heitkamp.com/) which is another Finder alternitive.

     

    I hope this helped and lets hope Lion fixes this horrible issue (I hear its supposed to come out next week! ),

     

    - Aidan

  • Gabe Jacobs Level 1 Level 1 (0 points)

    So I did what seemed to be the only solution to this problem and erased my hard drive and re-installed the OS. I then updated with the combo update and everything went fine. So lastly, I used migration assistant to get my applications back and my documents. 2 hours later, BOOM 10810.

     

    So it seems the only way to get this problem is to erase your hard drive and NOT migrate your information. Please lion, please fix this.

  • arnj Level 1 Level 1 (5 points)

    aaaannnd ... here's the follow-up follow-up to my original post(s):

     

    So everything was hunky-dory for a while, and about 1 week into the full re-format and SL reinstall, it all got bad again - the minute I plugged in a USB drive.

     

    After having invested so much time, I decided that I'd done my part, exhausted all of my know-how, and conceded that Apple needed to take a look at this.

     

    The next morning, there I am sitting at the Genius Bar getting my bad hard drive replaced. Mega-bad sectors. They did it while I waited. Apple just simply rocks. They went out of their way to take care of me.

     

    But two things that don't "rock" are Disk Utility and the Apple Hardware Test. Both repeatedly showed my old drive to be in good shape. It wasn't true, and started this whole entire process of troubleshooting. Had one of them given me even a little hint of HDD trouble, I would have thrown in the towel.

     

    I'm now at 7 days with the new HDD, and happily plugging in the most raggedy old hackjob USB drives-in-enclosures I have, along with my Android phone, iPad and two USB hubs (not to mention a firewire audio interface). The computer's running better than ever. No issues.

     

    The moral? Park the ego and "knowledge" (even if you're an experienced Mac tech), and call Apple.

     

    Thanks for listening!!

     

     

    P.S. to SteveJ: sorry for the terse email.

  • beckmart Level 1 Level 1 (25 points)

    @arnj: thanks for sharing your experience.

     

    3 questions:

     

    1) So you say a defective INTERNAL hard drive created the problems occuring when connecting (many different) external drives?

     

    2) And if Disk Utility and Apple Hardware Test are not able to find those problems, is there a software freely available (or at least not expensive) which can find those hardware defects?

    (DiskWarrior, maybe?)

     

    3) Does that mean that the people here maybe all have defective internal hard drives with bad sectors without knowing?

  • redcard78 Level 1 Level 1 (0 points)

    Hello beckmart & everyone,

     

    I just finally received a replacement Western Digital hardrive sent to me under the manufacturer's warranty and initiated my time machine back up. Everything went well and smooth It seems that the problem I had with my new MacBook Pro i7 and the Finder crashing everytime I would attempt a time machine back up was my old hard drive. Even though it worked perfectly with my previous MacBook pro (Core2duo) and showed no signs of issues, it was causing my new MacBook Pro i7 to crash... After trying it all (repair OSX install, Reintalled OSX and all apps...) The new external hardrive worked perfecty and no more issues with the finder crashing and/or time machine.

     

    For those of you having the finder crashing and/or time machine crashing and hungging up.. I can tell you that there is a 98% chance that it is your internal/external hardrive causing the problem, it happened to me.. I spent 3 days with applecare support trying to figure out the issue.. finally Western Digital replaced my external hard drive and now my system is working perfectly.

  • aidanjones Level 1 Level 1 (10 points)

    I just installed Lion and it fixed the problem! I suggest you all update.

  • Kappy Level 10 Level 10 (252,505 points)

    Given the nasty nature of the problem you may want to check out this:

     

    The XLabs new FAQ on the -10810 Problem.

  • arnj Level 1 Level 1 (5 points)

    @beckmart: answers to your q's:

    1. it was my internal drive. Sorry for not mentioning that clearly.

    2. As far as what tools to use, the Apple tech used SMART by Volitans: http://www.volitans-software.com/smart_utility.php to uncover what Disk Utility couldn't. I've heard mixed reviews about Tech Tool Deluxe, but it apparently used to come with Apple Care. I have not been able to find it if that's the case, but it's mentioned by the article Kappy mentioned from XLabs.

    3. Yes, people here could very well have defective hard drives and not know it. Disk Utility did NOT uncover the real problem: a failing HDD.

     

    @kappy: EXCELLENT article (The XLabs new FAQ on the -10810 Problem). Thank you.

     

    It totally makes sense, and confirms many suspicions. Error 10810 is a generic error and only the tiniest indicator that something is amiss.

     

    In my case, the Apple tech explained that the bad sectors were probably where certain kernel or driver code was sitting, and therefore behaved poorly upon access.

     

    Then the mirage that Disk Utility created (HDD verified and "ok") allowed me to proceed (and waste tons of time) down another troubleshooting path.

     

    This is an Apple problem, ultimately. They need to have factors engineered in the OS kernel that doesn't allow such things as Zombie Processes and Fork Bombs from 3rd party software, so that the process table doesn't get filled up. Perhaps apps should be forced to declare their process threads up-front, so OS X can crash them if they're destined to take down the whole system. The fact that this doesn't happen makes OS X very UNPROTECTED from 3rd party instances, which was the whole point of moving to Unix and away from OS9 ten years ago.

     

    I suppose we'll see if Lion addresses it. However, apparently this problem has lived through several major OS X versions.

  • Kappy Level 10 Level 10 (252,505 points)

    As the article suggests it may or may not be a bug in OS X. I do know from experience that third-party extensions or mods to OS X USB drivers can cause the error. In my experience I've only seen the error in connection with USB drives (not flash drives.) In one instance it was a drive that ran from a third-party card in my Mac Pro to provide USB 3.0 to an external drive. Proprietary extensions were installed. I started getting 10810 errors using the drive. I switched to using Firewire and haven't had a problem since. In the other case it turned out to be a defective enclosure or failed drive - not yet sure which.

  • arnj Level 1 Level 1 (5 points)

    I hear what you're saying, but I think that depends on what your definition of bug is.

     

    An OS that allows itself to be taken down by 3rd party software influence is not a protected-kernel operating system, which had been the major complaint of OS9 and Windows 95-Vista (some may argue that Windows 7/Server 2008 are not actually kernel-protected either, and that Linux/Unix stands as the only relatively fault-tolerant/protected OS). This article talks about some of those principles.

     

    The argument that Apple has been making over the years is that OS X is, in fact, Unix, and therefore, the OS's base kernel tree is protected from 3rd party influence.

     

    This problem illustrates that it is not. In my opinion, it would suit Apple well to investigate how to address this issue, if they haven't already with Lion (side note: this has also been an issue in IOS, which is basically OSX).

     

    Bad 3rd party software will never go away, nor will errors in certain sub-components of the OS. If an OS is to be truly "bulletproof", then it should allow those 3rd party failures to crash gracefully without crippling the OS.

     

    Don't get me wrong, OSX is awesome, but OS X Snow Leopard does not protect itself well. To me, this is a bug, and a result of poor design in terms of this topic.

  • hepcat72 Level 1 Level 1 (15 points)

    Peter Neal, that worked for me!  Great!  Thanks a lot.  I'd mark it as a correct or helpful answer if I could.  I wish there was a way to sort the thread by number of likes, useful, or correct answers.  I at least liked your post...

  • Tech101Helper Level 1 Level 1 (0 points)

    To Fix This:

    Open Up Terminal, and write the following code/System/Library/CoreServices/Finder.app/Contents/MacOS/Finder &

    You should see something like this:

    [1] 55996

    And Finder should Open.

Previous 1 41 42 43 44 45 Next