Skip navigation

The application can't be opened.

463969 Views 693 Replies Latest reply: Mar 14, 2014 2:16 PM by registered99 RSS
1 2 3 ... 47 Previous Next
Kel Solaar Level 1 Level 1 (0 points)
Currently Being Moderated
Aug 30, 2009 12:36 PM
I upgraded to Snow Leopard yesterday, and I'm having a lot of troubles, Finde, Time Machine and Disk Utility being the most annoying of them. I don't really know which one of them is making the others unstable / crash but well that's starting to be very irritating, now when I try to start the Finder I get this :

*The application can't be opened.*

Restarting the Computer ( Mac Book Pro Uni ) usually fix that, but it's the second time that it's crashing a 220 go files package copy. I ended up doing it with rsync, the copy is still going on ( it will take a long time ) but I'm left with a Zombie Computer where I can't open a finder, and every Application that use it to open some file is crashing itself.

Is there a way to manually relaunch it ( I don't want to reboot, my computer is stuck backing up a lot of files ) ? I tried Sudo Launch the Finder from /System/Library/CoreServices/ with no luck, any help would be appreciated.


Message was edited by: Kel Solaar
Mac OS X (10.6)
  • willdenow Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 30, 2009 12:56 PM (in response to Kel Solaar)
    This message seems to be new to SL. I've had plenty of Finder crashes in Leopard, and never once recall seeing it.

    This has happened to me twice on my MacBook Pro 13". If Finder crashes, you will get this error message under SL if you try and reinitiate Finder after a crash or a force quit and before Finder fully recovers. This can take some time. I've had to wait upwards of a minute or more. On one occasion, I hard to compel a hard restart, but I don't like to do this unless absolutely necessary because it can corrupt any application and/or data files that are open and active at the moment of the restart.
    iMac 24 2007, Mac OS X (10.6)
  • Carolyn Samit Level 10 Level 10 (84,160 points)
    Currently Being Moderated
    Aug 30, 2009 1:05 PM (in response to Kel Solaar)
    HI Kel and Welcome to Apple Discussions...

    How much free disk space?

    Right or control click the MacintoshHD icon. Click Get Info. In the Get Info window you will see Capacity and Available. Make sure you always have a minimum of 10% to 15% free disk space at all times.

    Have you tried deleting preferences files? If not..

    You can find these files here:

    /Users/YourName/Library/Preferences. Drag those files to the Trash, empty the Trash and restart your Mac.

    Intel iMac 2.66 Snow Leopard, Mac OS X (10.6), iPhone 3GS PBookG4 iBookG4 Intuos Tablet Epson Olympus Airport iPods JBL
  • Two Weims Level 1 Level 1 (50 points)
    Currently Being Moderated
    Aug 31, 2009 7:31 PM (in response to Kel Solaar)
    I am having the same problem. I get the "The Application Finder can't be opened -10810" Message after working with files that are located on a Drobo connected to a DroboShare on my network. Everything works fine for a while. Then, for no apparent reason, the Finder gives me an error message about not having permission to save the current file that I am working on. Then the beachball starts spinning and never stops. If I try to relaunch the Finder I get the error message above.

    This only happens while working with files on the Drobo and it has only started since I upgraded to Snow Leopard. My Boot Drive is less than 50% Full and both the Drobo and the DroboShare have the latest Firmware installed.

    Since the Drobo uses SMB, my suspicion is that there is something wrong with the Snow Leopard implementation of Samba. That is where I am heading with further investigation.
    Two iMac G5s, Two C2D MacBook Pros, & a Mac Pro, Mac OS X (10.6)
  • Gavin Fourie Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 2, 2009 11:09 AM (in response to Kel Solaar)
    I'm having the same problem. For me it happens when ejecting an external hard disk fails and after clicking relaunch Finder I get the error message and Finder won't restart.

    I tried accessing the filesystem from firefox (to see if that would prompt a relaunch of Finder) and crashed firefox. Which I thought had crashed my system but after a minute or two while it all came back up with finder working, sort of.

    Finder listed my Time Machine backup drive under devices but not the other partitions on this drive. Using the eject all function on this drive caused Finder to crash in the first place. So I tried to eject this Time Machine disk and Finder tells me it is in use but gives me the option to force eject which I chose and am told that it has been ejected even though it is still listed under Devices and I can still move through the file system on this drive.
    Macbook Pro 4.1, Mac OS X (10.6)
  • Asylum119 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 2, 2009 5:56 PM (in response to Carolyn Samit)
    If i can not open finder and have no desktop icons, how do i get to the files to delete them.

    This has crippled my mac

    Need help
    Mac OS X (10.6)
  • RRReed Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 4, 2009 10:17 PM (in response to Kel Solaar)
    I'm seeing the same problem with a ReadyNAS Duo (latest firmware). It usually occurs after I've tried to dismount a share by dragging it to the trash, and had the Finder lock up. After force quitting the Finder, I get the -10810 error and can't relaunch it until I reboot.
    2.8GHz Core Duo Extreme iMac, Mac OS X (10.6)
  • Izzard-UK Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 5, 2009 2:40 AM (in response to Kel Solaar)
    I got the same error just now. I'm not too concerned as I sort of caused it myself - but I'll explain my environment as it might help get this fixed.

    I use Time Machine to backup to an iSCSI target on my network. It is simply a PC in my garage running Ubuntu with one drive exposed as a target. My Snow Leopard iMac connects to it using GlobalSAN iSCSI Initiator: I formatted it as Mac OS Extended and off I went. This works brilliantly as a Time Machine backup solution.

    I caused this error just now because I restarted the Ubuntu machine while I was browsing the Time Machine drive with Finder. (That's a bit unfair to Finder as, unlike a USB external drive, it's not going to know I've disconnect what it was looking at.) Finder locked up (beachball) and I got the above error after Force Quitting it and trying to launch it again. Once I had told GlobalSAN iSCSI Initiator to drop the failing connection, Finder was able to start just fine.

    Before I upgraded from Leopard I was using the same method to backup to an iSCSI target hosted by FreeNAS on the PC in the garage. This system would fail sometimes (hence the change to Ubuntu), causing Finder and my whole Mac to lock up. Unlike the situation I have now, disconnecting the GlobalSAN iSCSI Initiator connection didn't bring it back to life - in fact I couldn't even start System Preferences - and I always had to do a hard reset of the Mac. So something has improved if I can now just restart GlobalSAN iSCSI Initiator to bring Finder back - but I don't know whether to attribute this to the change of the iMac to Snow Leopard or the PC to Ubuntu.

    I hope this information is of use.
    iMac 24" 2.4GHz Core 2 Duo, Mac OS X (10.5.6)
  • Ashims Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 6, 2009 1:18 AM (in response to Kel Solaar)
    I just had the same problem. I'm on a new Macbook Pro 15-- the good one, which I freshly installed with snow leopard. HDD is empty except for Adium, Perian, Firefox, Textmate and Versions. Computer has been running horribly slow since the update. Apps keep crashing all over the place... Finder crashed out when I force closed activity monitor which had stopped responding. Force quitted it and now it doesn't open with that error.

    Fun fun -_-'
    Buffed Intel Imac, Mac OS X (10.4.6)
  • Rowalan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 6, 2009 2:12 AM (in response to Kel Solaar)
    I have had the same problem, when i tried to restart after finder crashed, It just had the thinking sign with the blueish screen. I had to hard start
    Signed up just to put this out there, hopefully the right person stumbles on it and creates a "fix" update. Feels terrible, I just don't want to accept that apple's has made a Vista like mistake, in rushing to finish 10.6
    MBP, 4GB, 2.5 GHz
  • gelki Level 1 Level 1 (10 points)
    Currently Being Moderated
    Sep 6, 2009 3:06 AM (in response to Kel Solaar)
    I have exactly the same. I think it is caused by Time Machine in combination with my external disk. I had it connected via my Apple LED Cinema, now via another device to see if the problem lies there.
    Macbook pro Late 2008, Mac OS X (10.6)
  • Graham K. Rogers Level 5 Level 5 (5,430 points)
    Currently Being Moderated
    Sep 6, 2009 3:13 AM (in response to gelki)
    Some of you might consider putting in the SL install disk and clicking on the optional installs package. That may over-write some of the problems with the Finder. Either that or over-writing the install itself: some people have cleared problems by installing twice.
    iMac 2.4 + MacBookPro 2.16 (2G RAM), Mac OS X (10.6), iPhone 3G, iPod touch
  • Alan Goodall Level 1 Level 1 (130 points)
    Currently Being Moderated
    Sep 6, 2009 4:39 AM (in response to Carolyn Samit)

    Snow Leopard has been working OK for three days - until this morning I got this error message -10810. on my MacBook Pro.

    This has happened twice just now. Each time when I was trying to move items to the trash. After the first time (when the Finder refused to relaunch and I got error -10810 - I trashed the preferences you suggested (except TimeMachine which was not in my preferences - perhaps because I have not used Time Machine?

    I restarted and things worked Ok for a while (I even moved other items to the trash OK) then, the next time I tried to trasha file - I got the message 'preparing to move items to the trash - and then the spinning beach ball. Tried to relaunch Finder but could not and got - error 10810

    What else can be done? So far It has not happened on my iMac!
    iMac 3.06 GHz, MacBook Pro Duo 2.4 GHz, Powerbook G4, Mac OS X (10.6)
  • Alan Goodall Level 1 Level 1 (130 points)
    Currently Being Moderated
    Sep 6, 2009 5:13 AM (in response to Alan Goodall)
    Further to my post above. After a restart SL is failing to mount my external LaCie Hard drive - which was the drive containing the files I was trying to delete.

    It then tells me that the disk is unreadable! I attach the same disk to my iMac - and the blue power light keeps flashing. I read somewhere else that this could be a power supply problem. So I used a power supply from another LaCie. Now it works OK and is recognised by both iMac and PB. The files on it are OK and repair disk says it is OK

    But, am I going to have the same problem again? Did SL ruin the power supply during this finder error problem?

    Another LaCie external mounted OK!
    iMac 3.06 GHz, MacBook Pro Duo 2.4 GHz, Powerbook G4, Mac OS X (10.6)
1 2 3 ... 47 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.