7 Replies Latest reply: Sep 10, 2009 2:10 PM by emandelapaz
Lyndale Level 1 Level 1 (0 points)
We would like to upgrade to the new Snow Leopard OS.

However we are presently running Parallels Desktop 3.0 for Mac on the OS X Leopard software. Part of the decision to upgrade to OS X Snow Leopard will depend on being able to do a smooth transition for Parallels when we do the upgrade.

Has anyone gone through this yet and if so can you tell us if you have encountered any difficulties with running Parallels 3.0 once you have done the upgrade.

Thanks ... Lyndale

iMac, Mac OS X (10.5.6), Parallels 3.0 Build 5626
  • barjohng Level 1 Level 1 (0 points)
    I haven't tried version 3.0 but 4.0 works fine as long as the Kernel is booted up in 32 bit mode. If you boot up the kernel in 64bit mode you get a driver error and it won't start.
  • Jim P Level 2 Level 2 (300 points)
    I upgraded to SL and Parallels 3 is not supported at this time. It will not open. Lets hope Parallels gets a fix done quickly. I am holding off on the grade for my other machines until that is done.
  • MuddyBulldog Level 2 Level 2 (215 points)
    Paralells 4 now supports Snow Leopard. It is not expected that 3 will be updated to be compatible.
  • MacGRDEsq Level 1 Level 1 (15 points)
    I have Parallels Desktop 4.0. What is a kernel and how do I make sure that it boots up in 32 bit? I'm assuming the Kernel is the Windows Virtual Machine? I run Windows XP Pro on my VM.
  • barjohng Level 1 Level 1 (0 points)
    The kernel is in Snow Leopard and it by default boots up in 32 bit mode. You can force a boot in 64 bit mode by holding down the 6 and 4 keys during boot up or edit the appropriate plist to have it defaul to 64 bit and force a 32 bit boot by holding the 3 and 2 keys during boot up.
  • emandelapaz Level 1 Level 1 (10 points)
    I can attest to the fact that Parallels 3 will not work with SL. I learned the hard way three days ago. I jumped on SL as soon as it was released in my locality. Alas after completing the upgrade I realized I couldn't open my Windows XP VM. Having many mission critical tasks based on the VM, my quick fix was to upgrade to Parallels 4 (something I had always hoped I would never have to do).

    For the most part the upgrade to Parallels 4 in SL was a breeze. There were no problems with the VM side. All applications were functioning and there was no trouble with the data. The caveat: Parallels Tools is not fully functioning no matter how much I tried to reinstall it. I encountered the following:

    1. Mouse synchronization not working between host and VM (I'm stuck with having to hit ctrl + alt to release cursor all the time)
    2. Dynamic resolution tool not working (guest OS window not resizing automatically)
    3. Coherence is not working

    The other tools seem to be working fine: clip board and time synchronization, shared profile and applications tools, and parallels compressor. It is more of a convenience issue of seamlessly working between host and VM, but a convenience I sorely miss. It appears from Parallels Forums that a significant number of users are experiencing this trouble. No working solution for me yet, but let me share the three options offered by Parallels Support:

    METHOD 1: Uninstall and Re-install Parallels Tools using the VM Control Panel => Add and Remove Programs (http://kb.parallels.com/en/4841) followed by reinstall of Tools from the Virtual Machine Menu of Parallels Desktop.

    METHOD 2: Uninstall Parallels Desktop using the latest dmg file (build 3846) then re-installing using the same. You won't lose your VM with this trick, but it didn't work for me still.

    METHOD 3: Alternate method of re-installing Parallels Tools by connecting the VM to an ISO image (prl-tools-win.iso) in your /library/parallels/tools folder (placed there during initial install of Parallels 4) then installing tools from the VM side.

    Apparently the above workarounds have worked for some. I am still hunting for the solution that will work for me (any suggestions from the gurus out there?). I miss Parallels 3 now, but I'm still hoping I never need to roll back to 10.5.8.

    Consider these when thinking about your planned upgrade.
  • emandelapaz Level 1 Level 1 (10 points)
    Lyndale,

    I can now confidently tell you that SL and PD4 truly are compatible.

    I had trouble with the installation process initially, but finally got help from Parallels Support. Compatibility was not the issue with my technical trouble, but one of installation glitches. In a nutshell it appears that the root of the problem I described above is with the correct drivers not getting installed as it should during the Parallels Desktop install process. In my particular case, not having a video adapter was preventing coherence mode from functioning. The correct drivers were manually installed from the Parallels directory from the VM and following a simple reboot, everything was in order. All components of Parallels Tools finally working.

    The issue is discussed extensively at the Parallels Forums.

    If you do consider upgrading to PD4, be prepared to encounter some glitches and downtime. Once you surmount them, you'll be pleased with SL and PD4 as I am now

    Message was edited by: emandelapaz