Previous 1 2 3 Next 108 Replies Latest reply: Aug 13, 2015 3:03 PM by veddah
Wiremonkey Level 1 (0 points)

I'm really having problems with this Snow Leopard, and don't want to be agitated, or frustrated, but it's getting harder and harder to do so.

After installing on my 17" Macbook Pro, I was able to log in, fine, but was unable to do much of anything, as I was prompted to give a administrator password, but had no idea of what this was.

After trying every combination of my name (which has been my user name from before time), and pass work, I got it in my head that "this messing ain't cutting it."

After a bit of looking here on the forum, I was able to find out how to use my install disc to crate a "system administrator" account, and then, after restarting from my hard drive, I was able to go into the system preferences, find my users, and give myself permissions to act as an administrator (after this, I read several posts about how it's scary to crate an administrator account -- and it was -- but just tried to be strong -- channeling bit of strength from an alligator I once saw eat a big chunk of old truck tire, and just pressed on).

Now I should note that while I was log in as the (scary) administrator, I did seem that I was able to open folders without issue, however, when I logged back in as me (the monkey of wire), nothing much had changed, I could not open any folders with exception of "public" and something else like that...

The warning I get is ""don't have premission to see its contents" -- wow, I can't even look?


And, what scares me even more, is that I can go back in my time machine and see things that I would like to bring forward, but when I try to, I'm told "this is part of OS X and can't be modified... " or something close to that... Don't worry about this issue right now, I think it might be tied to the "no permission" deal, but if I've lost those back ups... Well, we all know what that feeling is like, and I will be feeding parts of my grays anatomy to said "Alligator."

So, while I'm here, what about just going back to OSX plain old Leopard?

Can I do this if I do a reset to factory install?

Will that boot out all the snow?

And if so, what I fear is that I have already corrupted my time machine drive with a back up done while this Snow Leopard OS installed... Yeah, when I plugged in the drive to check what it's staturse was, the Macbook just jumped in and performed a new back up -- of this state of affaires.... Scary again.

I was thinking I might be able to go into the drive and erase this one (or perhaps two) backups, but then when I looked there is a document that's very new -- like just at the time this back up was being done -- and it's called something catalog, I think, and I have a gut wrenching feeling that to erase that would be the beginning of a horror show... So, let me not go there just yet...

Wow, that's a lot... Any help on this would just be awesome.

I honestly just rock out hard no my apple products, I'm a long time user, and always do things carefully and with thought, but this is very underwater frozen under the snow black water gator **** for me right this moment in time.

Thank you,

MacBook Pro 17", Mac OS X (10.6), machine is 2.5 years old
  • Carolyn Samit Level 10 (103,365 points)
    HI and Welcome to Apple Discussions...

    First, open Disk Utility (Applications/Utilities) and repair disk permissions.

    After you repair disk permissions you should be able to use Time Machine.

    If you are the only person that uses your Mac you are the administrator of the computer. You have the "admin account". You can change your admin password using System Preferences/Accounts. You can create a password hint. It's very important to keep track of this information. Every time you update software from Apple, you will be prompted for your admin password. It's a security precaution.

    You're really not up to your xxxx in alligators You can always get help here.

  • Wiremonkey Level 1 (0 points)

    Many thinks for your effort, but these steps did not effect any change.

    I tried running repair disk permission from both my account and the new administrator account -- restated each time -- and still got the same "don't have permission" deal.

    Also, I've always been the only user of this machine, and until I created this new administrator account, I could do absolutely nothing.

    Any other thoughts?

    Thank you,
  • Wiremonkey Level 1 (0 points)

    Many thinks for your effort, but these steps did not effect any change.

    I tried running repair disk permission from both my account and the new administrator account -- restated each time -- and still got the same "don't have permission" deal.

    Also, I've always been the only user of this machine, and until I created this new administrator account, I could do absolutely nothing.

    Any other thoughts?

    Thank you,
  • Wiremonkey Level 1 (0 points)

    Sorry for the double post above.

    Can anyone please point me to a thread -- if one exits -- that explains the process of returning to OSX 10.5 Leopard?

    I have run out of steam here with this Snow Cat version... The rewards have evaporated and I am not a fierce alligator.

    Thank you,
  • petermertens Level 1 (0 points)
    Well, all I can say: you are not alone. Since the (not so smooth) installation of Snow Leopard I have the same "can’t be opened because you don’t have permission to see its contents" problem, and neither Disk Utility or simply with Get Info doesn't work. I hooked the disk to another computer and it remains...
  • Will27 Level 1 (0 points)
    Unfortunately, same issue here.
  • Seth Hodge Level 1 (5 points)
    Hello All,

    The easiest way I've found to fix this problem is to highlight the folder you can't gain access to, right-click the folder and choose Get Info. Now at the very bottom you should see a section titled Sharing & Permissions. Expand this out and click the lock in the lower right. This will prompt you for the admin password and should unlock. Once unlocked click the + sign and add yourself. Then change your permissions from read only to read/write.

    That should fix the permissions problem and allow you into the folders. Do note that some subfolders may also need to have their permissions adjusted.

    Hope this helps,

  • GodzFire Level 1 (0 points)
    Glad to see I'm not alone. I just got 10.6 and did a complete clean install of 10.6 on HD1, with HD2 as my backup with 10.5.8.

    The install went fine, and I booted into 10.6 for the first time. I started organizing things, but couldn't seem to rename anything, and when I tried to change permissions to allow editing, it would just switch back.

    Somehow the permissions got screwed up, and now my HD2, with all my information, is locked out. When I try to click on it I get "The folder "Mac HD 2" can't be opened because you don't have permissions to see its contents."

    This is terrible, please advice.
  • dasle Level 1 (35 points)
    that is exactly what it happened to me, I've two HD and both are blocked and after repairing, reaieing, reinstalling, loggig as root (administrator) and I don't know what else to do
  • instageek Level 1 (5 points)
    I tried your method, Seth, but even after repairing permissions with Disk Utility, verifying the disks, resetting my firmware password, resetting the ACLs on every home folder on every account, for every volume, I can't change my permissions in Get Info from "Custom." It will let me choose Read & Write etc. but once I click off it immediately switches back to Custom. Help.

    One thing I noticed in Disk Utility when it was checking permissions: there were two or three root/var permissions "found but not expected". It said they were repaired.

    Any idea why it's not happening on my LaCie? It's connected by FW800. The Iomega is connected to the LaCie's spare fw800 port, and the Maxtor is connected directly via USB. The LaCie is partitioned into 3 volumes, as is the Maxtor. The Iomega has just one volume.
  • Seth Hodge Level 1 (5 points)
    Hey Instageek,

    The only other thing I know to try is when applying the method I originally listed there is one there option that will apply the permissions update to not only the folder you have selected, but also all subfolders and files.

    Once you've added yourself with full read/write permissions click the little cog and a drop down menu should pop up with the option to Apply to enclosed items.

    If that doesn't work I'm out of ideas.

    One last idea would be to create a new user with full admin permissions and try taking control with that one. If the new profile can access the folders, but your current profile cannot it would be something specific to your profile.

    Hope this helps,

  • instageek Level 1 (5 points)
    Hey Seth,

    The weird thing is that I don't get an option to change all the enclosed subfolders and files; maybe because it doesn't actually make a permanent change to the parent folder. I get two options that are both grayed out: Make me the owner and Revert changes. I've tried checking and unchecking both shared folder and Ignore Ownership but nothing changes the Custom settings.

    I did try creating a new account with admin privileges yesterday and had no luck with that either. It won't even let me add the new user to the list of users in the Get Info.

    This seems like a job for Unix command-line expert. Anyone know the command to reset all permissions on all attached volumes to default?

    I've also used a utility called Sandbox in the past but can't seem to find it now. I guess there's also Batchmod but not sure if it's Snow Leopard compatible...
  • instageek Level 1 (5 points)
    I found a solution over on Macrumors forums, though it's not for the faint of heart. The solution starts at post #36, about halfway down the page:

    As I suspected, this is a Terminal / Unix / Command-line procedure, and anyone uncomfortable with it should probably just take their Mac to the Genius Bar at their local Apple store. That said, below is the procedure that worked for me (I'll make it easier for those who don't want to read the whole thread on

    Also, the first procedure is ONLY FOR HARD DRIVES/VOLUMES WITH ONE-WORD NAMES. If you have two or more words in the name(s), the procedure is slightly different, and I've listed that below the first procedure.

    *1. Open an application in your Utilities folder called Terminal.*

    This is the Unix part of Mac OS X that does not have a GUI (graphic user interface). Think of it like working in DOS (or BASIC), if you're as old as I am. It's also a bit like a word processing program, only much more powerful.

    You type a command (_EXACTLY, character for character, space for space, as it is shown in the example_) and then hit ENTER or RETURN to execute the command. After the first ENTER/RETURN, you will probably have to enter your account password (or an administrator password if you're not logged in as such).

    You won't see any characters appear as you type your password, (the cursor remains in the same place) but continue typing it and then hit RETURN/ENTER.

    2. In Terminal, CUT AND PASTE the following lines +one at a time+ (obviously replace "Volumename" with the name of your volume). Make SURE you include spaces where there are spaces. And those are ZEROS after "chflags" and "chown", not Oh's.

    Hit RETURN/ENTER after the "Volumename", and watch your HD's icon on your desktop after each command. In my case, the little padlock disappeared first, then my custom icon was restored, and then it was just blink blink every time after. But it works!!! REMEMBER, THIS FIRST PROCEDURE IS ONLY FOR VOLUMES WITH SINGLE-WORD NAMES:

    *sudo chflags 0 /Volumes/Volumename* <HIT RETURN/ENTER HERE> (don't type this part in Terminal.
    *sudo chown 0:80 /Volumes/Volumename* <HIT RETURN/ENTER HERE>
    *sudo chmod 775 /Volumes/Volumename* <HIT RETURN/ENTER HERE>
    *sudo chmod -N /Volumes/Volumename* <HIT RETURN/ENTER HERE>

    BUT if your volume's name includes one or more spaces like this: "My HD Backup", then you must write the command like this (Notice the spaces :

    sudo chflags 0 /Volumes/firstname\ secondname\ thirdname\ fourthname\ fifth etc.
    sudo chown 0:80 /Volumes/firstname\ secondname\ thirdname\ fourthname\ fifth etc.
    sudo chmod 775 /Volumes/firstname\ secondname\ thirdname\ fourthname\ fifth etc.
    sudo chmod -N /Volumes/firstname\ secondname\ thirdname\ fourthname\ fifth etc.

    or like in my example:

    sudo chflags 0 /Volumes/My\ HD\ Backup
    sudo chown 0:80 /Volumes/My\ HD\ Backup
    sudo chmod 775 /Volumes/My\ HD\ Backup
    sudo chmod -N /Volumes/My\ HD\ Backup

    That should do it! Hope it works for everyone with this problem. Thanks to "IEatApples" on MacRumors for the solution!

    For anyone who cares, here's what another MacRumors user (angelwatt) said these commands actually do:

    1. chflags 0 removes all flags from the file(s)
    2. chown 0:80 ensures root:admin (owner:group) permissions so the system can access the files
    3. chmod 775 adjusts file permissions so you and your group have read/write/execute permissions
    4. chmod -N removes the ACL (Access Control Lists) from the named file(s)


    *disclaimer: I take no responsibility for any mucking up this does to your machine due to mis-types by you or me. But pull up your bootstraps, be brave, this works!
  • GodzFire Level 1 (0 points)
    In response to dasle and instageek, yes, SAME thing happening to me! Even worse, it was my 10.5.8 Leopard backup with my data on it.

    When I do the Get Info, all of my permissions are set to Custom, and even though I unlock and input my password, it will not change anything from Custom. I can try to set it to Read/Write, but it won't stick after choosing it in the dropdown.
Previous 1 2 3 Next