Previous 1 3 4 5 6 7 8 Next 108 Replies Latest reply: Aug 13, 2015 3:03 PM by veddah Go to original post
  • Applefreq Level 1 (0 points)

    Thank You Instageek!

    I had a terrabyte internal drive go rogue on me  in my 17" i7 MAcbook Pro. I am pretty sure it was when I tried to apply the command that gave me read and write permission to " all enclosed folders". (I would highly recomend NOT doing what Nerowolf says to do here unless you know it works on your OS and on your computer  )


    Bad idea as not only do hundreds of system files need to be read only to function, repairing disk permissions doesn;t fix the problem , and I had my TB internal become unopenable as well!!


    Had I not had a recently cloned and bootable OS on hand  I would have been royally buggered. Fortunately I did so I could at least access the OS by hiolding down alt when I restarted and choosing to boot up off the external clone which didn;t have the problems .


    But that still left the problem of getting into my 1 TB iternal which has my sample library, large file back ups, and itunes/iphoto libraries etc... some of which weren't backed up yet.


    This solution worked first time!! Many Thanks for your hardcore Ninja skills Instageek.

    You've made my week as my LOgic install disks are a continent away and have 2 tunes to finish and deliver in the next 2 weeks.

    You rock!

    Darin ...

  • Flowmotion Level 1 (0 points)

    This worked perfectly and was easy to do.  Thanks!


    "I just spent several hours on the phone with an Apple Specialist and we discovered that if you can get to your terminal application, you can type in the following command to fix this problem:

    sudo chflags nouchg (at this point, drag and drop the drive you would like to change the settings for making sure there is a space after the "g") hit return


    You will get a message that tells you that you want to ensure that you have the path correct, if you do, then hit return and you will be asked for your password. This is your system password. It may look like nothing happened when you typed in the password, but that should be fine. Then go to the drive, click "Get Info" and you should now be able to change the settings on the permissions for the drive."

  • Georginio79 Level 1 (0 points)

    It's not that complicated it looks like your macs are confused on users accounts . just go to get info open the LOCK under "Sharing & Permissions" click on the + sign on the bottom it will show you your administrators account add them to the list and change privilege to read & write. Voila .

  • TheH-Sweden Level 1 (0 points)

    I had the problem with the Time Machine bacups from my Mac Mini running Lion Server.


    HD 1 I could access no problem but HD 2 not accessable and I got the error message


    timemachine folder cannot be opened because you don't have permission to see its content.


    The below soluton suggested by Seth worked fine by opening the Time Machine backup from a 2nd computer


    Logging into the TimeCapsule


    Clicking the folder that had the permission problem


    Use "get into" and then do as described below.



    Seth Hodge wrote:


    Hello All,

    The easiest way I've found to fix this problem is to highlight the folder you can't gain access to, right-click the folder and choose Get Info. Now at the very bottom you should see a section titled Sharing & Permissions. Expand this out and click the lock in the lower right. This will prompt you for the admin password and should unlock. Once unlocked click the + sign and add yourself. Then change your permissions from read only to read/write.

    That should fix the permissions problem and allow you into the folders. Do note that some subfolders may also need to have their permissions adjusted.

    Hope this helps,

  • Jimmy P. Level 1 (0 points)

    Thanks jstjck!  This worked and NO need for the Terminal!


    1. Temporarily disable TM.
    2. Double clicked the TM mounted drive and on the first folder seen (Backups.backupdb) I did Apple+I for Get Info.
    3. Clicked the lock & entered admin password, then clicked on the + in the bottom left.
    4. I added myself as "read & write" then from the wheel looking icon next to the + & - on the bottom, I selected this and chose "set myself as the owner" and ok.
    5. It gave me a warning about not being able to change the settings once applied, clicked yes and it applied the changes.
    6. Note - as my HDD is large, this change took AGES. I gave up after 45mins and let it go overnight.
    7. From the top menu bar, choose "Enter Time Machine" and it all should be ok.
    8. Turn TM back on.
  • Aleatoric Level 1 (0 points)

    So, how come that doesn't actually work?


    And what happened to the Mac mantra of 'it just works?'


    I have a macbook pro and and iMac, and I've set them up with exactly the same username and passwords for both.


    Pretty much everything works as expected (including connecting to a windows box), but using Finder to share the network folders fails with the 'don't have permissions' issue. Why is it easier to connect to, and share the drives for, a windows box than it is to another Mac?


    I really like these computers, but this is just silly. There's no good reason for this kind of error to occur at all (heck, I've set up Linux servers to share more easily than this).


    I've tried most of the 'solutions' provided in this thread, with no real result.


    But that's not really the issue. For a provider that claims for things 'to just work', it seems pretty odd that mac to mac sharing has to be so deliberately involved.


    It's really pretty sad. I can (in pretty much the default setup) use my mac to connect to (and share) the drives on my windows PC and my linux PC, but it won't work correctly for my other mac.


    Is there someone at Apple getting a big laugh out of this?


    I shouldn't have to jump through my own *** to get this to work, sharing between macs should function properly without me having to go to the terminal and chanting magic spells.

  • Kat_C Level 1 (0 points)



    I was having the same problem and did what you suggested.  At first it didn't work, so I restarted the computer and everything, I mean everything, opens.  Many thanks.

  • Dante Abel Level 1 (0 points)

    You can also try this. I was having this problem as well.


    Right click on your HD icon, select "Get Info" then select the bottom arrow, "Sharing and Permissions". Here it will display three categories, which are as followed: "system", "wheel", and "everyone." Switch them all to read and write. Then restart you mac.


    Good luck. Hope it works!!!



  • FreudSydney Level 1 (0 points)

    Thanks instageek for all that info and research, but it still doesn' work for me

    I started to have this problem after installing Lion 10.72 update on my older Air

    which was running 10.7.1 - then CRASH  - a kernel panic every time I try to start up.


    When I try my re-install of Lion, I can't access the hard drive as it is locked.


    I tried the terminal suggestions, but it doesn't work.


    Firstly I noticed that some of you use * and others use _ so I'm not sure which to


    Also, my * appears as a non-superscripted item rather than superscripted as

    others seem to have typed it.

    I notice here (in this post) it appears as a superscript, but in terminal is does not - am I doing

    something wrong?


    I am sure this isn't a hardware problem.


    For those who access INFO - well I can't do this because I have no access to the icon for the HD

    other than as a reinstall option - where it is greyed out!!


    At my wits end - I must say that the folks at Apple have really stuffed up - this all reminds me of the old

    days about 10 years ago before Apple started to be the supreme company.


    Have ALWAYS been a MAC person, but I must say, I'm wondering whether the Lion stuff ups are the beginning of a gradual decline.


    If anyone else has some bright ideas I would be deeply grateful.


    BTW, also downloaded Disk Warrior - but can't start up from it till I get the Disk from the USA (am in Australia).

  • jstjck Level 1 (0 points)

    If you are able to boot & get into Lion, have you tried (in Finder) going to 'Go' > 'Computer' or shift+apple+c to get the Macintosh HD in a finder window?

  • psychocowprodder Level 1 (0 points)

    Instageek, you probably had this fixed already, but in reference to iDisk make sure the volumename is your mobileme username not "iDisk". I hope that helps someone!

  • ehktexas Level 1 (0 points)

    I almost never post in these discussions, but after MANY frustrating hours of trying everything mentioned above and more to regain permission to my external hard drives I found an EASY solution that worked immediately! The best part about this solution is you don't personally have to mess with Terminal. FYI- I'm on Snow Leopard 10.6.8, though I believe this solution will work for anyone on Mac OS X 10.5 or later.


    1. Download (

    2. Click on the "File" button and choose the external drive in question.

    3. Under Owner, choose "root" and check all 3 boxes (R, W and X). Under Group, choose "admin" and again check all 3 boxes. Under Everyone, again check all 3 boxes. **make sure you've checked the boxes and not just put a line in them...

    4. In Options box, check "Change ownership and privileges," check "Clear ACLs (10.5+)" and check "Unlock." Do not check "Clear xattrs."

    5. Finally, DO NOT check the box at the bottom that says "Apply to enclosed folders and files," because this is probably similar to what got you locked out of your own external hard drive in the first place!

    6. Click on the "Apply" button.

    7. Now open finder and open your external hard drive!

  • Rayzbo Level 1 (5 points)

    the tech at the Apple store fixed the one internal drive I have two externals with same problem.He emailed me this but I was unable to add the password when asked to type it.


    In the Finder, click the file and choose "Get Info" from the File menu.

    Then click the "Locked" checkbox.

    This works for files and folders, but not entire drives.

    To lock and unlock a drive, we use Terminal found in the Utilities folder in the Applications folder.

    sudo chflags uchg - lock a drive

    sudo chflags nouchg - unlock a drive

    When Terminal opens, type

    "sudo chflags uchg <drag the drive from the desktop to the Terminal window>"

    without the quotation marks.


    To lock a drive named "Macintosh HD" it will look like this.

    sudo chflags uchg /Volumes/Macintosh\ HD

    Note how the space is started with a back-slash first.

    To unlock a drive named "Backup Disk 1" would be:

    "sudo chflags nouchg /Volumes/Backup\ Disk\ 1"


    Any help would surely be appreciated.

  • curlied Level 1 (0 points)

    That worked!! thanks except now my files are all empty that are suppose to be in my external hard drive?!?!?

  • Rayzbo Level 1 (5 points)

    I found a cheap answer here:


    Works like a charm!


    Here's a small bit of what I found.



    Change permissions without the Terminal
    BatChmod is a utility for manipulating file and folder privileges in Mac OS X.
    It allows the manipulation of ownership as well as the privileges associated to the Owner, Group or others. It can also unlock files in order to apply those privileges and finally, it can remove any ACLs added to a folder or file under Mac OS X 10.5 Leopard or better.

    If none of this makes sense to you, maybe BatChmod is not for you :-) It has the potential to mangle your files if you do not know what you are doing. ESPECIALLY if you change the permission of your whole disk at once... just don’t do that.









    Unlock what is rightfully yours
    BatChmod can also give you back access to locked files, folders or disks. If something is locked, it can unlock it. If you no longer have permissions to files or folders, change the permissions back.
    Sometimes, a whole hard disk can become inaccessible or locked and often, BatChmod can unlock those too!
    If you moved a folder or files from another machine or another user on your machine, BatChmod can help set you up as their rightful owner.





    Keep your Trash clean
    Ah the beauty of a nice clean Trashcan on your Desktop. How annoying when you cannot empty it because some files are thought to be in use by the Finder! BatChmod offers a nice "Force Empty Trash" menu when you click on its icon or when you go to the BatChmod Menu when you run it. Quick and simple and you will never see those files again.






Previous 1 3 4 5 6 7 8 Next