Previous 1 2 Next 26 Replies Latest reply: Mar 8, 2010 4:52 PM by
Daniel Kiechle Level 1 (90 points)
I use a Western Digital My Passport Studio 500 GB external drive to back up my MacBook Pro with Time Machine. I had created a 30 GB Leopard boot partition with various utilities and tools; since the small drive goes wherever the laptop goes, I figured it might come in handy to be able to boot the computer in the event something went wrong with its internal 250 GB drive.

Over the weekend, I upgraded the external drive to Snow Leopard, and now it can no longer be used to boot the laptop. The symptoms are truly weird. Holding down the Option key while rebooting does not show the external drive unless I disconnect and reconnect the FireWire cable. The drive then shows up. I select it, and it appears to begin to boot, then it just sits on the gray screen with the little round thingie turning for a long time (five to ten minutes). Eventually, the system boots from its internal drive. This happens regardless of whether I'm connected by means of FireWire 400 or 800.

After spending a lot of time looking at the usual suspects (cables, permissions, PRAM, etc.) I reinstalled Sand Leopard (OK, 10.5) and lo and behold, the drive boots again (though for some reason I still have to go through the disconnect/reconnect routine). Clearly, something in the OS has changed with respect to the way booting from external drives is handled.

On the positive side, I have none of the symptoms described in other threads: Time Machine works flawlessly, and both the boot partition and the Time Machine partition appear on the Snow Leopard desktop every time I connect the drive.

Does anyone have the same issues? Does anyone know of a workaround?



Jan 08 Mac Pro 8-core 2.8 / 3.5 TB HD / 10 GB RAM, Mac OS X (10.6), 15" MacBook Pro / 250 GB HD / 3 GB RAM
  • Esquared Level 5 (4,410 points)
    What partioning table does that disk have? I think on Snow Leopard is must be GUID (GPT). You can check this in Disk Utility: select the drive (not the partition) and look at the bottom of the window.
  • donv (The Ghost) Level 5 (4,600 points)
    Why not clone SL to your external and then uninstall/delete things you don't want on the drive. I'd go with SuperDuper for cloning. Get the most recent version; it is good to go with SL. And, it emphasizes a step that is supposed to ensure boot ability. SuperDuper will also provide the right partition and formatting.

    Message was edited by: donv (The Ghost)
  • Daniel Kiechle Level 1 (90 points)
    Thanks for the suggestion; the partition table is indeed GUID.

  • Daniel Kiechle Level 1 (90 points)
    That's an interesting suggestion, though it will take me some time to try this as it would be a fairly time-consuming operation. On the other hand, it the only things was to have SuperDuper do its bootability stuff, then I could actually clone the current partition that doesn't boot and try to apply it with SuperDuper. Somehow, though, I am not optimistic because the OS thinks the drive is bootable: it shows up in the Startup Disk prefs pane, and it also shows up from the boot device selection screen.

    Still, thanks for the suggestion. I may give this a try this coming weekend if I haven't solved the problem by then.

  • Sierra Whiskey Level 1 (0 points)
    Hey Daniel ...

    Misery loves company. You're not alone. I just installed 10.6 onto a FW800 WD Passport, and my MBP won't boot up either. Yes, it's a GUID partition, and I even ran DiskUtility from the Snow Leopard DVD to update the boot partition.

    When I press the option key at startup — my MBP doesn't recognize the Passport. When I set it to the startup disk from System Preferences — it still boots from my internal hard drive. I've tried it from the end of my FW chain, and as the only peripheral. Nada.

    This is definitely a glitch.
  • Daniel Kiechle Level 1 (90 points)
    Hi Sierra Whiskey,

    Thanks for the company

    I bet that if you start up with the option key down and plug in your WD Passport after the boot volume selection screen appears, the drive will show up. It can be selected to boot from, and with Leopard it does, with Snow Leopard it doesn't. At least that's the behavior I am seeing.

    I've just spent quite a bit of time completely recreating my emergency boot partition with OS X 10.5.x, and I can now boot off this partition as described above. I have decided not to upgrade this partition to Snow Leopard; this way, I can also use it to rescue an older PPC-based laptop I still have should the need arise.

    Yes, this is a glitch, but I am more and more convinced that the problem is with this particular model of drive and not with Snow Leopard. The fact that the drive needs to be disconnected and reconnected to be recognized as a boot volume is already an indication that something is amiss.

  • Sierra Whiskey Level 1 (0 points)
    Hi Daniel,

    Indeed, plugging in a Passport drive apres the boot volume selection screen brings up my FW800 WD Passport as the startup disk. I transfered all my applications and documents to the Passport and am now in the process of isolating incompatibilities before I upgrade my production machine.

    It's hard to tell if it's a hardware or firmware issue with the Passport, or some software protocol with Snow Leopard. I'll test it over the USB port and see if this further isolates the issue. For now, I'm just glad there's a procedure to get it working. Thanks for your original post.
  • Sierra Whiskey Level 1 (0 points)
    Just a Quick Update ....

    The FW800 WD Passport 500 GB shows up as a boot volume option using USB. No plugging or unplugging necessary.

    With a Sonnat FW800 Expresscard/34 card on my MBP — the same WD Passport needs to be first unplugged — then replugged into the port to be shown as an option.

    Hope this helps others to troubleshoot the same issue.
  • Howard Ferguson Level 1 (0 points)

    Working from a MacBook Pro 2.4 (Santa Rosa) with 4gb ram, running OS 10.5.7-
    (All external HDs are 7200 rpm)

    Shortly after our fresh install of Snow Leopard onto a new but already tested External 1.5 Seagate Barracuda (with the most current firmware), in an OWC Mercury Elite enclosure-

    We installed Snow Leopard smoothly to that external HD without any issues, and it booted up from that 1.5T external HD, and worked fine.

    Then, still working from the MacBook Pro, I turned on and booted another external HD (a Newertech Guardian Maximus RAID running 10.4.11 via FW800, daisy chained to the 1.5T External with Snow Leopard newly installed.

    Again that's MacBook Pro <FW800> Snowy external HD <FW800> 10.4.11 RAID (booted & working from the RAID).

    But when I tried to bootup up Snow Leopard, after doing the work on the 10.4.11 RAID-
    It would not boot up.

    Though Snowy would appear as an available Start Up disk, each time it was selected as the Boot drive,
    the Internal HD OS 10.5.7 booted instead.

    I changed around the cables and tried repeatedly.

    Same result, no Snowy boot.

    Even after the OS 10.4.11 external RAID was power down, and disconnected.

    After some looking around, I found this forum:

    Got me thinking.

    I tried the USB, and it booted !
    I tried the FW400, and it booted !
    And mysteriously, at this point- I tried the FW800, and it booted !

    And then, the MBP boots seemed to reliably boot from that external, via FW800.

    Snow Cat needs to be taught originally how to find FW800 from the bottom up ?

    Turns out, Snow Leopard doesn't like booting,
    if the preceding boot was on the 10.4.11 RAID, and work was done with programs there.

    So, once again, I repeated this process:
    After working with programs on the 10.4.11 external HD,
    the MBP would not boot the Snow Leopard external HD,
    it defaulted to booting from the MBP internal HD OS 10.5 via FW800.
    even though Snowy was selected for Start Up.
    This was the case repeatedly.

    (It would also boot from the 10.4.11 external RAID, if it were selected for Start Up.)

    (In each of these tests below, I only rebooted the computer at each test. I did no work with programs on the various HDs.)

    SO, once again, at this point of the process:
    I plugged in that Snowy external HD via FW400,
    and it booted up fine !

    Then I booted up from the Internal 10.5, and tried to boot Snowy via FW800 again.
    It worked !

    Then I turned on the 10.4.11 RAID external HD, and tried to reboot from the Snowy external HD.
    It worked too !

    Then I booted from the 10.4.11 RAID, it came up fine.
    Then booted from the Snowy, it came up fine.
    Then booted from the Internal HD 10.5, it came up fine.
    Then booted from Snowy again, it came up fine.
    Then I turned off the 10.4.11 HD, booted from Snowy, it came up fine.
    Then booted from the Internal, it came up fine.
    Then tried Snowy one last time, it came up fine.

    Anyway, the issue is:
    It works fine-
    Except when I do work within the programs on the 10.4.11 external RAID.

    Then I have to use FW400 or USB to get it to boot once again . . .
    Regardless of whether the other external HD is removed from the system.

    It's some sort of flaw, and totally repeatable in testing.

    Hopefully, it will be fixed soon.

  • Daniel Kiechle Level 1 (90 points)
    So, Sierra Whiskey, are you saying that if you plug in the external drive after the boot screen comes up not only does the drive show up, but it can be booted, too? If so, that behavior is different from what I am seeing because try as I may, I have never been able to boot the Passport with Snow Leopard installed in either FW400 or FW800 (though I admit I didn't try USB). Now, of course, the Passport is back on plain vanilla Leopard, so I can't test...

  • Daniel Kiechle Level 1 (90 points)
    Howard, thanks for this very extensive report. I think what you've been able to show is that there is indeed an issue with Snow Leopard booting from FireWire drives. However, your situation is not exactly identical to mine. For example, my external drive doesn't show up on the boot volume selection screen when I boot with the Option key down: I have to unplug and reconnect the FireWire cable to make it visible. This is true regardless of whether I have Leopard or Snow Leopard installed on it. In the case of Leopard, the drive can be booted once it's been recognized; in the case of Snow Leopard, the drive will not boot regardless of what I try.

    I believe that the WD Passport drive has an issue booting a Mac into OS X 10.6 when it is connected to that Mac with FW400 or FW800; this is in addition to whatever problems Snow Leopard itself may have.

    As I stated earlier in this thread, my main reason to use this drive is Time Machine, and the smallish bootable partition is just an emergency convenience. Also, I don't plan to upgrade this bootable partition to 10.6 any longer as this allows me to also use the Passport as an emergency boot disk for an old 12" Powerbook G4 that my wife still uses.

  • ohuq Level 1 (0 points)
    Hello there,...

    I just installed Snow Leopard (SL) on an external RAID 5 System from LMP ( <-German page). Everything went fine apart from after finishing the Install I couldn't boot the SL attached via FireWire 400/800 to my Mac mini. I retried the Install. Same result. When I connected the same Volume to my MacBook Pro (2,53 GHz Unibody) via FireWire 800 it just booted without any problems.
    With the Mac mini I could not even launch the boot manager,..while pressing the "alt"-key the Mac mini starts to boot without showing any alternatives...
    The thing changes if I connect via USB where the Drive will boot without any problems with the Mac mini...
    With the Boot manager of my Mac Book Pro the external RAID-Drive with SL on it will also show normally as a bootable volume which I can choose and boot normally...

    Probably some firewire (driver/firmware?) issues depending on the chipset used?!...We'll see what Apple will do in one of the forthcoming updates...
  • Sierra Whiskey Level 1 (0 points)

    Thanks for the exhaustive troubleshooting. Indeed I think you've helped to identify that it's an issue with "snowy".


    Yes, that's correct it does boot up from the external "Snow Leopard" partition— but only after I unplug, and then re-plug the FW-800 cable from the WD Passport drive. If you recall, the one additional step I performed was to fix the boot sectors on both my internal 10.5.x drive AND the external Passport drive using the *10.6 Disk Utility* repair disk option run directly from the 10.6 Install DVD.

    I'm not sure if that will fix your situation — BUT the repair disk option did update the boot sectors on both drives.
  • Daniel Kiechle Level 1 (90 points)
    Hey, Sierra Whiskey, what's with this "Danielle" thing? As far as I know I haven't had an operation, nor am I scheduled for one...

    Anyway, just to clarify: My MacBook Pro does have Snow Leopard installed, and when the Passport drive failed to boot, I tried to use the version of Disk Utility that comes with 10.6 to repair the Passport. It found nothing to repair. I can't believe that it would make a difference if I ran the utility directly from the DVD as opposed to from a hard disk on which it was installed. The only other thing I could try is to run Disk Utility BEFORE upgrading the drive to 10.6, but frankly, it's turning out to be too much of a hassle. I'm quite happy to leave the Passport on 10.5.x for the moment.

    By the way, I have three other (non WD) external FW hard disk drives, and I migrated two of them to Snow Leopard. One is USB and FW400 and the other USB, FW400, and FW800; I use those with my Mac Pro, but I tested both on the laptop. Either shows up when you boot with the option key down, and either one will boot the MacBook Pro into Snow Leopard without a problem.

    I am left with the conclusion that there is a problem with the Passport drives (as evidenced by the need to unplug and replug), though the Passport boots 10.5 without an issue and only balks at booting 10.6 (at least my Passport does). So, it looks like something in Snow Leopard has changed with respect to booting FireWire drives, and the already borderline Passport seems unable to handle it.

    I'm curious to see whether 10.6.1 will make a difference.

Previous 1 2 Next