Previous 1 2 Next 23 Replies Latest reply: Apr 27, 2010 12:54 AM by mlbosx
xjrguy Level 1 Level 1 (0 points)
I upgraded from Leopard Server 10.5.8 to 10.6

My site has individual blogs and a group wiki.

For some reason, I can't access my individual or group calendars.

It results in an error message saying I don't have permission to view the calendar.

I did not see an obvious way to recreate the calendar for myself or my group, or to fix the permissions.

Has anyone else seen this problem?

Thanks in advance.

Mac Pro and MacBook Pro, Mac OS X (10.6)
  • xjrguy Level 1 Level 1 (0 points)
    All,

    I figured it out.

    I had my "Wiki Server" entry under the Ical Settings page in Server admin set to 127.0.0.1 instead of my FQDN.

    I changed it to my FQDN and that resolved the "You don't have Permission....." error message.
  • eXtremeSG Level 2 Level 2 (245 points)
    Hey xjrguy!

    Thanks, ... you just solved the same problem I had.
    I thought I was because I was messing around with the ACL lists, and had toasted it somehow.

    Cheers!
    Steve
  • xjrguy Level 1 Level 1 (0 points)
    Awesome!

    Glad that helped.
  • Joe Kinney Level 1 Level 1 (5 points)
    I have a fresh install of 10.6 running on our internal network. Other computers in the network can find the machine. Wiki and Blogs are up and running, and I can edit them freely once I log in via the web interface.

    Initially, the Web Calendar displayed the error you wrote about above... "You don't have permission to view this calendar".

    After finding this thread, I changed the default IP address in the Wiki Server portion of Server Admin to what I thought was the FQDN (machinename.domain.net), but what I actually did was use ".com" instead of ".net" at the end. Oops.

    After a minute, I found the error and switched .com to .net. I still get the same permissions error, but now if I'm NOT logged in as a user, and I try to access any web page, I get a dialog that reads...

    ---
    To view this page, you must log in to area “/Search” on machinename.domain.net:80.
    ---

    And none of the logins work. After pressing cancel it reads...

    ---
    Unable to access calendar, because the Web service is configured incorrectly.
    ---

    I can login through the regular login process, but that strange dialog box above will not let me login. Either way I have yet to see a web calendar working.

    Any help appreciated. Thanks.
  • Christopher Manning Level 1 Level 1 (0 points)
    I am having the same problem. Leopard Server upgraded to Snow. Changed the Wiki Server field to the fully qualified domain (server.example.com) with out a trailing dot. Tested to no success, all other Wiki functions seem to be working properly. iCal server was running prior to upgrade and accessible by clients in iCal and that function is still running, just the Wiki leaving me with "You don't have permission to view this calendar".

    Thanks All.
  • wu-shell Level 1 Level 1 (0 points)
    Hi,

    i have a clean installation of 10.6 Server and everything seems
    to work fine (icchat, addressbook server, etc) but the ical server.
    I cant neither connect to the server via addressbook client nor
    over the webpage/wiki.

    I get the same error message "You Don't Have Permission to View This Calendar"
    i also tried to use the trick with the FQDN setting, but this didnt change much.
    Would be nice if you have some hints that get the ical server running.


    Another note:

    ical server logs a lot of garbage into /var/log/system.log
    seems to me not the right place to offload all the logmessages from
    ical ?


    cheers

    udo
  • Mango Buzz Level 1 Level 1 (5 points)
    I had a similar problem. However, I noticed in logs that calendar server ran into an error and exited with an error 1.

    Here is what I ended up doing.
    I had to delete the files located in /library/calendarserver/documents/ (don't forget to backup first)
    I then had to uncheck and recheck the calendar setting for each user in system preferences.
    This corrected the calendar problems for each users. (Assuming the wiki services is selected for that website)

    For groups.
    I needed to setup the group with users using server preferences. Using an Administrator account I logged into the wiki web page and change the settings for that group to allow the correct users and/or groups to access and make changes to the calendar.

    Hope this helps
  • hutene Level 1 Level 1 (40 points)
    Kia ora,

    check your ssl settings, in serverprefs/info, serveradmin/opendirectory, serveradmin/web/sites/security, serveradmin/ical, in the wiki if you turn on ssl, the address starts with https, if no ssl used then address starts with http.
    In my experience the 'you don't have permission error' is due to authentication problems to the iCal server in the web interface.
    I have found that the upgrade uses the default certificate, or creates one if none existed, but its use has to be explicitly identified, to be safe even if ssl is not being used.

    regards
  • lnail Level 1 Level 1 (5 points)
    Okay.. I did have the local IP in iCal server, but have changed it to the FQDN, restarted Web and iCal services. I have double-checked all SSL settings ( ServerPrefs/Info, ServerAdmin/OpenDir, ServerAdmin/Web/Sites/Security, ServerAdmin/iCal ), and they are all set properly.

    EVERY other user can access their calendar and their groups calendar, except me (original server admin).

    iCal Server Error Log shows:
    2009-09-19 18:01:12-0500 [-] [caldav-8009] [QueryProtocol,client] >[calendarserver.provision.root#warn] Wiki lookup returned ERROR: <StatusResponse 403 The >username ( myusername ) corresponding to your sessionID was not found by calendar server.


    Any ideas?
  • hutene Level 1 Level 1 (40 points)
    Kia ora,
    Is your admin account created in the ladp directory, and do they have the same admin names and passwords.

    In 10.5 if the admin/password are the same in the local directory (WGM connect to server.local etc, versus connect to FQDN server) and the ladp directory, then it would throw up a permissions error or similar.
    I suspect your admin does not have an account in the ladp directory (and I don't think there is any reason why it should) My admin account for the server does not have a ladp account but I have made myself a ladp account, different name etc, and assigned it admin rights,

    regards
  • Magus13 Level 1 Level 1 (5 points)
    lnail, Did you ever find a solution to the error? I am having the same problem.
  • lnail Level 1 Level 1 (5 points)
    Yes.. turns out I had messed up with my account. I had setup a server admin account when I first installed, and then later when adding server accounts (not local accounts), I set one up for myself and accidentally gave it the same shortname as the server admin account. It had a different password, but I guess the shortname just left it bewildered and confused. I ended up going into WGM as diradmin and deleting the second account that I had setup, and that resolved the problem right off the bat.

    HTH

    L Nail
  • spraguga Level 1 Level 1 (50 points)
    I am having the same problem upgraded from 10.5 to 10.6. How can the admin not have access to his own calendar?!

    SSL is configured in server info. However, I have also added a user to a group for wiki access in server info and that didn't appear to work. So I am not relying on Server info for anything, it seems very buggy to me.

    Any other apparent ideas to get the web calendar working? I have tried everything above.
  • spraguga Level 1 Level 1 (50 points)
    Got it working now. I had to create my own cert., default wasn't working.

    Thanks!
Previous 1 2 Next