4 Replies Latest reply: Sep 3, 2009 12:22 AM by parish_chap
parish_chap Level 1 Level 1 (15 points)
OS X 10.5.8, iPhoto 8.1

Since creating and uploading albums to Facebook I have changed my Facebook password. Now, whenever I tell iPhoto to Check Now any of my albums I get an error about not being able to authenticate with the server and to check my login and password details.

OK, fair enough, I know I need to do this - but how????

The only place can find to enter/edit my Facebook account details is when I publish, but I don't want to publish any new photos. Surely there must be another way to do this?

Any ideas anyone?

MacBook Pro 2.4GHz, 4GB, 160GB. iPod Touch 2G 8GB, Mac OS X (10.5.8)
  • LarryHN Level 9 Level 9 (62,590 points)
    Select a facebook gallery in the source pane and click on the settings icon in the toolbar at the bottom of the screen

    LN
  • parish_chap Level 1 Level 1 (15 points)
    Tried that already, all that happens is the server authentication error pops up and when I click the OK button, nothing.
  • parish_chap Level 1 Level 1 (15 points)
    I've now u/g to Snow Leopard and when I click OK to dismiss the Server Auth error the Facebook Settings dialogue appears asking if I want to change the settings for the album. the only problem is that the Change Settings button is disabled, only the Remove Account from iPhoto and Cancel buttons are enabled.
  • parish_chap Level 1 Level 1 (15 points)
    Well, I've found a workround.

    Select a photo - any photo - in your iPhoto Library, then click the Facebook button at the bottom of the window. This brings up a Facebook login dialogue. Enter your username (mine was already filled in) and password and click Login.

    When the Publish dialogue appears, click Cancel.

    Now when you right-click an existing Facebook album and select Check Now it works. On one of them I still got the Server Auth error, but when I dismissed that it worked correctly.

    Whether this survives across exiting/restarting iPhoto - or a reboot - remains to be seen.

    I'm sure this is a bug as the workround is so kludgy and un-Apple-like.

    One thing, I maintain albums for two Facebook accounts (mine and my gf) so maybe that has something to do with it?