Previous 1 2 3 Next 107 Replies Latest reply: Aug 2, 2014 4:24 AM by Lurkums Branched to a new discussion.
Mishutka Europe Level 1 Level 1 (0 points)
Can anyone help?

I am trying to empty trash, having just installed Snow Leopard. However, I keep getting an error -8003 (which is not documented anywhere in the error code pages).

I think it may have arisen because I deleted some backup files as I have moved to Airport Extreme for Time Machine - other forums have discussed this but none have any resolution

iMac, Mac OS X (10.6)
  • thomas_r. Level 7 Level 7 (29,205 points)
    If you deleted files from your Time Machine backup using the Finder, then you've just destroyed your backup, most likely. You're probably going to need to reformat the hard drive, unless you are able to put all the files back exactly where you moved them from. Time Machine backups have some special quirks and are not meant to be accessed via the Finder.
  • Agent680 Level 1 Level 1 (0 points)
    I am getting the same error. I did not delete any files and have not even used Time machine yet.
  • rafals Level 1 Level 1 (0 points)
    I have the same.
    I was trying to remove old beckup file from external harddrive.
    First I try to enter TM on old beckup and go to menu and do "remove all beckups of this drive or somethig like this"
    That donst work so I try to remove the file from HDD to trash using the finder and now I have some file in trush and I cant remove them and I cant put them back to the old folder.
    Andy solution??
  • Shuttle guy Level 1 Level 1 (0 points)
    It is all due to the fact you deleted files from Time Machine through finder.
    Re-install Snow Leopard, as soon as it booys start deleting trash, error code will be gone, at least thats the way it worked for me
  • Shuttle guy Level 1 Level 1 (0 points)
    re-install Snow Leopard, files will be able to be deleted
  • Vinmar Level 1 Level 1 (85 points)
    I almost hate to offer this suggestion but you can try using the command line to empty the trash. Disclaimer: you can do serious damage to your installation at the command line (esp. using the 'rm' command). Make a full backup first and proceed at your own risk.

    - Open Terminal.app and type in the following quoted commands (don't type the quotes...)

    - type "cd /" (and/or type "cd " then drag the disk icon for each of your disks to the terminal window)
    - type "cd .Trashes"
    - type "sudo ls -a" (Note: you will be asked to enter your admin password - this is to see a list of files and directories in the .Trash directory)
    - type "sudo rm -R (and the file or directory name exactly as named, or * to delete all the files at once)" - be very careful with this command and make absolutely sure you're in the .Trashes directory.

    This should delete those pesky files.
  • Mishutka Europe Level 1 Level 1 (0 points)
    In the end I used Trash It! http://www.macupdate.com/info.php/id/8214 which did the trick for me
  • Arfur3 Level 1 Level 1 (0 points)
    I have just used trashit after getting the -8003 error message. It worked like a dream. I sent him a donation of a fiver - it was worth it.
  • sansnuages Level 1 Level 1 (0 points)
    I also used Trash It! after several other fixes including Apple Support and it was the only thing which worked. It isn't exactly obvious that it's working but I had gigantic files I was trying to empty from the trash so it took a very long time to do it. It did work though when nothing else did.
  • hawpotr Level 1 Level 1 (0 points)
    Hello,
    I have had this happen a few times before the software update (OS 10.6.1) and used the Disk Utility to Repair Disk Permissions, then restarted the computer (MacBook Pro 2.33 GHz Intel Core 2 Duo). Most of the time I was then able to empty the trash. Sometimes I also ran the Repair Disk function on the external HD that I was using for Time Machine back ups too, then ejected the HD and restarted the computer. Then I remounted the HD and was able to empty the trash.
    Good luck.
  • bpeacock22 Level 1 Level 1 (15 points)
    Thank you for the Trash It! link. Working like a charm. At first I got error -8022. I searched these forums, support documents, and Google....nothing. So I rebooted and tried to empty trash again and got -8003 and found my way to this thread. Incidentally, I was trying to trash old Time Machine files too, wanting to make some more room for my FCS content install.
  • bpeacock22 Level 1 Level 1 (15 points)
    Yikes! I woke up to find Trash It! had crashed and 40 GB of my hard drive space were taken up from something. The trash bin was empty though. :/

    I've written the Trash It! devs to see if they can point me to where I might reclaim that 40 GB of HD space, but thought I'd check here too.
  • Andrew Firestone Level 1 Level 1 (0 points)
    I like most of you was deleting TimeMachine backup files. I ended up with the 8003 error. Unlike the rest of you TrashIt didn't work.

    I am currently running through three options. 1) Hooking up the external to a different 10.6.1 laptop and deleting 2) hooking it up to a 10.5 MacPro and deleting 3)Repairing permissions on both disks.

    I will keep you all posted incase someone else runs into this same problem.

    --
    Andrew
  • Steve Weaver1 Level 1 Level 1 (15 points)
    I just made the same mistake after getting a window that I was running out of room for Time Machine backups. I have a partitioned external HD. I went to Time Machine preferences and did not see a way to delete old backup files so I did it through the finder. Now I am trying different ways to get things corrected. Trashit worked for about 10 seconds and then all the files reappeared. Now I am about to run repair disk on the external HD.

    What is the proper way to delete the Time Machine backup files?

    Thanks.

    Steve
Previous 1 2 3 Next