Previous 1 2 3 4 Next 107 Replies Latest reply: Aug 2, 2014 4:24 AM by Lurkums Go to original post Branched to a new discussion.
  • Steve Weaver1 Level 1 Level 1 (15 points)
    Ok -- finally emptied the trash can. Nothing worked although I did run repair disk on the external hard drive because it was needed. The only way I finally got the trash emptied was to go to disk utility and erase all the data in the partition set up for Time Machine backups. The result of that was the trash being emptied. So I started over with Time Machine after that.
  • wase4711 Level 1 Level 1 (0 points)
    Pathfinder will empty trash files when SL wont as well...

    Bot, Snow leopard really is starting to remind me of Windoze.....all sorts of OS issues that were never present before..what's wrong with Apple?????
  • Allan Eckert Level 8 Level 8 (46,675 points)
    Hi Steve Weaver1;

    Were you attempting to delete items from Time Machine?

    Apple recommends against doing this. It is recommended that you allow Time Machine to do the deletions by itself.

    Allan
    tiger
  • Steve Weaver1 Level 1 Level 1 (15 points)
    Yes. I was trying to delete files in Time Machine backup because I got a warning window that the backup file was full and to check my Time Machine preferences. When I checked the TM preferences I didn't see anything pertaining to the warning window. So I tried to delete myself. I have learned my lesson!

    steve
  • danny2000 Level 1 Level 1 (0 points)
    I too was trying to trash old Time Machine files after migrating TM to a new drive. I used Cocktail to empty the trash of the old TM drive and then used the normal Finder empty trash to get rid of the rest.

    Seems to have worked fine so far!

    Apple, what's going on, I've had more silly issues with SN than I have with any other OS X release.
  • biddymon Level 1 Level 1 (0 points)
    Thanks very much for the link to TrashIt.

    I installed Microsoft Office 2008 and one of the last installation functions was to trash Office 2004. However, the trash would not empty upon command, with the Error Code -8003 signal. I tried every conceivable technique to empty the trash, but the only thing that worked was TrashIt.

    That was great advice.
  • Paul Norman1 Level 1 Level 1 (60 points)
    TrashIt did it for me too. I also sent a donation.
  • tonywardmusic Level 1 Level 1 (0 points)
    Casting another vote for Trash It..... worked like a charm for me. Maybe TM and I can now live in peace.
  • Soapy_1 Level 1 Level 1 (5 points)
    I agree, since SL there have been so many crashes when using Apple products! It is really starting to bug me as my workflow has slowed down and I seem to be having to, on a daily basis, lose hours of work by fiddling with OS bugs . . . don't know why Apple laughed so loud at their rival's problems when they seem to be creating their own Karma! I am seriously thinking about going back to Leopard. And for the first time have stopped recommending Apple computers out right . . . to be reminded of experiences of another OS is so un-Apple! In Leopard I could delete old T.M. backups from finder with no problems. I am currently waiting for Trash It! to see if it works. Get a grip Apple!
  • EricB73 Level 1 Level 1 (0 points)
    Hi All,

    I'm having the same problem as you all are. Trash not emptying (error 8003), Time Machine runs for hours on hourly back up (I know the initial takes a while).

    Feeling the same way about Snow Leopard but will refrain from commenting as Apple doesn't seem to like it, my last post was removed by them.... All I asked is if Bill Gates took over Apple.... Windows 7 is looking pretty good about now...lol. Opps, sorry Apple, I know freedom of speech is not allowed on the forums...I'll expect an email stating you removed my post my post.

    Eric
  • Peter Biffar Level 1 Level 1 (5 points)
    Used TrashIt (see link in earlier post) as was suggested earlier, works perfectly in seconds! Made my donation since this saved me hours!
  • yeiichi Level 1 Level 1 (0 points)
    Just try "Secure Empty Trash" from the "Finder" menu.
    It worked right for my case
  • mjsr Level 1 Level 1 (0 points)
    Trash It just did it Had the 8003 error after deleting Time Machine files using Finder.

    The MBP's logic board got changed and I had 2 different set of backups on my drive. Couldn't Apple make it easier for people to fix that kind of problems?
    I had the issue because the mac had to be repaired...
  • Kevin Williams5 Level 1 Level 1 (5 points)
    Trash It is the trick, should be standard issue with Snow Leopard!
  • lil_broskee Level 1 Level 1 (0 points)
    tried this and it worked for my TM stuff. but now i get it from anything
Previous 1 2 3 4 Next