Previous 1 6 7 8 9 10 Next 137 Replies Latest reply: Mar 24, 2014 3:45 PM by charliefromelgin Go to original post
  • Mr Office Level 1 (0 points)

    Hi folks,


    After buying a new HD because I thought my old one was knackered due to the random ejecting I have found a solution to my problem. I really hope it works for other people too.

    All I did was plug my HD into an Apple Cinema monitor and run Time Machine/transfer files from there. No random ejecting whatsoever.

    It's not very practical for folks that don't have a monitor, but hopefully it can shed some light on why the issue was happening - i.e. surely it can only be a hardware problem?

    My Macbook Pro also has a common issue (if it's an issue) of excess voltage running through the body, as a total stab in the dark maybe the two are linked? I honestly have no other ideas.

    I've not heard anyone mention the excess voltage as a possible reason for this so it would be interesting to know if anyone else has both issues. Although a lot of folk have had their HD eject problem fixed by reinstalling their OS so I suppose there could be many factors behind the random ejects.

    If I didn't find out this workaround then I would be pretty shagged unless I bought a Time Capsule or lots of DVDs as the random ejects ruined my last HD so all my data was only on this Mac.


    Hope this has helped,




    Mr Office

  • Nickelbacker Level 1 (0 points)

    Just wanted to add in that I also have the problem. The fix suggested by MrHoffman did the trick in Snow Leopard, but after the upgrade to 10.7.1, it has occurred again.


    Please Apple, don't make OSX look like Windows! Fix the problems...

  • geirhaa Level 1 (0 points)

    I have got a Lacie external HD (firewire) with this very problem of disconnecting frequently (on OSX Lion). I tried just entering the HD as shared with only myself having any access, and it seems to have fixed the problem; TimeMachine is up and running, no disconnections.

  • Raymon Goes Level 1 (0 points)

    Have the same problem here.


    New iMac 21,5 inch, with Lion 10.7.2 and fully updated. My external HDD is connected directly to Mac (it is a new Samsung M3 1,5 TB which supports USB 3 altough the Mac doesn't) and has its own power supply. I formatted it to exFat. It is not used for Time Machine (I have the newest Time Capsule for that).


    When waking from sleep i get the 'not ejected properly' message and i have to crawl behind my iMac to disconnect and reconnect the usb cable (pain in the *** and causing scratches all over the back of my new mac, not to mentions flashes as the back seems to create static electricty).


    Seeing as how everyone raves about Apple and 'It just works' I am very disappointed by the fact that such a problem, constituting multiple OS versions has not been fixed after more than 2 years.


    Togheter with the iCal vs Google Calender problem (erasing Google Calender when you activate iCloud forcing Google to no longer accept 'delete' commands from iCal, rendering it useless for the large amount of people using Google Calender) it is one of those pesky little things that annoy people.

  • tkbells Level 1 (0 points)

    This issue seems to have resolved itself (for me anyway) with the latest system update.


    I am using a WD 1.5 TB green drive in a macmall esata fw400 enclosure.

  • Wheelson Level 1 (0 points)

    I was seeing this error with FireWire800 LaCie drives and the "error -50" on LaCie P'9231 USB 2.0 2TB external hard drives. After upgrading the LaCie drive's firmware and installing the latest version of the "LaCie Desktop Manager" and after reformatting the drives to Mac OS Extended (journaled) / GUID Partition Table That fixed the FireWire 800 drive but not the USB drives. The USB drives would still throw the -50 error after they went to sleep (after 5 minutes of inactivity). I then went to System Preferences->Energy Saver and ticked the box next to "Put the hard disk(s) to sleep when possible" (Lion 10.7.2). After the energy saver change both the missing drive on the FireWire 800 external disk and the error -50 on the external USB drive have gone away.

  • elevenmedia Level 1 (0 points)

    Long time reader, first time poster. I had a very important Seagate 2TB External spontaniously eject for a few days until it finally could not mount. I tried everything to get it back, but that is another story.


    I have two 1TB LaCie and one 2TB LaCie USB drive attached and they started to eject while copying a large amount of files. I could not get past 100gigs without it ejecting. It would also eject overnight, sometimes, if I left it connected.


    I read this post and a number of others about the issue and tried everything to get them to stop ejecting. I had also upgrade to Lion when the ejects started, so I automatically blamed Lion.


    Here is everything I tried:

    • Ran Disk Warrior and Tech Tool Pro on the drives but two would eject half way through the tests. No data was lost as I was only running tests.
    • Ran Tech Tool Pro and Disk Utilities on the iMac i7 hard-drive. Nothing found except a few wrong permissions.
    • Tried to revert back to Snow Leopard, but couldn't get it to install on the machine.
    • Researched to see if Apple partitians vs GUID partitions caused the issue, but ejects happened on both.
    • I didn't test to see if it was only USB and not firewire.
    • Tried different cables, less drives attached at once.
    • Changed powerbars from a UPS system to a normal powerbar.
    • Jiggled the cable, sacraficed some chocolate animals and cursed.


    Final solution that worked:

    I read on one of the discussions about power issues with the USB drives. I thought since all my drives were powered it didnt effect me. As it stuck in my head, I connected the drives to a cheap powered USB hub. That was pretty much it.

    • I can now transfer larger sets of files. 500gigs over night worked perfectly
    • Ran Tech Tool Pro to check all the sectors of the drive (which takes 8-9 hours) and it completed just fine.
    • No ejects .. and I should have had about 10 by now
    • It has only been a week since It has been running fine, but I have been able to succeed and everything is working as normal.


    What my designer's theory is (no hardware background):

    • Lion changed something about power signals through the USB connection that is ejecting on weaker signals and needs power to see the drive properly.
    • My USB interface card (or whatever it is) is starting to kick the bucket.


    Hope some of this helps. I don't say that I have to solution, but this is simply what worked for me.

  • tkbells Level 1 (0 points)

    Just wanted to point out that the issue i had that seemed to go away, has started again....***

  • Yaelle Ridley Level 1 (35 points)

    Just to add my two pennies worth. I have a Lacie NetworkSpace 2 and have been suffering the same problem since the LION upgrade. I've doe all the firmware updates and things have been pretty stable since the last one until January 9th when the problem has started again only subtly different. Where before I couldn't mound the partitions, now the disk is just getting randomly ejected. I've tried it with both ethernet and USB connection but it seems to make no difference. And I've been through everything I can think of including a full reset and reformat of the drive.


    I've had to do a brand new TM backup (557 GB) which ran fine for the first 16 hours then the partitions just disappeared. I was about to go order a new USB/Firewire drive but found this post :-) At least I've saved some money. I'll watch with interest.

  • Wheelson Level 1 (0 points)

    Did you try System Preferences->Energy Saver and tick the box next to "Put the hard disk(s) to sleep when possible"? That fixed USB ejection issues on Lion for me.

  • Yaelle Ridley Level 1 (35 points)

    Thanks - yes I tried that. Seems to make no difference.

  • slammens Level 1 (0 points)

    Experiencing exactly the same issue on my MBA with Lion and a Freecom Mobile Drive XXS USB powered hard drive. Got another external hard drive that is self powered -- have yet to experience any issues with that one.


    Should I just take my MBA back to the store and get another one?


    23/01/12 20:03:55,000 kernel: disk2s2: device/channel is not attached.

    23/01/12 20:03:55,000 kernel: disk2s2: device/channel is not attached.

    23/01/12 20:03:55,000 kernel: disk2s2: device/channel is not attached.

    23/01/12 20:03:55,000 kernel: disk2s2: device/channel is not attached.

    23/01/12 20:03:55,000 kernel: disk2s2: device/channel is not attached.

    23/01/12 20:03:55,000 kernel: disk2s2: media is not present.

    23/01/12 20:03:55,000 kernel: disk2s2: media is not present.

    23/01/12 20:03:55,000 kernel: jnl: disk2s2: do_jnl_io: strategy err 0x6

    23/01/12 20:03:55,000 kernel: jnl: disk2s2: write_journal_header: error writing the journal header!

    23/01/12 20:03:55,000 kernel: disk2s2: media is not present.

    23/01/12 20:03:55,000 kernel: disk2s2: media is not present.

    23/01/12 20:03:55,000 kernel: disk2s2: media is not present.

    23/01/12 20:03:56,000 kernel: jnl: disk2s2: close: journal 0xffffff800bb16990, is invalid.  aborting outstanding transactions

    23/01/12 20:03:56,000 kernel: 0        0 AppleUSBCDC: start - initDevice failed

  • bfreebody Level 1 (0 points)

    I've had this issue for a while - Are you running MOVESLINK s'ware by any chance?


    I shut mine down (was a application running in the background waiting for a device to connect).


    Now I have no issues...


    As soon as I load MOVESLINK back up > bam! The USB/SD disk ungracefully dismounts...


    I need to do some digging but thought to share.

  • Yaelle Ridley Level 1 (35 points)

    I gave up and re-installed Lion clean (not an upgrade) Problem solved.

  • Maxim Porges Level 1 (5 points)

    I get this issue occassionally with both an external MacAlly 2.5" drive enclosure over Firewire 800, and also with a SanDisk PCI ExpressCard adapter used for transferring photos from an SD card. Didn't start on my hardware (15" original late 2008 unibody MBP) until after the Snow Leopard upgrade.


    I find that a reboot always fixes the problem immediately, but I'm not sure what triggers a relapse back into a problematic state. It could be that the issues start after waking from sleep. I haven't seen the issue in a while, but my laptop is usually left plugged in and turned on. I put it to sleep to take it on vacation this weekend and I saw the problem again.

Previous 1 6 7 8 9 10 Next