Previous 1 6 7 8 9 10 Next 137 Replies Latest reply: Mar 24, 2014 3:45 PM by charliefromelgin Go to original post
  • Proggie Level 4 Level 4

    I have a La Cie Neil Poulton 1TB that ejects once in a while. It seems to do it when it's very active (transferring lots of data or doing a Time Machine backup). I'm on 10.7.4 at the moment but it has occurred ever since I got the drive on earlier versions of the OS. Very frustrating!

  • Cheryl Nemazie Level 1 Level 1

    After I upgraded to Snow Leopard 10.7.3, I began having this problem with both of my Passport 1tb drives.


    I just installed the upgrade to 10.7.4 and it seems to have cleared everything up. Of course, as an earlier contributor suggested, doing resetting the SMC (System Management Controller) may have also helped. Now, 24 hours after the upgrade and reset, both drives are still connected.


    To save you the search, instructions for doing an SMC reset on Intel Macs is here:


    I did not reset my PRAM, which was another recommendation.


    Hope this helps someone!

  • Jonfinpa Level 1 Level 1

    So can anyone say which is the best way to add additinal Hard Drive space? Do I take my mini apart and add a larger drive inside, or take a chance on all these issues with a external firewire or usb ?



  • memalyn Level 1 Level 1

    I have pretty much reviewed all of the posts at this point and it looks like we all basically have the same problem; our external drives are being ejected randomly, and I say randomly because everyone has tried different methodology to track down the problem and no one has really definitively identified identified the culprit!! Yet we all continue to have the same issue.  Don't get me wrong, I am not a computer expert, not even a mid-level expert, but I have three WD external drives, one I use for nothing but Time Machine backups, one I use for downloading music and photos to and that one, for some reason,  decided to copy a number of My Documents to it,  (as I said I am not a computer expert I was much more comfortable with DOS & Windows) and I have a third WD drive I have never used becaused it is formatted for Windows and I am too lazy to do  it.  I also have a partioned drive for Windows because I have not been able to give up Quicken.  I recently began pausing my Time Machine backups while I work in Quicken because the process slows Quicken down to a crawl. Mind you I do not have a large number of files on my computer so I am not sure why it slows it down slow much.  So, even though I have recently been interrupting Time Machine backups, so long before I did this, my WD drive spontaneously ejected completely without warning  My WD drive has always ejected at the most unusual times and I, being the novice that I am, just unplugged it because there was no eject icon and the eject key would not work. It has not increased in frequency since I began to interrupt the backups.  Suddenly I got an error message starting several days ago that the backup could not be completed, and I assumed it was due to a full drive (had this before) and I pretty much ignored it.  Today, however, I got an error message saying that the disc could not be backed up or repaired and has to be formatted. Also My iPad says I have no backups - not true, I should have backups but that is another story because I still have not figured out iCloud and Siri hates me. But. Long story short, I've shut everything down until I figure out what to do since I'm still recovering from a hard drive failure in JUNE 2011  when Time Macihine decided the drive was full and did do any more back ups and I sure don't want to go through that again.   I long for the days when I had a tape  backup drive and switched the tapes out myself!  I'm hoping I can consolidate some of the info I have read here but I think I will just turn the computer back on, hope for the best, most likely the drive will show up as it usually does, and I will try to repair it. If that works, I plan to use Carbon Copy to clone the disc and go from there.  If anyone has any better suggestions, I would definately welcome them with open arms as long as it does not involve RAID, SMC, Sleep settings or anything else complicated that I can't grasp!! 

  • Jonfinpa Level 1 Level 1

    Mini server 10.6.8 plugged in a 3 gig

    800 FireWire external drive, sever goes to sleep and so do the drives

    Have no problem, the drive has functioned correctly sense the day I plugged it in.

  • mahanr2 Level 1 Level 1

    This is driving me crazy on my Macbook Pro; I am running the latest version of Snow Leopard (10.6.8). I have a range of external drives, some self powered and some not who all eject randomly. I use no hubs, I checked all the power supplies, cables and I am positive those are not the culprit. I have tried resetting the SMC, changing sleep settings; from what I can tell everything that has been suggested here. I have two self powered Lacie USB drives, a USB powered Western digital drive (time machine) and my android phone all eject randomly some time after mounting. This mounting can happen after sleep, during an operation or when it is idle. I guess I should not have downgraded from Lion because that was the only way I could have fixed this problem.

  • alanjswan Level 1 Level 1

    thanks this worked apart from the reconnecting to mac but it is stil working through HUB so I am happy!

  • gperetz Level 1 Level 1

    The problem is worse than ever for me now after the 10.8.3 update using my Seagate FW800 2TB GoFlex drive. I'm continually seeing the drive disconnect, losing all my sidebar shortuts and any open work i have from off the drive. Computer is set not to sleep (only the display). The freeware program Keep Drive Spinning was working okay under 10.8.2, but not now...

  • bnmphoto Level 1 Level 1

    I just strted having this problem in the last to days (The imac is about 2 years old) and I've conncected all manner of USB stuff to it (Jump drives, card readers, External HDD, etc) without any problem..... until now.


    Today I noticed (yes I got the disk was improperly ejected message) that 4 of the 4 USB connections didn't seem to work. I plugged a brand new 4TB seagate drive into one of them and it was not recognized!. I restarted the computer and the new drive was now seen by the machine as well as the drive that was 'ejected'.


    This may be too simple, but could this issue be connected to the software that controls the USB ports (or the ports themselves going out !?)  I'm no tech guy, but it just seems to be the last thing - I've read through all these posts...... TM on / off, sleep on/off, disk sleep on / off - all with no help.


    Others have reported NO issue with firewire drives...... seems to me that the issue is with the usb ports.


    Any thoughts on that?


    I gotta get this worked out, this is a shared drive and I do a lot of work to and from it....    just saying.

  • pierrefromrichmond Level 1 Level 1

    After suffering for more than a year my electronic engineer reptile brain made me think "this randomness must be thermal", so I ensured the external HDD would STAY COOL -- turned it on its edge, away from any walls or supports....


    And bingo. Almost zero ejections. I think I had 2 since the change... about 1% of the previous rate.


    Of course the platters are now vertical, so it could be a gravitational effect on the head mechanism. But whatever the reason, I'm now happy, especially since TM saved my butt once again after not committing code changes for a whole day.


    Hope this simple fix can help someone else.

  • Cheryl Nemazie Level 1 Level 1

    I've since purchased a new external drive and have not had a problem. But regarding your 'experiement', I'm wondering if the cooling technology in my new drive is just more efficient than the old one. Thanks to your post, I'm going to try your suggestion with the old drive.

  • iochroma Level 1 Level 1

    My external Hitachi switchless SimpleDrive, being used as a TM, started to misbehave recently with random spontaneous, unsafe disconnects.  A trawl through many web sites leads me to believe that this is a common problem that has attracted many differing suggested cures but no one consistent remedy that has worked.


    Most mornings when waking my iMac from sleep I would get the unsafe drive removal message.  The drive light was still on. Removal and reinsertion of the USB lead alone had no effect: the drive refused to re-mount. The power lead had to be disconnected and reinserted for the drive to become recognised once more.


    I conducted a number of experiments with different HDDs in the enclose and power tests and came to the conclusion that my problem is related to 2 features of these drive enclosures in particular:


    1) they have no on/off switch but become active when both the USB and power lead are inserted

    2) the 12V/1.5 A rated power brick (or HDD drive) degrades with time and it can no longer maintain the voltage when supplying the surge current at the drive spin up.


    In my case, once the HDD spin up surge current had momentarily pulled the drive voltage below a threshold level the enclosure electronic interface, detecting whether to power down the drive, triggered a shutdown and the unsafe removal message. This was almost immediately followed by the voltage returning to normal, but the drive was left in an abnormal powered up state (light on) but still disconnected from the USB interface. 


    My solution was to replace the power brick with another with a higher current rating.  I now use a 12V/2.25A rated power brick with the enclosure and the SimpleDrive appears to be spinning up without problem either from sleep or sudden access.  At under £7 it is a cheap test/fix.


    This may not be the solution to all the problems reported but it does explain the seemingly random nature of many of the events.  The transient response of the power brick needs consideration with these switchless drive enclosures and the one supplied is, I believe, is marginal. Hope this may be of use!

  • nitagale Level 1 Level 1

    Mine acutally just ejected again as I was typing this. I've tried everything in this posts. System Prefs, sleep hard rives on hard drives off - insatlled caffeine and other apps that prevent computer from sleeping.


    What's worse that any attempt to backup my external (WD 1 TB) drive to an onlien cloud also ejects the drive.


    And each time this happens I lose DATA


    This is FU""KING ridiculous

  • DanjoCross Level 1 Level 1



    I run a film program, and I have seen this problem happen twice, where the hard drive partition (where students save all of their work) is ejected from the Event Library and the Project Library right after Final Cut X opens (but you can still see the partition in Finder).  The IT guys came down to look, and suggested it might be a "corrupt filename" causing it.  They also noticed something strange: Final Cut could still IMPORT from the ejected drive, but it was listed under "Cameras" rather than "Devices" where hard drives are usually listed.  That got me thinking; what if something is causing Final Cut to think the hard drive is a camera? 


    So I looked at the files that students had saved to the drive that kept ejecting, and sure enough, I saw a camera archive on there; the student had copied the entire contents of an SD card we use in our AVCHD cameras (a directory that is named "PRIVATE" by the camera).  So I took this "PRIVATE" folder (or archive or whatever) and moved it inside a folder on the drive, et voila!  Final Cut no longer ejected the drive! 


    So you might try looking at the files on the drives you are having problems with.  If you have camera archives on there, you might try putting them inside folders, so Final Cut does not mistake your hard drive for a camera. Simple mistake, right?  Stupid computers! 


    Hope this helps some of you.  If it works, pass it on. 



  • aluth23 Level 1 Level 1

    I was having this same issue on a MacBook Pro, drive worked fine, next time I tried to use it after upgrading to Mavricks, it would randomly eject and remount over and over again. I found this on another post and it seems to have corrected the problem (for now atleast) easy and worth a try. Go to spotlight in the System Preferences and add your external drive to the privacy tab. My harddrived is partitioned so I added both.

    Timemachine has been running for about 20 mins now with out issues, typically before wouldn't make it past 5. Hope this helps some of you out as this is a super annoying problem!

    Spotlight Setting.jpg

Previous 1 6 7 8 9 10 Next