Previous 1 3 4 5 6 7 Next 137 Replies Latest reply: Mar 24, 2014 3:45 PM by charliefromelgin Go to original post
  • explorz Level 1 Level 1 (45 points)
    Also running 10.6.3 and it still occurs.
  • soules Level 1 Level 1 (0 points)
    I have the latest version 10.6.3 , it still ejects randomly.

    1 thing i noticed is that some files the snow leopard cant copy to usb disk. It will give you eject.

    When restarting your mac and if you put your files in your usb drive right after it restarted. It will work without error unless there are some files leopard cant read. I did this with the default settings and without power adapter to the usb drive and i have a macbook unibody.

    When 1e time succeed the 2e time doesnt work. So you need to restart your mac again.

    I just hope mac company will fix this with some update because it seems this problem is still the same from 6 months ago.

    gr,

    soules

    Or for the time being upload your file to some sharing upload site for alternative
  • niftyken Level 1 Level 1 (0 points)
    I started having the problem today. iomega 500GB drive just randomly gets ejected. I'm on OSX 10.6.4 and the drive is plugged in directly to my iMac via Firewire 800. (It's a 2.5-inch drive being powered solely by FW800.) Happened about 4 times today already. Sometimes I was working in Adobe Lightroom and sometimes I was just sitting at the Finder with no apps open. Sometimes it happens quickly after plugging it in. Other times it happens after a good hour of work in Lightroom. Thought it was my external drive starting to fail, but given the prevalence of the problem online, maybe it's something else!
  • turnbull Level 1 Level 1 (0 points)
    I've had exactly this (really annoying) problem for a couple of weeks now with a WD Passport 500gb, Mac edition, journaled) plugged via usb into a brand new Mac mini running OSX 10.6.4... and I think I may have found the root cause and solution...

    A little history first - the passport had been happily working away with no problems on my old Mac mini (OSX 10.5) for a few months before my mini spectacularly died with main logic board problems. Since day 1 with my new mini, I have been experiencing random eject issues with this particular drive. Interestingly I also have 2 more WD passports, one USB, one Firewire 800 which have worked perfectly on the new mini.

    Looking at my system log in Console at the same times as the random ejects I was seeing the following error relating to Spotlight: SIStoreDirytySDBChunks:Error storing dirty sdb pages. Aha I thought, Spotlight for some reason can't index this disk, and sure enough when I stopped Spotlight from searching that volume the random ejects stopped.

    My next step was to move all the data off the disk as I thought that an Erase would solve the issue properly. So I did this, before copying half my data back yesterday and turning spotlight back on for that volume. Success or so it seemed until today. As I was copying across my remaining files and folders the disk randomly ejected again. I was able to consistently recreate the eject by copying this one particular folder across. I created a new folder manually on my drive (with the same name) and copied the original files across with success.

    So in summary it looks like the eject problem is narrowed down to a folder or hidden system file(s) within that folder creating an error when accessed within Snow Leopard (and therefore the apparent randomness of ejects being created by Spotlight attempting to index this as and when). The actual data files within the folder copied fine and since creating my new folder structure I have so far had no more random ejects. The original folder worked fine in Leopard. Let me know if this works for you, and I will keep you up to date on hopefully no more random ejects
  • Umble Level 1 Level 1 (0 points)
    My Freecom XXS Usb Samsung Hard Disk Drive, Model: HM500LX (500GB/5400rpm/8M), got probably damaged after being automatically ejected and connected again and again and again and
    I thought it is the disk. But another Freecon XXS 250gb begins getting automatically ejected as well.
  • CTitan Level 1 Level 1 (0 points)
    My problem: It started today, about a week after I formatted my few years old Seagate Freeagent Desktop ext hd to mac os x extended. Basically, it just disconnected for no reason, and gave me an error, saying that I should disconnect properly. I had to reconnect my seagate all day, sometimes waiting awhile, usually having to restart my imac. I verified and repaired the disk, but it was fine.

    Below is a possible solution that may or may not work for you and which I take no responsibility:

    On the previous page, a poster linked to a problem related to time machine (http://discussions.apple.com/message.jspa?messageID=6228348#6228348). In that post, it says-

    +PROBLEM: An external drive has an incomplete or apparently empty Spotlight index (searches return nothing at all or only partial results), and the usual procedures for getting Spotlight to re-index the drive, e.g., putting it into the Spotlight Privacy list and removing it again, or even running the terminal command:+

    +sudo mdutil -E /Volumes/YourDiskName+

    +do not resolve the problem.+

    'man mdutil' in the terminal says that the -E parameter deletes the indexes and I know that after logging out and back in, the index for all volumes starts to rebuild even if you used -E. So in other words, -E only deletes the index, it doesn't stop the index from being rebuilt. And to fix this, you'll want to disable indexing on your ext hd.

    Some options and descriptions from 'man mdutil' in the terminal-

    +Main commands for mdutil-+

    -E
    +This flag will cause each local store for the volumes indicated to be erased. The stores will be rebuilt if appropriate.+

    +-i on | off+
    +Sets the indexing status for the provided volumes to on or off. Note that indexing may be delayed due to low disk space or other conditions.+

    -a
    +Apply command to all volumes.+

    First, show hidden files. The link above has a terminal command for it, but I simply used tinkertool (http://www.bresink.com/osx/TinkerTool.html). You'll need to show hidden files to delete .Spotlight a few times. Also, you may have added a file named '.metadataneverindex' to your ext hd root to stop indexing. Delete it since it causes an error (and I don't think it even works since .Spotlight kept being created with it in there). You shouldn't need it if the method below works.

    To stop all indexing-

    sudo mdutil -i off /Volumes/internalHD
    sudo mdutil -i off /Volumes/externalHD

    Then, to delete the old indexes (local stores), you use-

    sudo mdutil -E /Volumes/internalHD
    sudo mdutil -E /Volumes/externalHD

    I would check the ext hd with hidden files shown, and delete the .Spotlight folder if it is there, and empty the trash before I log out.

    Also, you can log out and back in at this point if you want to, but since I wanted Spotlight to keep indexing my internal hd, I did this command before I logged out-

    sudo mdutil -i on /Volumes/internalHD

    ('on' and 'off' are part of the commands above and not me directing you :P )

    Then I logged out and back in. Spotlight started indexing the files on /Volumes/internalhd, and it didn't index my ext hd. Still, check your ext hd, and delete that .Spotlight folder if it's there.

    If you want to check if a drive is enabled or disabled once you're logged back in, use-

    sudo mdutil -s /Volumes/eitherdrive

    My results ('HD' is my external hd)-

    *JohnDoe-iMac:~ johndoe$ sudo mdutil -s /Volumes/HD*
    /Volumes/HD:
    Indexing disabled.

    *JohnDoe-iMac:~ johndoe$ sudo mdutil -s /Volumes/Macintosh\ HD*
    /:
    Indexing enabled.

    I won't know for sure for another day or two, yet I am doing things that were causing it to eject earlier (downloading large files to it, etc) without it ejecting now.

    So all in all, stop all indexing, delete indexes (local stores), turn back the indexing on your internal hd (if you want to), log out, log back in. Hope it helps.

    A few notes-

    I have disk permissions as being ignored on my ext hd. I have no clue how that affects things.

    My problem could still be a usb power problem. I let my ext hd rest for a few hours, and cool down, so that may be why it's working now. Hopefully not, and the fact that I can add large files to it gives me hope.

    Also, I recommend running every check in disk utilities on your main hd, and the ext hd that has the problem. I didn't run the repair disk on my main hd, but still it can't hurt.
  • CTitan Level 1 Level 1 (0 points)
    I should also mention that my ext hd doesn't get its power from my imac (at least I don't think so). It lights up only when plugged into the wall. And it wasn't overheating earlier.

    Also, I had to use the seagate drive manager for windows in parallels, and even though it was set for sleep interval in 5 minutes, changing it to never didn't help at all (it wasn't going to sleep, the light would stay on).

    And it just completed a 126mb 720p download, so I think it's probably fixed. It was having problems with 5mb downloads earlier.
  • tyke65 Level 1 Level 1 (0 points)
    I'm having this problem (MacBook Pro, ext WD powered from USB, Snow Leopard) but the cause seems simple - it may have already been mentioned in this topic but I didn't find it.
    All working OK, computer goes to sleep and WD powers down. Bring computer out of sleep and WD takes a bit longer to come alive so MB thinks it has been ejected. By the time I click 'OK' everything is working.
  • phlex4 Level 1 Level 1 (0 points)
    I'm running a late 2009 27" iMac with Drobo connected via USB. It has external power. Every time my computer goes to sleep I wake it up and my Drobo has been "ejected improperly" just like everyone else here.

    I have checked:

    Put the hard disc to sleep whenever possible
    Wake for network access
    Allow power button to put the computer to sleep

    I didn't have this issue with my G5 tower that I owned previously.
  • grunder Level 1 Level 1 (0 points)
    I'm also having this problem. It happened a few hours after I started using the drive.

    MacBookPro
    - OS X 10.6.4
    - Put drives to sleep whenever possible: on
    - Computer sleep: disabled
    - Time Machine enabled, but backup disk disconnected

    External Drive: Seagate FreeAgent 2TB
    - external power
    - no power switch (to set to auto)

    No message in the system logs at "eject" time, just the improper eject dialog, when I returned from dinner.

    Never seen this with my 1TB WD drives, or any of my smaller, more portable drives.
  • grunder Level 1 Level 1 (0 points)
    Well - it happened once, but not again in the next 12 hours. Computer was sleeping for most of that, but...I guess I'll take this drive into the field, for data collection.
  • Alistair Haimes Level 1 Level 1 (0 points)
    Me too. This is now happened to three different USB 2.0 drives running from all three USB ports over the past few weeks. The data on two of them has been completely fried to the extent that the computer doesn't even recognize the drive as mounted so it has been a full re-format job. Complete pain, the Mac now can't be trusted. I rue the day I ever updated to Snow Leopard, this was the start of all my woe.

    No problems with FireWire (Inshallah), but having lost so much data PCs are looking good again...
  • Darryl Yee1 Level 1 Level 1 (10 points)
    Just started happening with me within the past few weeks. Doesn't look like there's a solution yet. I've lost data and can't even reformat a couple drives.

    Happens with and without Time Machine.
    Happens while I am using the computer copying data to the drive.
    Happens when waking the computer from sleep.
    Happens with a USB hub.
    Happens with the drive plugged directly into a USB port on the Mac.
    Happens with WD Elements drives.
    Happens with drives in 3 different Thermaltake docking stations.
    Happens with 2 different Antec enclosures.
    Happens with an Addonics enclosure.
    Happens with a couple generic USB enclosures.
    It also happens with a Firewire enclosure.

    The common denominator seems to be my Mac. Whether it's software or hardware related is the question.
  • Darryl Yee1 Level 1 Level 1 (10 points)
    I don't know why it started all of a sudden. I'm pretty sure it all began shortly after updating to 10.6.5. I used to have complete faith in my system, but I've gone out and purchased drives the past few days to backup my backups.
  • cavenewt Level 2 Level 2 (345 points)
    cole7aff wrote:
    I have resorted to this: I am running a RAID mirroring two 320GB 7200 rpm drives in a sleek raid controller you can find in the link. It uses it's own external power source and it has yet to eject, since it is constantly mirroring the data the ejections can not cause corruption.


    I think what actually happens is that any corruption will also get mirrored to your second drive. But you are not having the eject problem anyway, you said.
Previous 1 3 4 5 6 7 Next