Previous 1 4 5 6 7 8 Next 137 Replies Latest reply: Mar 24, 2014 3:45 PM by charliefromelgin Go to original post
  • cavenewt Level 2 Level 2 (345 points)
    Reading this entire thread, I think there may be several things going on. Two different problems are described:

    1. Drives disconnecting during sleep (get the warning dialog on wake)
    2. Drives disconnecting spontaneously (get the warning dialog while working)

    I'm going to ignore #2, though it could be the cause of some of the cases of #1. Since I'm here on behalf of a few clients with problem #1 (I'm a Mac consultant) I'm going to ignore #2 (except to say I don't think it's a good idea to plug your external drive into a keyboard port.)

    It would be helpful to have the following information for those experiencing the warning dialog on wake:

    1. What brand of external, and whether it has its own power (AC adapter) or if it's bus-powered

    2. If it's been repartitioned (as GUID or APM) for Mac, and if not, if it has been reformatted (Mac OS Extended Journaled). It is possible to reformat as the latter but still have an underlying partition scheme of Master Boot Record (since most externals come set up for PCs). I've seen anomalous behavior in those cases. If you're using the drive for Time Machine, TM insists of repartitioning and reformatting for Mac, so you don't need to do it yourself. I'm wondering if using an external with PC formatting will cause more clashes with the Mac OS.

    3. Have you installed any of the drive utility software that came with the drive? (I never do, IMHO it's all crappy.)

    4. When you wake up the computer and get the warning dialog, does the drive still mount itself after a few moments? Or do you have to force it to remount? I think this is *the most* important question, because if it still remounts by itself, it might just mean that the OS is hasty in assuming it's been disconnected improperly.

    I've mostly seen these problems with WD and LaCie Neil Poultons, but my sample is skewed because those are the brands I usually buy. I gave up on the Neil Poultons because too many clients ended up with the drive unmounted for some reason without realizing it; I would see the blue light churning constantly as the drive struggled to remount, in which case simply power-recycling the drive would pop it back onto the desktop.

    Not directly related to the original question, but the first thing to consider with any drive issue is the actual health of the drive. Any drive that's 3+ years old is suspect, in my opinion. Unfortunately SMART tests don't usually work on externals (unless you can attach via eSATA), so you're stuck with things like lengthy surface scans for bad blocks.

    Message was edited by: cavenewt
  • Darryl Yee1 Level 1 Level 1 (10 points)
    I'm pretty sure I solved the problem - at least on my machine.
    Since I couldn't narrow the culprit down to a specific brand, device, or port I figured it had to be my Mac Pro. I reset the SMC and then zapped the PRAM a couple weeks ago and haven't had the problem since. I've had a Time Machine drive plugged into a USB port around the clock and it hasn't disconnected yet, even after waking from sleep.

    reset SMC: http://support.apple.com/kb/HT3964
    zap PRAM: http://docs.info.apple.com/article.html?path=Mac/10.6/en/26871.html

    hope it's not just a coincidence.
  • itwontletmeusemydesirednicknam Level 1 Level 1 (0 points)
    I had the same problems as most with random ejecting. What worked for me finally is i plugged it into a usb hub(mac wires keyboard with built in hub). It worked perfectly. After many hours of testing it worked wonderfully. Now its plugged directly and its still working. Try it for yourself and post your results.
  • itwontletmeusemydesirednicknam Level 1 Level 1 (0 points)
    I have found a solution for my situation. As I mentioned in my previous post, I plugged my external drive into a hub and it worked perfectly. Then I unplugged it from the hub after many different tests and plugged it in directly. I tested it by transferring very large files to and from my external to my internal. Then I made a backup to the external of my internal. Basically it has done everything without a problem yet.

    I am using 10.6.4. The external is a western digital 1TB ..I should mention it's formatted to NTFS as it was originally on my PC and has many files i need.
  • Alfred Luk Level 1 Level 1 (0 points)
    Plugging the drives into a USB hub works for me! I really have no idea why this trick works. It works both for my WD 500GB and LaCie 1TB. I tried to transfer very large files (about 100GB in total) from WD to LaCie without any problems. Though I haven't tried plugging them directly to my iMac after this.

    I have tried other methods discussed above, including the Spotlight one but all to no avail. This one works for me however. Thanks @itwontletmeusemydesirednicknam!

    Maybe I briefly describe my problems concerning this issue. Essentially my drives were unable to connect at all. I had to always force the disk to power off and restart my mac in order to connect the disks. Sometimes this even wouldn't work. The ejecting warning popped up whenever I turned on my mac. Plugging and unplugging simply didn't work as well. Even though sometimes I could connect my disks, the transfer of files would be interrupted. Very often this problem has caused me to force my mac to shut down many times already as the interruptions caused Finder not responding and the system couldn't be restarted or shut down.

    Hope this also works for some of you!
  • OmegaRed1723 Level 1 Level 1 (0 points)
    I was experiencing the spontaneous ejection issue with my Drobo connected to a Mac mini (running 10.6.5, now 10.6.6) via FW800. The Drobo was used for media storage only, not Time Machine. I have a WD MyBook connected to the same machine via USB that is used for Time Machine backup and never randomly ejected. It was not a sleep issue, nor a spotlight indexing problem. Sometimes the drive would eject while reading or writing data, other times it would simply disconnect while the machine was idle. Connecting the Drobo to a different Mac yielded the same results, i.e., spontaneous drive ejections.

    The console logs didn't yield a lot of information. No errors reported leading up to the ejection; only the message "disk2s2: media is not present". Disk Utility reported no problems with the disk(s) and permissions were all fine.

    Finally, I used Disk Warrior to examine the Drobo. It reported that the directory structure was out of whack. The utility was able to rebuild and replace the directory, after which I have experienced zero ejections in the past five days, which is five days longer than previously going between ejections. Obviously I'll continue to monitor things, but it appears Disk Warrior nipped the problem in the bud.
  • Wilkie IT Level 1 Level 1 (0 points)
    I updated to 10.6.6 on my minimac last night and this morning for the first time ever I got this exact issue.

    I have a Drobo attached to my system and was using iTunes to copy Podcasts onto my iPad, when all of a sudden I get this can't copy and disk ejected error message. Disabled spotlight for the entire Drobo no more issue.

    Hope it gets fixed soon
  • PGPG Level 1 Level 1 (0 points)
    I've a number of problems, started with disconnects somewhere around my hardware upgrade to 10.6.6 Drives disconnected, time machine mostly, machine wont shut down, programs freeze when trying to save. I can even open applications sometimes, dreaded spinning rainbow. Drives not recognized in apple keyboard usb, but in imac usb they are... My expensive computer seems more like a lemon than an Apple. Apple recommends an erase and install, after 3 months of operation, sounds like a bad upgrade.

    http://discussions.info.apple.com/thread.jspa?threadID=2644309&tstart=1
    http://discussions.info.apple.com/thread.jspa?threadID=2563197&tstart=45&message ID=13033864
  • SNPaine Level 1 Level 1 (0 points)
    Exact same type of problem as experienced by many others-- a 1 TB Seagate Expansion drive (PN 9SF2A4-500, wall-plug powered), which had been running TM backups perfectly under 10.5.8, would spontaneously disconnect after an upgrade to 10.6.6, on a Mac Pro. Typically, TM could write about 2 GB before the drive would disappear permanently until a USB unplug/plug cycle. None of the following had any effect on the problem:

    1. Changing USB ports
    2. Changing USB cable
    3. Trying a fresh-out-of-the-box identical model drive
    4. Using the Seagate Drive Settings tool (on Win XP) to turn off the sleep feature
    5. Enabling or disabling "Put the hard disk(s) to sleep when possible" in System Preferences-> Energy Saver
    6. SMC reset
    7. PRAM reset

    However, an older Western Digital Elements 320 GB USB drive (WD3200C035) pulled off the shelf works perfectly.
  • gperetz Level 1 Level 1 (10 points)
    I have a Seagate FreeAgent GoFlex Desk 2TB drive. Connected via the USB 3.0 dock (functioning on the iMac's native USB 2.0 ports), I have had good success and a stable connection -- it functions normally. However, I wanted to leverage the GoFlex capability to use another desktop dock, so I bought the FireWire 800 version, hoping for faster-than-USB speeds. While using it (the only FW800 device), I've been seeing the random disconnects as well. My computer is set not to go to sleep (just the display) and the hard drives are not allowed to spin down ("sleep when possible"). The random disconnect behavior has been consistent between 10.6.5-10.6.7 updates. The only workaround I've found is to create and run a shell script in the background:

    #!/bin/sh
    +while true+
    do
    +touch /Volumes/2TB/touchy.log+
    +sleep 600+
    done

    Basically, the script just generates a minimum of disk activity on a repeating basis. This seems to defeat whatever is timing out on the FireWire 800 bus and causing the disconnections. I've tried this at varying intervals, from every 30 sec. on up to the current 10 minutes and it seems to provide a stable connection to the drive. However, I don't like the "insomniac" nature of a continually spinning disk -- both for energy consumption and for drive wear that will shorten its lifespan. I would like to see this fixed properly, hopefully with the next 10.6 update.
  • Adam Randlett Level 1 Level 1 (100 points)
    I am experiencing the same issue with my Western Digital TM drive which will spontaneously eject. It happens more often after wakeup but will happen during backup. I have tried many of suggestions with no success.
  • julesfrombalmain Level 1 Level 1 (0 points)

    I am also experiencing this problem with my MBP running OSX 10.6.7, arghhhh .  I am using a 500GB LaCie drive.  Next Byte told me to buy a new drive, and they had never heard of the problem!!!

  • rick1630 Level 1 Level 1 (0 points)

    I have a brand new iMac i7 3.4GHz and connected a brand new external USB 2.0 WD 1.5TB Elements drive for Time Machine. It started up just fine, but almost immediately I stated noticing that after the Mac woke from sleep the TM drive disappeared. I got the same "disk ejected improperly" message that others get. The drive has AC power and I've tried it through a hub or direct connct to a USB port. No difference. I called Apple support, and they acted like it was a brand new, unheard of issue. Obviously from this thread that's not the case.

     

    At their recommendation I formatted a different external drive and switched it to be the Time Machine. This was a Maxtor USB 2.0 that I've used successfully for a couple of years on Windows. The first time it went through a sleep cycle, it got improperly ejected when the Mac woke up. I had left the WD drive connected as well, just not as the TM drive, and it also failed to wake up correctly. So the problem is not TimeMachine specific.

     

    Following a suggestion in this thread I judst excluded the TM drive from Spotlight searches. Will see if that makes a difference.

  • brebaje Level 1 Level 1 (0 points)

    April 2011 - I started using my WD Elements 1.5 TB as drive for my Time Machine backups with Leopard. Everything worked fine.

     

    April 2011 - I then upgrade my iMac to Snow Leopard and used my TM copies for restoring my data. Everything worked fine too.

     

    June 2011 - I erased all data on my drive and used the external WD as an old and simple backup drive. I then reinstalled Snow Leopard on my iMac and transfered all the files back to it (most of them at least, since some files gave me a read/copy error, error -36 if I remember correctly, first disappointment). I erased all data again in my external drive and intend to use it again as my Time Machine backup drive.

     

    Couldn't finish any of the first time backups I tried. Everytime either the drive (not likely, only 2 months since I bought it) or Snow Leopard hangs the copy process with a disconnect error. My external drive disappears from my OS and I have to unplug it and reboot in order to have it back again. I noticed the blue light in the back of the drive is still on while this happens.

     

    I think my Snow Leopard is responsible for both errors (copy/read error -36 from the drive and disconnect issue). I'm now trying again after excluding my WD from Spotlight searches. If this doesn't work I don't know what else to do, any thoughts?

     

    Sorry but english is not my primary language. Thanks.

  • rick1630 Level 1 Level 1 (0 points)

    Follow-up. 6/2011.  I relocated my WD drive and plugged it directly into an iMac USB port and the problem with it ejecting incorrectly after sleep mode simply went away. Could it really be that simple? When OS X wakes up it looks for the drive, but had to deal with my USB hub first, and it assumed the drive had been dismounted because it didn't respond quickly enough. To reach the iMac USB port I had to use an 3' extender USB cable and that did not create any issues at all.

Previous 1 4 5 6 7 8 Next