Previous 1 2 Next 28 Replies Latest reply: Sep 11, 2010 8:44 AM by JRE61
ryu_syd Level 1 Level 1 (0 points)
Any idea what this mean?
I have a Brother MFC 9440CN, but I cannot print anything! An error message of "Invalid format for short nick name" shows no matter what I try to print from Safari, Preview, Excel, etc. I have deleted the printer and re-adding it, but it still does not work. I have tried connecting it directly via USB as opposed to via my ethernet network. I have run Software update. I have checked Brother web site but can see nothing of any use. I have the same problem on both my desktop (a Mac Pro) and a laptop (MacBook Pro). Any suggestions?

Mac Pro, Mac OS X (10.6)
  • A A P L Level 7 Level 7 (21,730 points)
    What is the short-name of your Mac user account name?
  • moeg Level 1 Level 1 (55 points)
    Hi, ShortNickName is an entry in the ppd file (driver in this case) for your printer. I can suggest 2 solutions that may work for you. One of which is more destructive than the other...

    1. Non destructive - Is "Generic PCL Laser Printer" available to you as a choice in Add Printer
    From Print & Fax preferences select the + button.
    In the default list find the printer you are interested either connected thru USB or on your network.
    When you click on the "Print Using:" popup menu do you see "Generic PCL Laser Printer"?
    If so, select it, and in the Name text field enter "something other than you have for a name. Say, test.
    Click the Add button
    NOTE: this may complain that you have a printer by the same name - ignore that warning - You won't get that warning if you have deleted that printer before doing this

    Can you print?

    This should get you started.
  • ryu_syd Level 1 Level 1 (0 points)
    I have found the solution - essentially, delete all Brother software and run Software Update again.

    I think the problem is that older Brother software (including drivers) was creating the conflict. Therefore, the solution is to delete these software. The steps I follow, as far as I can remember the order:
    1. Goto /Library/Printers folder and delete the "Brother" folder
    2. Goto /Preference folder and delete the "Brother" folder (I don't think this is essential, but I delete this folder anyway.)
    3. Open Print & Fax in Preference and delete the Brother printer and then re-add them
    4. Run Software Update - this will then download and reinstall the now missing Brother drivers (those that were deleted under step 1)
    5. Restart the computer

    The printer now works!
  • TC brah Level 1 Level 1 (0 points)
    I found out a couple of things when I ran into this problem using the Brother MFC-885CW. (Initially I was able to print right after the upgrade to Snow Cat but had to reinstall Rosetta then the Brother ControlCenter software CD to get the scanner back up and running.) Anyway, when I tried to print after that I received the "Invalid format for short nick name" error message as well.

    First, apparently when you delete the Printer directly in Sys Pref: Print & Fax it automatically deletes the Library/Printer & Preference files.

    Second, in Print & Fax I clicked on the "+" Add button and then when the Add Printer window showed up I went to Print Using "Brother MFC-885CW CUPS v.1.1" rather than just Brother MFC-885CW CUPS. In other words, if you add printer (in my case) Brother MFC-885CW-1 instead of Brother MFC-885CW only it should print. Apparently the v1.1 and -1 suffix may be the key. (At this point, admittedly, I have not tried scanning again.) Hope that this helps... ; )
  • Saved By Grace Level 1 Level 1 (0 points)
    same thing happened to me. I tried Brother MFC - 9449CN BR-Script3 and it works.
  • billyox Level 1 Level 1 (0 points)
    I am having the same problem. i try everything uninstall the printer, reinstall printer and drivers and nothing happen only the same message again and again: error "invalid format for short nick name" please help me i'll appreciate your help. thanks
    p.d. my printer is brother 465CN.
  • JW_88 Level 1 Level 1 (0 points)
    Agreed - switching to the BR-Script worked for me, even when the CUPS drivers wouldnt work.
  • Yvonne O Bowers Level 1 Level 1 (20 points)
    I had the same problem with my MFC-9840CDW. I'm not sure exactly what the arcane message means but the fix for me was to install the "optional packages" "All Printer drivers" from the SL disk. After installing and restart, delete the printer and re-add the printer. Worked for me.
  • philonious Level 1 Level 1 (0 points)
    THANK you! This actually worked- just adding the same printer again did the trick.

    I noticed that the printer icon is the old 'standard' one from pre-Snow Leopard... the new driver (which I downloaded at least 3 times) that generates an icon that looks like my MFC 7440N didn't work, even after I installed the new OS 10.6.1 update which was supposed to address printer issues...
  • Sam Chow Level 1 Level 1 (0 points)
    Yeah, I had the same problem too with my MFC 240C.
    To fix the problem I selected the driver that had the v1.1 at the end.
  • weblady Level 1 Level 1 (0 points)
    This solution worked for me. Thanks so much.
  • andyruwilliams Level 1 Level 1 (0 points)
    Hi
    I got round this by :
    delete the printer in the printer fax settings pane
    click +
    this time set up the printer using the ip address tab ie not bonjour
    it offers the correct ip address for me so i set line printer daemon
    it automatically then sets for me (MFC 8870DW) cups driver
    Voila
    I tried all the above methods
    i deleted all the drivers
    downloaded the drivers from apple
    downloaded the drivers form brother
    messed everthing up for about 6 hours then came across the above method

    Works for me hope this helps
    :)))
    Andy
  • cantrade Level 1 Level 1 (0 points)
    I loaded the new drivers for the scanner and printer. They were placed on the Brother site on 9-7-2009. Then I reset the printers by using the right click method to clear the printers and reinstalled the whole mess and bingo!

    Don
  • bellepepper Level 1 Level 1 (0 points)
    I followed these but didn't even need to use the IP thing. I just deleted the printer, added it using the default tab, and chose the v1.1 option under "Print Using". Whole problem solved in about 3 minutes.
Previous 1 2 Next