Previous 1 2 Next 28 Replies Latest reply: Sep 11, 2010 8:44 AM by JRE61 Go to original post
  • JKenning Level 1 Level 1 (0 points)
    Funny... I had a similar experience trying to get my MacBook to talk to my MFC-885CW over IP. I had tried to use the newer CUPS driver package- the one for Snow Leopard- but ended up having to delete all of those drivers from the library and go for the v1.1 CUPS drivers. Apparently there's something fishy going on in the newer version; seems like a lot of people are using v1.1.

    Has anybody else found the CUPS 1.1 drivers to be excruciatingly slow??
  • Coffee13 Level 1 Level 1 (0 points)
    moeg, you rock. Your short fix solved my problem in about 2 minutes. I have a new borther MFC 7840W, currenty using a USB connection. All I had to do was use the "Generic PCL Laser Printer" fix you mentioned and voila, I am printing and scanning again, no problem!
  • Shalini Jerath Level 1 Level 1 (0 points)
    For anyone who has the patience to read all the responses and reach my response, I downloaded and installed the latest Brother driver for my printer from Brother.com as per the instructions on the download page and the problem is solved. Printer in question was MFC-685CW. The latest driver was the CUPS driver v1.1
  • Thomas Brown6 Level 1 Level 1 (0 points)
    Guys,

    Thanks a gabillion.

    I just changed the driver in the printer window under Printer Setup to "Generic" and the Brother MFC 7820N started printing again.
  • Mac:The overpriced,pretty PC Level 1 Level 1 (0 points)
    moeg,

    Where did you learn English? I cannot imagine that the instructions you've contributed make sense to anyone, including yourself.

    If you are either unwilling or unable to utilize basic language conventions so as to engender the understanding of your intended audience, please refrain from wasting both space and everyone else's time.

    The literate of the world thank you in advance.
  • DaddieMac Level 1 Level 1 (35 points)
    Another solution: for the Brother MFC-7440N, I went to the /Library/Printers/Brother/Utilities folder and ran "Install Utility," "Remote Setup," and "Brother Status Monitor." After doing that, then a new printer automatically showed up in my Print & Fax preference pane called "MFC-7440N" (instead of "Brother MFC-7440N" like the other ones that came when I added them from the drivers I downloaded from Brother's website). Under "Options & Supplies" it shows driver version 1.21, an older one. This came from the installation CD that shipped with the printer, as suggested in another thread here:
    http://discussions.apple.com/thread.jspa?threadID=2361313&tstart=0
    After I had installed the stuff of that CD then it still gave this message with the error "Invalid format for short nick name" but I was able to fix it by just running those utilities... I didn't have to delete, update, or reinstall anything, beyond just installing what was on the CD. <shrugs>
    Also note that if you go to your web browser and go to this URL: http://localhost:631/admin ... it lets you administer CUPS and there you can turn on an error logging feature by checking the box next to "Save debugging information for troubleshooting" ... to view your error log go to: http://localhost:631/admin/log/error_log? ... this can really help finding the error (search for the "error" text in your browser at that page, and copy-paste the error text into a search engine... that's how I found this thread).

    Hope this helps.

    I miss System 8.6. Never ONCE EVER EVER EVER EVER had a printing issue on Mac OS until this. EVER. That's from System 1.0 (literally) all the way thru 10.4 ... then came CUPS... and the nightmare began. I HATE CUPS!!
  • faeriemary Level 1 Level 1 (0 points)
    Okay, I can't believe what a pain this was to take care of!! Once I figured it out it was easy, but it took me like 2 hours to figure out what to do.

    I have a Brother MFC-7420 printer and it is not set up for networking. My computer is a MacBook with the 10.6 Snow Leopard OS.

    I put in the CD for the drivers, utilities and documentation for Macintosh, installed the software, and was thwarted at every turn when I tried to print. I kept getting the Invalid Format for Short Nick Name message. I tried many of the above solutions and none worked. Anyway, I finally found this most useful page on the Brother website: http://solutions.brother.com, which informed me that none of the drivers and utilities on my CD-ROM were compatible with a 10.6 OS (I bought the printer over a year ago). Then it gave me a link to download the ones I need, and very detailed instructions on how to install them! Here is the page: http://welcome.solutions.brother.com/BSC/public/us/us/en/faq/faq/000000/002600/0 00025/faq002625002.html?reg=us&c=us&lang=en&prod=mfc7420all&Cat=1
    You can download the CUPS printer driver and TWAIN scanner driver from this page.

    Relief!!
  • Nenad Bach Level 1 Level 1 (0 points)
    Thank you for your instructions. It worked perfectly.

    1. I did erase what you suggested
    2. Went under apple sign and click Software Update

    Miracle happened. All works.

    My model is MFC 7820N.

    Thank you again and to all those who take their time to help others
  • DCvincent Level 1 Level 1 (0 points)
    I have an MFC-7840W and was getting the nick name error. After reading several posts and mixing a couple of them together I believe I came up with the easiest fix. Install the printer as directed and you most likely will receive the "installation complete" message. If you try and print and receive the nick name error, click on your apple icon in the upper left, click on software update... Install the updates and when your computer restarts the printer will work.
  • d_a_calf Level 1 Level 1 (0 points)
    I did the same.
    Brother website, latest driver for MFC-440N, as per directions. Fixed.
  • Geertienz Level 1 Level 1 (0 points)
    After much frustration I found this forum and put my error to bed for good, Many thanks your solution worked perfectly
  • rani unique Level 1 Level 1 (0 points)
    i have a DCP-135c and after trying everything you guys have suggested i still can not get it to work. can you help me ?
  • LIZ BUCHER Level 1 Level 1 (10 points)
    Shalini Jerath wrote:
    For anyone who has the patience to read all the responses and reach my response, I downloaded and installed the latest Brother driver for my printer from Brother.com as per the instructions on the download page and the problem is solved. Printer in question was MFC-685CW. The latest driver was the CUPS driver v1.1


    This worked for me too although I ran the 'software update' after installing the printer to download the driver (it installed the driver v1.1) *but then* I had to go to the drivers in the printer and select "driver v1.1 CUPS. My printer is the MFC-465CN

    Thanks so much. I'm new to MAC, having used MS for years. This support board is so much better then what MS offers...why am I not surprised. I am so glad I switched to MAC.
  • JRE61 Level 1 Level 1 (0 points)
    Thank you. This worked for me.
Previous 1 2 Next