Previous 1 9 10 11 12 13 14 Next 199 Replies Latest reply: Apr 8, 2010 8:35 PM by Robert Bosch Go to original post
  • Sebastian0883 Level 1 (0 points)
    I'm experiencing the same problem as described above: I get -36 errors when trying to write to my pendrive which is in FAT32. I never had problems before. So then I tried to copy a folder with Word files which I created on a PC to my WD external drive, and the same -36 error occurred.
    The funny thing is that some folders with files unrelated to a PC copy just fine. Especially the folder that I created on a PC and copied to my Mac via a pendrive (which, a couple of weeks ago, worked just fine), does not copy to a pendrive.

    Then I had the same problem with copying a folder full of newly created mp3s; to and from the pendrive would give a -36 error. Since I have recently installed Dropbox on my computer, I uninstalled it, did a clean restart and then the folder with mp3s copied fine to and from my FAT pendrive. But the problem with the specific folder full of PC-created wordfiles continued!

    I'm just very confused... I really hope 10.6.3 fixes this, and that the update comes soon!
  • CarCode Level 1 (0 points)
    It is amusing what William Kucharski writes.
    Apple introduce a new OS version and things which have worked before does not work anymore. Now the users should find the bugs or what? Are the users developers? Do they get beta versions for testing?
    I am very confused about this message of William.
  • William Kucharski Level 6 (14,985 points)
    I'm glad you find my posts so amusing.

    The bottom line is, these are user-to-user forums, Apple engineers do not officially read them or reply to posts here except on their own time.

    If you want an official response from Apple to an issue, you must contact AppleCare or join ADC and file a bug report.

    Apple tests their software extensively. There are literally tens of thousands of ADC developers who test new releases along with those recruited explicitly to beta test software, both major releases and individual OS updates, such as 10.6.1, 10.6.2, etc.

    But of course, testing doesn't catch everything, and when issues arise, they need to be reported to Apple, and (once again) AppleCare and the *Bug Reporter* are the mechanisms through which that happens.

    So what, precisely, have I said that is confusing and/or amusing to you?

    Complaining about an issue in these forums is like asking a big group of friends if they know how to fix an issue or if they're seeing the same problems. But asking why Apple doesn't take notice and do something is like having a problem with your car and being mad at its manufacturer for not fixing it without ever taking it into the dealer to be looked at - cathartic perhaps but not an effective way of arriving at a solution.
  • dsjokvis Level 1 (0 points)
    Dear all!
    First of all gentlemen have you searched the net for this problem with -36 error.

    1. Have you defined if it's a Windows error or an OS X error?
    2. Have you defined if it's a Windows driver error or not?

    I my self wrote on this discussion thread a long time ago and got help and was able to find a work around. My problem was not error - 36. It was SMB (Samba) and OS X together. Nothing to do with Windows. But in the same time it was.
    The error 36 is usually a hardware problem. That will say a driver problem. Look for the proper drivers or new/changed drivers.

    We have on the other concluded that their is a bug within 10.6.2 between OS X and SMB 3.0 - 3.3.4 which builds on Windows. For exemple on Linux servers we use SMB as the Windows communication shell. We create shares and users for Windows and for Macs to use their common networking shares and applications.
    If that isn't working properly a lot of companies with Linux servers and MACs have problems.
    With 10.6.2 a lot of companies have to have workarounds for Office for MAC, for example. So, the problem is not error 36. It's SMB(Samba) (Windows (not Netbios)) and OS X10.6.2.

    I personally have my MACs connected to Linux servers with SMB and they are working fine as long as I'm not saving Excel work sheets directly to my share.
    I instead save it to my work space and afterwords copy it to my share.

    To conclude. Both my MACs ar connected to hardware's that keep my backups via TimeShare. One is a IOmega drive and the other is a Netgear ReadyNas. They both works fine under 10.6.2. Both my MACs are also connected to my Linux Server with Suse Linux Enterprise Server 10.3. That's my problem where I cannot save directly to my share without saving to workspace first and then copying. I can live with it for the time beeing but I am certain that Apple already knows what the problem is and that they will solve it in the next upgrade.

    Best regards
    Dag S.
  • CarCode Level 1 (0 points)
    When it has worked before with Leopard and after updating to Snow-Leopard without changing anything else it does not work anymore, it will be obviously a bug in Snow-Leopard.

    Furthermore using muCommander with Snow-Leopard I am able to launch a file from the NAS as before without any problem, but launching the same file with Finder I get error -36.

    So what?

    By the way who is William? Does he belongs to the Apple staff?
    So why he does not post something like: Yes, the bug is known and Apple works for an update.
  • William Kucharski Level 6 (14,985 points)
    CarCode wrote:
    By the way who is William? Does he belongs to the Apple staff?
    So why he does not post something like: Yes, the bug is known and Apple works for an update.

    I'm just a user like you - I do not now nor never have worked for Apple.

    If you want to know whether Apple knows about the issue and/or is working on it, for the third time contact AppleCare or join ADC and file a bug report.
  • man overboard Level 1 (0 points)
    Thanks for the tip on muCommander. From this discussion thread, the problem with NAS drives using SMB appears to have been introduced in a recent release and that Apple is aware of the problem.

    In my configuration, I can write to the drive but the write fails after creating a zero byte file. Could be very dangerous copying back.

    muCommander provides me with a partial work around pending a new release to fix the problem. At this point, my take is to wait for the next release before investing additional hours.
  • CarCode Level 1 (0 points)
    I guess it might be a problem with different Samba (smb) versions. Samba runs on several computers in my network, but I cannot change the version on the NAS. With Snow-Leopard the special Apple Samba version has changed. Perhaps some config commands in the Apple Samba config file may solve the problem, but Apples Samba documentation is rather poor and I do not have the time to dig further into it.
    Facts are that it has worked sufficient with Leopard and failed with the Snow-Leopard update.
  • Lakefront Level 1 (0 points)
    I had a similar problem when trying to merge an iphoto library from my laptop to my desktop using iPhoto Library Manager. The solution I found was to make sure that I connected to my laptop as a user using an account with write permission, rather than as a guest. Even though I had set permissions for my iphoto library on my laptop to read/write for everyone, accessing the laptop over my network as a guest still resulted in the -36 error when I tried to merge the libraries. It was only when I connected to the laptop as a user that I was able to merge without the error. I found this solution on Fat Cat's website at
  • fakeollie Level 1 (0 points)
    I'm not sure if anyone have already posted this (long thread), but here's how I learned to remedy Error code -36 issues. The problem, I've found is when you copy files from non-apple formatted (HFS) devices (FAT32 windows drives, thumbdrives, smb or nsf network shares etc) into a Mac and then at some later point try to copy them back into those non-HFS devices.

    It's something to do with the ._ files that get generated and then not properly restored. The solution I've found whenever an Error code -36 error appears is to open the troublesome folder (or folder containing the files) that Finder refuses to copy in a Terminal, run the command dot_clean and then try the copy again. It always works.
  • jaredddddd Level 1 (0 points)
    William, please.
    Submitting a bug report to Apple does not help me with this issue. I'm quite sure without bug reports Apple would still know about this issue as well. Even still, to answer your question. Yes, I have contacted Apple...and nothing. It's another problem with Snow Leopard and I am guessing certain drives. Problem is, I am having this problem too. It's pretty bad when there are over 10 pages of this stuff and this question still has not been answered. As much as people want to say Apple has nothing to do with these forums is complete bs as well. This *****.
  • Awfers Level 1 (75 points)
    I have exactly the same problem. Files downloaded from an FTP server, copied from a PB 12" running 10.5, copied to a USB key, then copied to a Windows network server, then recopied to a USB key..

    And then I copy it to from the USB to my 15.4" running 10.6, and then copy it back to the USB key.... error code -36 on some files that I never even touched/modified using the 10.6 machine...

    I can't even delete them from the trash and there's a "read/write error".. or "file is currently in use" which is BS as I've just rebooted...

    Very, very frustrating
  • fakeollie Level 1 (0 points)
    Alright, here's a step-by-step of the workaround I've described in my last message. So, you've just tried dragging some files somewhere else and got an Error code -36. Try this:

    1) Open terminal. Applications > Utilities > Terminal

    2) In terminal type: dot_clean <space> (Don't type the word <space>, just press the space bar)

    3) Drag the folder you're trying to copy/move inside the terminal window
    (if you're trying to copy just a few files and not a whole folder, nevertheless drag the folder they're in, not the files themselves. if said folder is open in finder, you can drag this little icon on top of the window: )

    4) Notice how your terminal line now reads: dot_clean /full/address/of-your/folder (press ENTER now to run that command)

    5) Now just try copying those files again. It will work.

    All you've done was using the command dot_clean to clean all hidden dot-underscore files. They are OS X specific, and not used by other systems, cleaning them will not harm your data. 10.6 Somehow doesn't properly handle these resource fork files (hidden dot-underscore files) when files are copied to/from non-Apple partitions and then later back to them.

    It's not a mystery, not a windows error, not a driver error, it's just a Finder bug introduced in 10.6 and I'm sure the mothership is aware of it and it'll probably go away on 10.6.3. Meanwhile, here's a workaround for you.
  • coldrick Level 1 (0 points)
    Nope, still doesn't work for me after the dot_clean
  • Weallstoned Level 1 (0 points)
    Doesn't work for me either. I STILL cannot open any files stored on my LAN drive (connected via smb). If I try to open a photo, listen to an MP3 or view a video, I get the -36 error. Before Snow Leopard, this worked fine. Ho hum....